Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Many-to-One NAT configuration

Trying to configure a many-to-one NAT on a Cisco 3845 router running 12.4-7 IOS. I've configured:

ip nat pool Temp 10.11.12.13 10.11.12.13 netmask 255.255.255.255

ip nat inside source list 20 pool Temp overload

!

access-list 20 remark NAT Traffic

access-list 20 permit 10.10.0.0 0.0.255.255

access-list 20 permit 10.20.0.0 0.0.255.255

With the above configuration I'm trying to get all traffic from 10.10.0.0/16 & 10.20.0.0/16 NAT'd to 10.11.12.13. My only concern is whilst configuring the MAT pool, when I specify the /32 netmask, I receive an error specifying the netmask is too large. Should I be using a different netmask, even though I've specified the start and end addresses as the same?

I've not yet had time to build the above configuration in the lab, would some NAT experts be able to share their knowledge?

Thanks

8 REPLIES

Re: Many-to-One NAT configuration

HI

U need to enter the correct mask which is given to u.

And have u configured the proper nat statments under the interfaces ie ip nat inside and ip nat outside.

Thanks

Mahmood

New Member

Re: Many-to-One NAT configuration

Hi ,

if it only one ip address has to be used for translation ..then u can configure withput nat pool command

ip nat inside source list 20 10.11.12.13 overload

HTH

Regards,

Rajesh

New Member

Re: Many-to-One NAT configuration

Thanks for the responses

'ip nat inside source list 20 10.11.12.13 overload' is not configurable as a command, after entering source list 20, I can only configure interface or pool afterwards.

With regard to the netmask configured on the pool command, I've currently configured with a /32 which kicks up an error, should I be using /8 or /24 ?

Thanks

New Member

Re: Many-to-One NAT configuration

Try /31

New Member

Re: Many-to-One NAT configuration

you cannot configure a 32 bit mask. Use a smaller mask and you will be okay. It will not affect your NAT.

New Member

Re: Many-to-One NAT configuration

Hi

be specific with your nat ouside interface wheather it is one or two interface. has your inside interface is class B /16. use the below command

ip nat pool test 10.11.12.13 10.11.12.13 netmask 255.255.0.0

Thanks

New Member

Re: Many-to-One NAT configuration

try the following config:

interface loopback 1

ip address 10.11.12.13 255.255.255.255

ip nat outside

ip nat inside source list 20 interface loopback 1 overload

Leonard

New Member

Re: Many-to-One NAT configuration

Hi Daniel...

If you want to use two Public Ip Address,then command will be like this...

ip nat pool Temp 10.11.12.13 10.11.12.14 netmask 255.255.0.0

ip nat inside source list 20 pool Temp overload

!

access-list 20 remark NAT Traffic

access-list 20 permit 10.10.0.0 0.0.255.255

access-list 20 permit 10.20.0.0 0.0.255.255

Second if you want to go with single public Ip address..

Then command are....

ip nat inside source list 1 s1 overload

!

access-list 20 remark NAT Traffic

access-list 20 permit 10.10.0.0 0.0.255.255

access-list 20 permit 10.20.0.0 0.0.255.255

Give your public ip on serial 1 interface..

Hope it helps..

Rate the post if find it useful...

Thanks

Mahi

6008
Views
9
Helpful
8
Replies
CreatePlease login to create content