Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

MCAST, BGP and Inter-Domain MSDP

Hello,

Im trying out a new lab witch is working fine for the first 3 min, after my VLC IGMP join, then my traffic is getting Pruned and dont know why.

I can see that my VLC host is still sending IGMP join reports for the channel.

It works perfectly >3min if directly connect the 2x L3 swithes (SW1 and SW2) and make an BGP peering between them.

AS65008 and AS65009 routers are multicast-routing enabled and have ip pim sparse-dense mode enabled on there link interfaces.

SW1 config:

--

interface FastEthernet0/15

no switchport

ip address 10.250.0.1 255.255.255.0

ip pim sparse-dense-mode

!

interface FastEthernet0/16

no switchport

ip address 10.250.1.1 255.255.255.0

ip pim sparse-dense-mode

!

interface FastEthernet0/18

no switchport

ip address 10.250.10.1 255.255.255.0

ip pim sparse-dense-mode

!

interface Loopback0

ip address 10.250.21.1 255.255.255.255

!

!

ip multicast-routing distributed

!

ip pim rp-address 10.250.21.1

ip msdp peer 10.250.22.1 connect-source Loopback0 remote-as 65002

ip msdp cache-sa-state

ip msdp originator-id Loopback0

!

!

router bgp 65001

no synchronization

bgp log-neighbor-changes

network 10.250.0.0 mask 255.255.255.0

network 10.250.1.0 mask 255.255.255.0

network 10.250.10.0 mask 255.255.255.0

!network 10.250.13.0 mask 255.255.255.0

network 10.250.21.1 mask 255.255.255.255

neighbor 10.250.0.2 remote-as 65008

neighbor 10.250.1.2 remote-as 65009

!neighbor 10.250.13.2 remote-as 65002

no auto-summary

--

SW1#sh ip bgp

*  10.250.11.0/24   10.250.1.2                             0 65009 65002 i

*>                  10.250.0.2                             0 65008 65002 i

*  10.250.22.1/32   10.250.1.2                             0 65009 65002 i

*>                  10.250.0.2                             0 65008 65002 i

--

SW1#sh ip mroute

(*, 233.0.0.1), 00:06:32/stopped, RP 10.250.21.1, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    FastEthernet0/18, Forward/Sparse-Dense, 00:06:32/00:02:32

(10.250.11.2, 233.0.0.1), 00:06:32/00:01:59, flags: MT

  Incoming interface: FastEthernet0/15, RPF nbr 10.250.0.2

  Outgoing interface list:

    FastEthernet0/18, Forward/Sparse-Dense, 00:06:32/00:02:32

--

SW2

--

interface FastEthernet0/15

no switchport

ip address 10.250.2.1 255.255.255.0

ip pim sparse-dense-mode

!

interface FastEthernet0/16

no switchport

ip address 10.250.3.1 255.255.255.0

ip pim sparse-dense-mode

!

interface FastEthernet0/18

no switchport

ip address 10.250.11.1 255.255.255.0

ip pim sparse-dense-mode

!

interface Loopback0

ip address 10.250.22.1 255.255.255.255

!

!

ip multicast-routing distributed

!

!

router bgp 65002

no synchronization

bgp log-neighbor-changes

network 10.250.2.0 mask 255.255.255.0

network 10.250.3.0 mask 255.255.255.0

network 10.250.11.0 mask 255.255.255.0

!network 10.250.13.0 mask 255.255.255.0

network 10.250.22.1 mask 255.255.255.255

neighbor 10.250.2.2 remote-as 65008

neighbor 10.250.3.2 remote-as 65009

!neighbor 10.250.13.1 remote-as 65001

no auto-summary

!

!

ip pim rp-address 10.250.22.1

ip msdp peer 10.250.21.1 connect-source Loopback0 remote-as 65001

ip msdp cache-sa-state

ip msdp originator-id Loopback0

--

When my traffic is getting pruned:

SW1#sh ip mroute

(*, 233.0.0.1), 00:10:22/stopped, RP 10.250.21.1, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    FastEthernet0/18, Forward/Sparse-Dense, 00:10:22/00:02:11

(10.250.11.2, 233.0.0.1), 00:04:37/00:01:34, flags: MT

  Incoming interface: FastEthernet0/15, RPF nbr 10.250.0.2

  Outgoing interface list:

    FastEthernet0/18, Forward/Sparse-Dense, 00:04:37/00:02:11

--

SW1#sh ip msdp sa-cache

MSDP Source-Active Cache - 1 entries

(10.250.11.2, 233.0.0.1), RP 10.250.22.1, BGP/AS 65002, 02:09:00/00:05:28, Peer 10.250.22.1

--

SW2#sh ip mroute

(*, 233.0.0.1), 01:13:13/stopped, RP 10.250.22.1, flags: SP

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list: Null

(10.250.11.2, 233.0.0.1), 01:13:13/00:02:53, flags: PTA

  Incoming interface: FastEthernet0/18, RPF nbr 0.0.0.0

  Outgoing interface list: Null

--

SW2#sh ip rpf 10.250.10.2

RPF information for ? (10.250.10.2)

  RPF interface: FastEthernet0/15

  RPF neighbor: ? (10.250.2.2)

  RPF route/mask: 10.250.10.0/24

  RPF type: unicast (bgp 65002)

  RPF recursion count: 0

  Doing distance-preferred lookups across tables

--

SW2#sh ip msdp sa-cache

MSDP Source-Active Cache - 0 entries

Under all this, the 2 VLC players can ping each other all the time, no packet loss.

Lo0 can ping each other also.

Hope any one have an input ....

Cheers Martin

10 REPLIES
VIP Super Bronze

MCAST, BGP and Inter-Domain MSDP

What IGP are you using OSPF, ISIS, RIP etc...?

New Member

MCAST, BGP and Inter-Domain MSDP

Hello Reza,

Im not running any IGP, have included my top. drawing in PDF.

Annon. my LAN net in BGP + it is working the first 3 min :-) then it is Pruned.

Cheers Martin

MCAST, BGP and Inter-Domain MSDP

Have a look at the below documents I posted on CSC which may be useful for your lab setup

https://supportforums.cisco.com/docs/DOC-8293

https://supportforums.cisco.com/docs/DOC-8375

Hope this help

New Member

MCAST, BGP and Inter-Domain MSDP

Hello Marwan,

I know your posts, top $$$ i must say. My test lab is build based on your config :-)

Know i have forgotten to enable sparse-dense mode on the Lo0 interfaces but can this do

that after 3min of working mcast, my traffic is Pruned ??

Martin

Re: MCAST, BGP and Inter-Domain MSDP

Try to disable mcast SPF !

Sent from Cisco Technical Support iPhone App

New Member

Re: MCAST, BGP and Inter-Domain MSDP

Hello,

As65008 and 9 has to run there own RP right? but is it nessary for as65001 and as65002 to MSDP Peer with 8 and 9 or is it enough with my Peer between 1 and 2??

Sent from Cisco Technical Support iPad App

Re: MCAST, BGP and Inter-Domain MSDP

Well it's all about what you

Want to achieve msdp is used to exchange multicast sources info between different multicast domains

And at the same time your underlaying infrastructure has to support pass mcast traffic

And sometimes msdp used for redundant RPs but it is not in your lab topology case

See the below link for some more details

http://www.cisco.com/en/US/docs/ios/solutions_docs/ip_multicast/Phase_1/mcst_p1.html

Hope this help

New Member

Re: MCAST, BGP and Inter-Domain MSDP

Got it up and running.

Had to msdp peer A-to-B and B-to-C and not A-to-C :-) Not the way i wanted but okey, it works now

Cheers and thx

MCAST, BGP and Inter-Domain MSDP

Glad to know that

Do you mean younset up the switches and the routers as msdp peers

In a full mesh topology ?

It dose make sense as immentioned above it used for edge devices between different multicast domains and as described in cisco link above

New Member

Re: MCAST, BGP and Inter-Domain MSDP

Yea, the switch A and router B is msdp peering. Switch C is msdp peered with router B. Router/AS B is an isp so i didnt want to msdp Peer with them, thats why i wanted A and C talken together directly.

Sent from Cisco Technical Support iPad App

803
Views
0
Helpful
10
Replies
CreatePlease to create content