Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

mGRE-mGRE tunnels with static routes

I have a bunch of 172.15.0.X /29 networks (17 at present time) that I want to interconnect in a full-meshed fashion using mGRE. As an edge devices I have Cisco851 routers. From various sources I gathered that I have to use VRF so that the tunnel knows where to send encapsulated data. And this is where my confusion starts. Here is what I do:

ip vrf tstvrf

rd 1:1

interface Tunnel10

ip vrf forwarding tstvrf

ip address 192.168.10.1 255.255.255.0

no ip redirects

keepalive 1 100

tunnel source FastEthernet4

tunnel mode gre multipoint

tunnel key 123

interface FastEthernet4

ip address 172.15.0.145 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

ip route vrf tstvrf 0.0.0.0 0.0.0.0 Tunnel10 172.15.0.233 global

ip route 172.15.0.0 255.255.255.0 172.15.0.150 ! next hop gateway

Where 172.15.0.233 is the address of another Cisco851 that also terminates mGRE.

ping 172.15.0.233 sou 172.15.0.145

Sending 5, 100-byte ICMP Echos to 172.15.0.233, timeout is 2 seconds:

Packet sent with a source address of 172.15.0.145

!!!!!

Tunnels do not work except for the case when I use pair mGRE-GRE. Here I see only one-way data flow from GRE to mGRE.

Some of the examples show mGRE with nhrp others with BGP4. Cisco851 have nether of them and tend to use static routes for the starters.

How can you help me?

1 REPLY
New Member

Re: mGRE-mGRE tunnels with static routes

New fw (c850-advsecurityk9-mz.124-15.T1) has nhrt for mGRE so the problem is solved.

369
Views
0
Helpful
1
Replies