Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Migration/Configuration IPv6

Hi I am migrating from IPv4 to IPv6, my current configuration of my Internet router is:

access-list 50 permit 192.168.100.0 0.0.0.255

interface FastEthernet0
description ***WAN***
ip address 190.119.172.200 255.255.255.248
ip nat outside
speed 100
full-duplex

interface Vlan1
description ***LAN***
ip address 192.168.100.1 255.255.255.0
ip nat inside

ip nat inside source list 50 interface FastEthernet0 overload

ip route 0.0.0.0 0.0.0.0 190.196.17.201

My new addressing network IPv6 is: IPv6: 2800:160:18ff:0:0:0:0

I need enter this commands?:

ipv6 cef
ipv6 unicast-routing

ipv6 route ::/0  fastethernet0

interface fastethernet0

ipv6 address 2800:160:18ff:2/64

interface Vlan1
ip address 192.168.100.1 255.255.255.0

Is that correct?
How is the NAT configuration con inside ipv4 and outside ipv6?
Thank you very much

1 REPLY
Bronze

Re: Migration/Configuration IPv6

Dear Thomas ,

I prefer to get another IPv6 /64 class for your internal network and configure the same on your VLAN sub interface .This way your network will become as Dual stack  and assigning EUI-64- IPv6 address to VLAN interface will help the users in your LAN to get IPv6 address automatically for IPv6 enabled hosts

interface vlan 1
ipv6 address XX:XX:XX::/64 eui-64

If you need to configure NAT between IPv6 and IPv4  please refer the attached slide and let mw know how it goes .

Please rate if this helps

Regards,

Haris

178
Views
0
Helpful
1
Replies