Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

migration from 1760 to router 1841

Hello dears

kindly,i have the following qoustion regarding migration from (router 1760 and switch 3550 and DHCP server) to (router 1841 with normal hub and switch)

my Qoustion is how the configuration will bebecame ,since its the first time i deal with this router 1841

your support are highly appriacated

note :- the attach file show the past configratio for router and the switch

5 REPLIES
Hall of Fame Super Silver

Re: migration from 1760 to router 1841

Hello Rashid,

configuration of router can be quite similar.

Here the point of attention is the change on the switch part.

You say : >> migration from (router 1760 and switch 3550 and DHCP server) to (router 1841 with normal hub and switch)

if you mean you want to use an unmanaged switch or hub there are some changes needed.

with an unmanaged switch you cannot assume it knows about vlan2 and vlan100 you are currently using.

Or the device can be configured and you can use two vlans, trunk port and vlan subinterfaces as you are doing now or the device supports a single vlan like an hub.

In the latter case you need two unmanaged switches one for current vlan2 and one for current vlan 100.

This requires you to configure two physical ports as the current subinterfaces of the C1760.

you need to go from:

interface FastEthernet0/0.1
encapsulation dot1Q 2
ip address 10.3.2.254 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 100
ip address 10.200.6.1 255.255.255.0
!

to

int f0/0

desc to siwtch1

ip address 10.3.2.254 255.255.255.0

int f0/1

desc to switch2

ip address 10.200.6.1 255.255.255.0

also notice that you cannot use the voice vlan concept, this means you need to connect PCs to first switch and phones to switch2.

Hope to help

Giuseppe

New Member

Re: migration from 1760 to router 1841

dear Giuseppe

kindly , i have only one unmanage switch thats right, but i want to get benefit from the 4 ports in 1841 router to operate Voice and Data

thanks

Hall of Fame Super Silver

Re: migration from 1760 to router 1841

Hello Rashid,

if your C1841 has an etherswitch module installed with 4 ports you can use three for phones and one towards the unmanaged switch, PCs can be connected to the unmanaged switch.

the three ports of etherswitch module can be configured with a data vlan and voice vlan as in a regular standalone Cisco Lan switch

in this case you need to do the following:

a) create L2 vlans on etherswitch module

this may require to enter vlan database config mode

router#vlan database

router(vlan)#vlan 2

                 name datavlan

                 vlan 100

                 name voicevlan

                 apply

                 exit

now you can create SVI, L3 interfaces for vlan 2 and vlan 100

router#config t

int vlan 2

! data vlan subnet here

ip address  ...

no shut

int vlan 100

! voice vlan subnet here

ip address ...

no shut

single ports can be configured as switch ports with

int f0/x

switchport

switchport mode access

switchport voice vlan 100

swtchport access vlan 2

no shut

Hope to help

Giuseppe

New Member

Re: migration from 1760 to router 1841

Dear Giuseppe

thanks for you replay

your notes was benefit to me ,anyhow VOICE and data are working according to the below configuration

no ip dhcp use vrf connected

!

ip dhcp pool ASIACELL-data-Pool

   network 10.4.6.0 255.255.255.0

   default-router 10.4.6.254

   dns-server 192.168.163.1 192.168.163.30

   domain-name asiacell.com

   option 150 ip 10.200.128.10

!

controller E1 0/0/0

channel-group 0 timeslots 1-31

!

controller E1 0/0/1

channel-group 0 timeslots 1-31

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

switchport access vlan 2

!

interface FastEthernet0/1/1

switchport access vlan 2

!

interface FastEthernet0/1/2

switchport access vlan 2

!

interface FastEthernet0/1/3

switchport access vlan 2

!

interface Serial0/0/0:0

ip address 10.254.2.202 255.255.255.252

encapsulation ppp

!

interface Serial0/0/1:0

no ip address

encapsulation ppp

!

interface Vlan1

no ip address

!

interface Vlan2

ip address 10.4.6.254 255.255.255.0

!

!

router eigrp 100

redistribute static

network 10.0.0.0

no auto-summary

!

end

where I make one DHCP in the router with one subnet(it give ip address for ip phone and pc). And delete V Lan 100 voice

Anyhow my questions now are:-

1-      The above configuration work but how can I return the VLan 100(subnet voice) with the cmd switchport voice vlan 100 since when I try to make separate DHCP pool for voice, the rest fastethernet port go down and data go down the pool was

   ip dhcp Voice-Pool

   network 10.200.130.0 255.255.255.0

   default-router 10.200.130.254

   option 150 ip 10.200.128.10  

   dns-server 192.168.163.1 192.168.163.30

2-      for the first comments from you side :how the configuration will be done if make the DHCPS for voice and data in the router ?and how I can do connect if I using DHCP server for the two unmanaged switch

BEST regards

RASHID 

Hall of Fame Super Silver

Re: migration from 1760 to router 1841

Hello Rashid,

as I've explained you need first to create vlan100 as a L2 broadcast domain.

This can be done or in the vlan database context or in config context this depends on your IOS version and what etherswitch model you have.

For your reference I put the following link about etherswitch configuration in 12.4T

http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_hwic_ethsw_ic_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1046684

Also be aware that vlan database cannot be exited using CRTL-Z but you need to type exit because changes become effective only after apply or exit command

attempting to assign etherswitch ports to a non existent vlan causes the ports to be placed in a disabled state.

So the key point should be to find the correct way to create L2 object vlan100.

Once that this is done all should work.

interface Vlan100 is the L3 object that can be up/up only if L2 object exists.

This creates some confusion sometimes. It is important to see the difference between the two objects.

the second DHCP pool can be created with no problems, remember to exclude router ip address in SVI vlan 100

Hope to help

Giuseppe

938
Views
0
Helpful
5
Replies
CreatePlease to create content