Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Missing a route?

Hello,

I have created a new VLAN on a HP 3550 and use a 1941 router. the setup seems fairly straight forward

I have set the following configuration

On the switch -192.168.1.37 255.255.255.0

exit

ip default-gateway 192.168.1.1

ip routing

vlan 1   name "DEFAULT_VLAN"

untagged 1-36,38-48

ip address 192.168.1.37 255.255.255.0

no untagged 37

jumbo

ip igmp 

exit

vlan 2

name "VLAN 2"  

untagged 37  

ip address 192.168.0.1 255.255.255.0

exit

on the router – 192.168.1.1 255.255.255.0

ip route 192.168.0.0 255.255.255.0 192.168.1.37

client ip address 192.168.0.4 255.255.255.0 GW 192.168.0.1

ping 192.168.0.1 from switch - success

ping 192.168.0.4 from switch - success

ping 192.168.0.1 from router - success

ping 192.168.0.4 from router – success

ping 192.168.0.1 from 192.168.1.113 on VLAN 1 -success

ping 192.168.0.4 from 192.168.1.113 on VLAN 1– success

ping 192.168.1.1 from client on VLAN 2 – success

ping 192.168.1.118 from client  on VLAN 2– success

ping www.google.com from client on VLAN 2– fails

There is no internet access for the client on VLAN 2 , although the client can ping the router, and the router can ping the client, what am I missing?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Missing a route?

Hello Roger,

the router configuration looks like fine.

A point to be checked is the following:

the HP 3550 switch has a default route pointing to C1941 internal IP address 192.168.1.1?

you have used ip default-gateway. In cisco world that would be a command effective only when ip routing is disabled and you have also enabled ip routing on the HP switch. This is correct so the question might be providing an effective default route to the HP switch.

the cisco syntax for a static default route is

ip route 0.0.0.0 0.0.0.0 192.168.1.1

I would try to add a static route on the HP using the appropriate syntax

Hope to help

Giuseppe

4 REPLIES
Hall of Fame Super Silver

Missing a route?

Hello Roger,

likely a NAT configuration is missing so that the IP address 192.168.0.X are translated when accessing the internet.

Actually 192.168.0.0/24 and 192.168.1.0/24 are private addresses per RFC 1918. Your router should have two statements like the following:

ip nat inside source list 1 interface GigabitEthernet0/1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

all you need is to add a line to the access list to make VLAN2 IP subnet to be translated:

config t

access-list 1 permit 192.168.0.0 0.0.0.255

WARNING: your network setup may be more complex then this you may need to use NAT only towards internet but the idea is the same

Hope to help

Giuseppe

New Member

Re: Missing a route?

Hello Giuseppe,

Thank you for your assistance.  I have changed the ACL to permit all traffic, but still cannot connect to the internet from VLAN 2,  I have attached the router configuration.  Not sure what is happening here!!

Best Regards, Roger

Hall of Fame Super Silver

Re: Missing a route?

Hello Roger,

the router configuration looks like fine.

A point to be checked is the following:

the HP 3550 switch has a default route pointing to C1941 internal IP address 192.168.1.1?

you have used ip default-gateway. In cisco world that would be a command effective only when ip routing is disabled and you have also enabled ip routing on the HP switch. This is correct so the question might be providing an effective default route to the HP switch.

the cisco syntax for a static default route is

ip route 0.0.0.0 0.0.0.0 192.168.1.1

I would try to add a static route on the HP using the appropriate syntax

Hope to help

Giuseppe

New Member

Missing a route?

Hello Guisseppe,

That is exactly correct...you are the man...thank you

Best Regards, Roger

455
Views
5
Helpful
4
Replies