Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

MLPPP 3xT1 Slow also want flow based for Voice

Hi,

I have done some testing and the links seem realy slow for example I have been TFTPing an Image between routers over the wan R1---PPP---MPLS---ppp---R2

I do a show interface ser0/1/0 0/2/0 and 0/3/0 and the output is below..

5 minute input rate 16000 bits/sec, 4 packets/sec

5 minute output rate 1000 bits/sec, 4 packets/sec

I can initiate a extended ping between them and thats not real quic either considering one side is 2 xt1 and this one 3xt1

Also we are going to put voice over these links so Im wondering if IP CEF will distribute traffic per flow over one of the Multilink interfaces as i dont want the Voice traffic to be load shared for Obvious reasons.

So basicaly my questions are

1. Will voice streams be routed over 1 multilink interface if IP CEF is running (flow based).

2.Tried ext ping and pkts over 1500 bytes fail will this cause issues at all. I dont want to adjust MTU If i dont need to.

3.Anything else I can do to the config to improve it.

Thanks Allan

Config Below

class-map match-all Sprint_Data_Class_A_Voice_Only

description LLQ_Priority_Queue_RTP_Bearer_Traffic

match access-group 111

class-map match-any Sprint_Data_Class_C

description Class_C_Data_Traffic

class-map match-any Sprint_Data_Class_B

description Voice_Signaling_&_Class_B_Traffic

match access-group 106

!

!

policy-map Traffic_Shape-LLQ_CBWFQ

class Sprint_Data_Class_A_Voice_Only

priority percent 35

class Sprint_Data_Class_B

bandwidth percent 25

class Sprint_Data_Class_C

bandwidth percent 15

class class-default

fair-queue

!

!

!

!

!

interface Multilink1

ip address 172.20.150.222 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

service-policy output Traffic_Shape-LLQ_CBWFQ

!

interface FastEthernet0/0

description Inside Interface

ip address x

ip nbar protocol-discovery

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0

description Sprint DS1 xxx

bandwidth 1536

ip unnumbered Multilink1

encapsulation ppp

no ip mroute-cache

no peer neighbor-route

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/2/0

description Sprint DS1 #xxx

bandwidth 1536

ip unnumbered Multilink1

encapsulation ppp

no ip mroute-cache

no peer neighbor-route

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/3/0

description Sprint DS1 #xxxx

bandwidth 1536

ip unnumbered Multilink1

encapsulation ppp

no ip mroute-cache

no peer neighbor-route

no fair-queue

ppp multilink

ppp multilink group 1

!

ip classless

ip route

!

no ip http server

no ip http secure-server

!

access-list 106 permit udp any any eq 2427

access-list 106 remark UDP Port 2427 MGCP-CallManager_GW Control

access-list 106 permit tcp any any eq 2428

access-list 106 remark TCP Port 2428 ISDN_L3_Backhaul_To_CallManager

access-list 106 permit tcp any any range 2000 2002

access-list 106 remark TCP Port 2000_To_2002 SCCP_Signaling

access-list 111 permit udp any any range 16384 32767

access-list 111 remark UDP Ports 16384 32768 Voice_Bearer_Traffic

!

Multilink1 is up, line protocol is up

Hardware is multilink group interface

Internet address is 172.20.150.222/30

MTU 1500 bytes, BW 4608 Kbit, DLY 100000 usec,

reliability 255/255, txload 1/255, rxload 2/255

Encapsulation PPP, LCP Open, multilink Open

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

MLPPP 3xT1 Slow also want flow based for Voice

I know this reply is terribly late, but overall using multlink is going to add a bit of latency to your connection. Remember its adding 6 bytes to each frame

I see in your config you have fragmenting disabled. Depending on your service provider, what they have on the other end & how they configured it, you may actually want to turn that back on & add "ppp multilink interleave"

And as for voice, I've had just horrible results trying to use voip over multilink ppp. It was so bad for this client I had in NY, we actually ended up splitting the traffic via route maps so that all voip would go over one of the T1 lines, and I multilinked the other two and used them for everything else

Fortunately LRE's availability has increased significantly in the past 5 years and its cost has come down as well

anyway, i know this post is a decade late. hopefully someone else who has this problem will find this note and if possible, avoid bonded T1's like th bubonic plague. Pay the extra $ and get fiber!

3 REPLIES
VIP Purple

Re: MLPPP 3xT1 Slow also want flow based for Voice

Hello,

your config looks okay, is the other side configured with the same multilink parameters ? You could try and configure 'ppp multilink interleave' and see if that makes a difference...

As with regard to CEF, the default is per-destination load-balancing (that means that indeed your load sharing will be per-flow).

Regards,

GP

New Member

Re: MLPPP 3xT1 Slow also want flow based for Voice

I don't think you have a problem with your configurations. I believe the problem is with cisco's Multilink. We have a good number of links with multilink configured, cisco cases opened and still waiting on cisco to find the issue.

Issues I have seen with the multilink configured.

1. Pings end to end are not good.

2. Slowness in the network.

3. High output drops on the multilink, all issues clear when removed from multilink.

New Member

MLPPP 3xT1 Slow also want flow based for Voice

I know this reply is terribly late, but overall using multlink is going to add a bit of latency to your connection. Remember its adding 6 bytes to each frame

I see in your config you have fragmenting disabled. Depending on your service provider, what they have on the other end & how they configured it, you may actually want to turn that back on & add "ppp multilink interleave"

And as for voice, I've had just horrible results trying to use voip over multilink ppp. It was so bad for this client I had in NY, we actually ended up splitting the traffic via route maps so that all voip would go over one of the T1 lines, and I multilinked the other two and used them for everything else

Fortunately LRE's availability has increased significantly in the past 5 years and its cost has come down as well

anyway, i know this post is a decade late. hopefully someone else who has this problem will find this note and if possible, avoid bonded T1's like th bubonic plague. Pay the extra $ and get fiber!

329
Views
0
Helpful
3
Replies
CreatePlease to create content