Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

MLPPP-4 T1 bundle, 1721 router

We have a customer who is using three bonded T1 circuits on a 1721 router. He recently purchased a fourth line with the intention of adding it to his bundle. I attempted to replace his current 1721 router, which contains one WIC-1DSU-T1 card and one VWIC-2MFT-T1 card, with another 1721, which contains two VWIC-2MFT-T1 cards. The current router functions properly with any three--or fewer--of the four circuits, however, the new router is unable to maintain a steady connection on any of the four circuits; all ports intermittently come "up,up," but almost immediately return to the "reset, down." Is this, perhaps, an issue with the hardware, or is there a portion of the configuration which needs to be modified?

New 1721 Config:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname XXXXXXXXXXX

!

boot-start-marker

boot-end-marker

!

logging buffered 8192 errors

enable secret xxx

!

memory-size iomem 25

no aaa new-model

ip subnet-zero

!

!

!

ip cef

!

!

!

controller T1 0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 2

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 3

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

!

interface MultilinkGROUP

ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

ppp multilink

ppp multilink group GROUP

!

interface FastEthernet0

ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

no ip redirects

no ip unreachables

no ip proxy-arp

speed 100

full-duplex

no cdp enable

!

interface Serial0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

interface Serial1:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

interface Serial2:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

interface Serial3:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

ip default-gateway XXX.XXX.XXX.XXX

ip classless

ip route 0.0.0.0 0.0.0.0 MultilinkGROUP

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password 7

login

!

end

Sample Error Messages:

(taken from a 2600; the only difference is the controller IDs)

*Mar 1 00:29:00.649: %CONTROLLER-5-UPDOWN: Controller T1 0/3, changed state to up

*Mar 1 00:29:02.652: %LINK-3-UPDOWN: Interface Serial0/3:0, changed state to up

*Mar 1 00:29:04.647: %CONTROLLER-5-UPDOWN: Controller T1 0/3, changed state to down (LOF detected)

*Mar 1 00:29:06.651: %LINK-5-CHANGED: Interface Serial0/3:0, changed state to reset

*Mar 1 00:29:07.648: %CONTROLLER-5-UPDOWN: Controller T1 0/3, changed state to up

*Mar 1 00:29:09.648: %LINK-3-UPDOWN: Interface Serial0/3:0, changed state to up

*Mar 1 00:29:12.148: %CONTROLLER-5-UPDOWN: Controller T1 0/1, changed state to up

*Mar 1 00:29:14.151: %LINK-3-UPDOWN: Interface Serial0/1:0, changed state to up

*Mar 1 00:29:15.645: %CONTROLLER-5-UPDOWN: Controller T1 0/2, changed state to up

*Mar 1 00:29:17.649: %LINK-3-UPDOWN: Interface Serial0/2:0, changed state to up

*Mar 1 00:29:21.647: %CONTROLLER-5-UPDOWN: Controller T1 0/3, changed state to down (LOF detected)

*Mar 1 00:29:23.647: %LINK-5-CHANGED: Interface Serial0/3:0, changed state to reset

*Mar 1 00:29:24.648: %CONTROLLER-5-UPDOWN: Controller T1 0/2, changed state to down (LOF detected)

*Mar 1 00:29:24.652: %CONTROLLER-5-UPDOWN: Controller T1 0/3, changed state to up

*Mar 1 00:29:26.648: %LINK-5-CHANGED: Interface Serial0/2:0, changed state to reset

23 REPLIES
Hall of Fame Super Gold

Re: MLPPP-4 T1 bundle, 1721 router

Joe

I believe that the problem is that the 1721 can not handle the load of 4 T1s doing multilink. I have seen a router performance document that indicates that the best case (CEF/Fast Switching with no services enabled) for the 1721 is about 6 Mbps. And the 4 T1s would give you that amount. I am not sure what the overhead is of running multilink, but I suspect that it is pushing the 1721 slightly over the edge.

HTH

Rick

Community Member

Re: MLPPP-4 T1 bundle, 1721 router

Thank you very much for the reply. Do you think that a 2811 would be able to easily support the given configuration? Also, do you have a link to the technical documentation regarding the 1700's bandwidth limitation?

Hall of Fame Super Gold

Re: MLPPP-4 T1 bundle, 1721 router

Joe

I feel pretty confident that a 2811 would easily support the 4 T1 members of the multilink. Where the max for the 1721 (running with NO services configured) was right at 6 Mbps the max for the 2811 is about 61 Mbps. So the 2811 has about a 10 times increase in performance and should handle the 4 T1s in multilink fine.

The link to the documentations is:

http://www.cisco.com/web/partners/downloads/765/tools/quickreference/routerperformance.pdf

note that it requires partner level access. I did a quick look for public level access but have not found anything.

HTH

Rick

Community Member

Re: MLPPP-4 T1 bundle, 1721 router

Great information. Thank you for your help.

Community Member

Re: MLPPP-4 T1 bundle, 1721 router

I set our customer up with a 2821, but I still had no luck getting the four circuits to run together. The 2821's configuration is nearly identical to that provided above (except for the controller IDs). I am assuming that there is something I am missing in the configuration(?). The only thing that I can think of is the "network-clock participate wic x" setting, but I imagine that is similar to the "clock source" command on the 1721. Thanks in advance...

Hall of Fame Super Gold

Re: MLPPP-4 T1 bundle, 1721 router

By all means please set network-clock-participate, but that alone doesn't explain the bundle to not come up.

A bit more troubleshooting would be needed including show intefaces, debug ppp negotiation, just to begin with.

Hall of Fame Super Gold

Re: MLPPP-4 T1 bundle, 1721 router

Joe

In your original post there were error indication of Loss of Frame and they were spread over various members of the multilink bundle. I am not clear whether the symptoms are the same on the 2811 or are different. Perhaps a new description of the symptoms would be helpful. If you can post some of the specific log messages and perhaps the new config, then perhaps we would be better able to figure out the problem.

HTH

Rick

Community Member

Re: MLPPP-4 T1 bundle, 1721 router

Here is a copy of the configuration from the 2821 that I am attempting to use. It may also be important to note that the other side of the connection is a 7206VXR (NPE 300).

Current configuration : 1791 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname GROUP

!

boot-start-marker

boot-end-marker

!

logging buffered 8192 errors

enable secret xxx

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 0

network-clock-participate wic 1

ip subnet-zero

!

!

ip cef

!

!

no ip domain lookup

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/0/1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 0/1/1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

!

!

!

interface MultilinkGROUP

ip address XXX.XXX.XXX.XXX

ppp multilink

ppp multilink group GROUP

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address XXX.XXX.XXX.XXX 255.255.255.248

duplex full

speed 100

!

interface Serial0/0/0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

interface Serial0/0/1:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

interface Serial0/1/0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

interface Serial0/1/1:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group GROUP

!

ip default-gateway XXX.XXX.XXX.XXX

ip classless

ip route 0.0.0.0 0.0.0.0 MultilinkGROUP

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 7

login

!

scheduler allocate 20000 1000

!

end

Hall of Fame Super Gold

Re: MLPPP-4 T1 bundle, 1721 router

Joe

Thanks for posting the config of the new router. This config looks fine and I do not see any obvious issues with it.

A 2821 with this config should certainly be able to handle multilink with 4 T1s. And depending on what else it is configured to do a 7206VXR with NPE300 should be ok with this load. So while I suspect you were overloading the 1721, I believe the current hardware is adequate.

Can you give us a description of the current problems and perhaps copies of relevant error messages?

HTH

Rick

Community Member

Re: MLPPP-4 T1 bundle, 1721 router

Thread Marked.

Community Member

Re: MLPPP-4 T1 bundle, 1721 router

I tried testing the line using the single available circuit while running "debug ppp negotiation." The following is the logged debugging result:

*Mar 31 21:28:53.383: %CONTROLLER-5-UPDOWN: Controller T1 0/1/1, changed state to up

*Mar 31 21:28:55.383: %LINK-3-UPDOWN: Interface Serial0/1/1:0, changed state to up

*Mar 31 21:28:55.387: Se0/1/1:0 PPP: Using default call direction

*Mar 31 21:28:55.387: Se0/1/1:0 PPP: Treating connection as a dedicated line

*Mar 31 21:28:55.387: Se0/1/1:0 PPP: Session handle[F000000A] Session id[1]

*Mar 31 21:28:55.387: Se0/1/1:0 PPP: Phase is ESTABLISHING, Active Open

*Mar 31 21:28:55.387: Se0/1/1:0 LCP: O CONFREQ [Closed] id 1 len 24

*Mar 31 21:28:55.387: Se0/1/1:0 LCP: MagicNumber 0x13C72D76 (0x050613C72D76)

*Mar 31 21:28:55.387: Se0/1/1:0 LCP: MRRU 1500 (0x110405DC)

*Mar 31 21:28:55.387: Se0/1/1:0 LCP: EndpointDisc 1 GROUP (0x130A01576562734F776E)

*Mar 31 21:28:57.371: Se0/1/1:0 LCP: TIMEout: State REQsent

*Mar 31 21:28:57.371: Se0/1/1:0 LCP: O CONFREQ [REQsent] id 2 len 24

*Mar 31 21:28:57.371: Se0/1/1:0 LCP: MagicNumber 0x13C72D76 (0x050613C72D76)

*Mar 31 21:28:57.371: Se0/1/1:0 LCP: MRRU 1500 (0x110405DC)

*Mar 31 21:28:57.371: Se0/1/1:0 LCP: EndpointDisc 1 GROUP (0x130A01576562734F776E)

*Mar 31 21:28:59.387: Se0/1/1:0 LCP: TIMEout: State REQsent

*Mar 31 21:28:59.387: Se0/1/1:0 LCP: O CONFREQ [REQsent] id 3 len 24

*Mar 31 21:28:59.387: Se0/1/1:0 LCP: MagicNumber 0x13C72D76 (0x050613C72D76)

*Mar 31 21:28:59.387: Se0/1/1:0 LCP: MRRU 1500 (0x110405DC)

*Mar 31 21:28:59.387: Se0/1/1:0 LCP: EndpointDisc 1 GROUP (0x130A01576562734F776E)

*Mar 31 21:29:01.403: Se0/1/1:0 LCP: TIMEout: State REQsent

*Mar 31 21:29:01.403: Se0/1/1:0 LCP: O CONFREQ [REQsent] id 4 len 24

*Mar 31 21:29:01.403: Se0/1/1:0 LCP: MagicNumber 0x13C72D76 (0x050613C72D76)

*Mar 31 21:29:01.403: Se0/1/1:0 LCP: MRRU 1500 (0x110405DC)

*Mar 31 21:29:01.403: Se0/1/1:0 LCP: EndpointDisc 1 GROUP (0x130A01576562734F776E)

*Mar 31 21:29:02.635: %CONTROLLER-5-UPDOWN: Controller T1 0/1/1, changed state to down (10 SES)

*Mar 31 21:29:03.419: Se0/1/1:0 LCP: TIMEout: State REQsent

*Mar 31 21:29:03.419: Se0/1/1:0 LCP: O CONFREQ [REQsent] id 5 len 24

*Mar 31 21:29:03.419: Se0/1/1:0 LCP: MagicNumber 0x13C72D76 (0x050613C72D76)

*Mar 31 21:29:03.419: Se0/1/1:0 LCP: MRRU 1500 (0x110405DC)

*Mar 31 21:29:03.419: Se0/1/1:0 LCP: EndpointDisc 1 GROUP (0x130A01576562734F776E)

*Mar 31 21:29:04.635: %LINK-3-UPDOWN: Interface Serial0/1/1:0, changed state to down

*Mar 31 21:29:04.635: Se0/1/1:0 PPP: Sending Acct Event[Down] id[3]

*Mar 31 21:29:04.635: Se0/1/1:0 LCP: State is Closed

*Mar 31 21:29:04.635: Se0/1/1:0 PPP: Phase is DOWN

*Mar 31 21:41:18.411: %CONTROLLER-5-UPDOWN: Controller T1 0/1/0, changed state to down (LOS detected)

*Mar 31 21:41:18.411: %CONTROLLER-5-UPDOWN: Controller T1 0/1/1, changed state to down (LOS detected)

The log entries on both the 2821 and the VXR are almost identical. In both cases it seems that neither router responds to the other's LCP Requests.

Hall of Fame Super Gold

Re: MLPPP-4 T1 bundle, 1721 router

Joe

I am a bit confused. I thought we were talking about routers with a multilink with 4 T1s in the multilink bundle. But your comment is:

testing the line using the single available circuit

are we talking a single circuit or multiple circuits. Also I note in the debug posted that 1 T1 controller comes up at the beginning of the debug and that 2 controllers go down at the end. Did the second controller come up just before the place where you selected your debug output to post?

I agree that the debug would seem to indicate that the routers are not responding to each other. I wonder if there might be an issue about having the correct cable connected to the correct port?

HTH

Rick

Community Member

Re: MLPPP-4 T1 bundle, 1721 router

He attempted to use one line while the three remaining lines were in production use. The three T1s currently in use are working fine, and have done so for multiple years. Converting to four t1s... it all falls apart.

Hall of Fame Super Gold

Re: MLPPP-4 T1 bundle, 1721 router

Robert

Do you work with Joe? If so can you tell me whether the debug output represents attempting to use the 4th circuit in the multilink bundle or was it operating independently?

HTH

Rick

1836
Views
0
Helpful
23
Replies
CreatePlease to create content