Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MLPPP configuration - Request assistance on config

Hi all,

I am looking to configure MLPPP to combine my [2] T1 serial interfaces to my ISP.

I have looked a bit on the cisco web site for information on how to do so but to date cannot seem to track down a simple config.

My other problem is that each T1 is a termination point for a site to site VPN tunnel. I believe I can create a MLPPP virtual interface and include both public addresses on that interface. one as the primary and one as the secondary but am not quite sure how to do this as well.

Any links/help would be greatly appreciated.

Best regards,

Mike

4 REPLIES

Re: MLPPP configuration - Request assistance on config

Hello,

a sample configuration would look like this:

interface Serial0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 123

interface Serial1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 123

interface Multilink123

ip address 2.2.2.2 255.255.255.252 secondary

ip address 1.1.1.1 255.255.255.252

ppp multilink

ppp multilink group 123

Be aware however, that the ISP should route both addresses to your router or use secondary addresses as well.

Hope this helps! Please rate helpful posts

Martin

New Member

Re: MLPPP configuration - Request assistance on config

Thanks Martin. I just wanted to confirm the configs.

Before config..

interface Serial0/0/0

description

ip address 1.1.1.1 255.255.255.252

ip access-group 101 in

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

ip inspect IDS out

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

crypto map SDM_CMAP_1

interface Serial0/1/0

description

ip address 2.2.2.2 255.255.255.252

ip access-group 104 in

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

no cdp enable

crypto map SDM_CMAP_2

AFTER MLPPP config ?? - *=Would this command reside on the MLPPP interface or physical ??

interface Serial0/1/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 123

ip verify unicast reverse-path *

no ip redirects *

no ip unreachables *

no ip proxy-arp *

ip virtual-reassembly *

ip route-cache flow * [capturing netflow]

interface Serial0/0/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 123

ip verify unicast reverse-path *

no ip redirects *

no ip unreachables *

no ip proxy-arp *

ip virtual-reassembly *

ip route-cache flow *

interface Multilink123

ip address 2.2.2.2 255.255.255.252 secondary

ip address 1.1.1.1 255.255.255.252

ppp multilink

ppp multilink group 123

access-group 110 in

ip inspect IDS out

ip nat outside ** would I then be nat'g to the primary? I would assume so...

crypto map SDM_CMAP_1

thanks in advance !!

New Member

Re: MLPPP configuration - Request assistance on config

One additional question....

Each of the current interfaces that will be combined has an access-list on them. I am assuming I should combine the access-lists into one and apply it to the multilink interface ?

thanks again !

Re: MLPPP configuration - Request assistance on config

Hello,

the idea of MLPPP is to combine interface resources into one logical interface (int multilink). This logical interface will get IP addresses and other configuration like access-lists.

So in short the answer is yes.

Be careful when merging access-lists because of top-down processing a match will not lead to further checking additional access-list entries.

General approach: more specific statements to the top.

Hope this helps! Please rate all posts.

Martin

289
Views
8
Helpful
4
Replies