Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

mlppp over 2 ds3s

I'd like a second opinion on the following config. I don't believe I need CEF on in the following config if MLPPP is doing its job. Any comments?

Side A

version 12.4

no service pad

service timestamps debug uptime

service timestamps log datetime msec localtime

service password-encryption

!

hostname Side_A

!

!

enable password

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip domain lookup

!

!

multilink virtual-template 1

!

!

!

!

!

interface Loopback0

ip address 192.168.1.57 255.255.255.252

!

interface FastEthernet0/0

ip address 192.168.1.50 255.255.255.248

duplex full

!

interface Serial2/0

no ip address

encapsulation ppp

dsu bandwidth 44210

framing c-bit

cablelength 10

clock source internal

serial restart-delay 0

ppp multilink

!

interface Serial2/1

no ip address

encapsulation ppp

dsu bandwidth 44210

framing c-bit

cablelength 10

clock source internal

serial restart-delay 0

ppp multilink

!

interface Virtual-Template1

ip unnumbered Loopback0

ppp multilink

ppp multilink fragment disable

!

ip default-gateway 192.168.1.49

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.49

ip route 192.168.1.88 255.255.255.252 192.168.1.58

ip route 192.168.1.90 255.255.255.255 192.168.1.58

!

no ip http server

!

!

!

control-plane

!

!

!

end

Side_A#

------------------------------------------------------

Side B

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Side_B

!

!

enable password

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip domain lookup

!

!

multilink virtual-template 1

!

!

!

!

!

interface Loopback0

ip address 192.168.1.58 255.255.255.252

!

interface FastEthernet0/0

ip address 192.168.1.89 255.255.255.252

duplex full

!

interface Serial1/0

no ip address

encapsulation ppp

dsu bandwidth 44210

framing c-bit

cablelength 70

serial restart-delay 0

ppp multilink

!

interface Serial1/1

no ip address

encapsulation ppp

dsu bandwidth 44210

framing c-bit

cablelength 70

serial restart-delay 0

ppp multilink

!

interface Virtual-Template1

ip unnumbered Loopback0

ppp multilink

ppp multilink fragment disable

!

ip default-gateway 192.168.1.57

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.57

!

no ip http server

!

!

!

!

control-plane

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

!

!

end

Side_B#

5 REPLIES
Hall of Fame Super Silver

Re: mlppp over 2 ds3s

Sean

The multilink part looks pretty straightforward with the exception of its IP addressing. I think you are creating a problem by assigning these addresses to loopback interfaces and then doing ip unnumbered on the virtual-template. I think you would be much better off to just assign the addresses on the virtual-template. I think it is particularly an issue on side_B where your default route (ip route 0.0.0.0 0.0.0.0 192.168.1.57 ) and your default gateway are pointing to the subnet connected on the loopback interface. I think this is also an issue with 2 of the static routes on side_A:

ip route 192.168.1.88 255.255.255.252 192.168.1.58

ip route 192.168.1.90 255.255.255.255 192.168.1.58

I believe that you should leave cef enabled. I think that your comment about not needing cef is based on the assumption that cef does load balancing and with MLPPP you have a single logical outbound path not load balancing. But cef does a lot more than just load balancing. Basic decisions like whether to forward out the FastEthernet or the virtual-template are enhanced by cef.

HTH

Rick

New Member

Re: mlppp over 2 ds3s

Thanks for your comments.

I'll look into the loopback/unnumbered. I followed the examples for configuration. I'll go over them again .. make sure I didn't miss anything. Regarding CEF that makes sense.

New Member

Re: mlppp over 2 ds3s

Found the original example I used

Point-to-Point Protocol (PPP)

Multilink PPP on Back-to-Back Routers with Multiple Serial Interfaces

Example 2: Virtual Template

Router1 - Cisco 2503

Current configuration

!

version 12.2

!

hostname Router1

!

!

username Router2 password 0 abc

ip subnet-zero

no ip domain-lookup

!

multilink virtual-template 1

!--- Applies the virtual interface template to the multilink bundle.

interface Loopback0

ip address 192.168.10.2 255.255.255.0

!--- The loopback address is used by virtual-template 1.

interface Virtual-Template1

!--- Interface virtual-template is a logical interface that creates

!--- virtual access interfaces dynamically and applies them to

!--- physical serial interfaces.

ip unnumbered Loopback0

!--- Always unnumber the virtual-template to an UP interface.

!--- Do not assign a static IP.

ppp authentication chap

ppp multilink

!--- Enables multilink PPP on the virtual-template interface.

interface Serial0

no ip address

encapsulation ppp

pulse-time 1

ppp multilink

!

interface Serial1

no ip address

encapsulation ppp

pulse-time 1

ppp multilink

!

!

ip classless

!

line con 0

line aux 0

transport input all

line vty 0 4

login

!

end

Router2 - Cisco 2503

Current configuration :

!

version 12.2

!

hostname Router2

!

!

username Router1 password 0 abc

ip subnet-zero

no ip domain-lookup

!

multilink virtual-template 1

!

!

!

interface Loopback0

ip address 192.168.20.1 255.255.255.0

!

!

interface Virtual-Template1

ip unnumbered Loopback0

ppp authentication chap

ppp multilink

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

clockrate 56000

pulse-time 1

ppp multilink

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

clockrate 56000

pulse-time 1

ppp multilink

!

!

ip classless

!

!

line con 0

line aux 0

line vty 0 4

!

end

The configuration above describes the virtual template configured on Router1 and Router2. In this example, both

routers are configured with virtual templates. The routers are connected back-to-back, and the multilink session

does not idle out. No static routes are needed: a host route is installed after PPP negotiations.

Use Cisco IOS Software Release 11.3 or later to use virtual template for PPP multilink.

The virtual template command dynamically creates a virtual access interface and applies them to physical serial

interfaces with the multilink virtual-template command. The parameters (such as ppp authentication chap) configured

in interface virtual template are applied for both serial interfaces. The ppp multilink command in the interface

virtual-template bundles the physical serial interfaces to form a virtual-access in order to aggregate the

bandwidth.

Hall of Fame Super Silver

Re: mlppp over 2 ds3s

Sean

I am glad that you found and posted the example that you followed. It is certainly pretty specific in its comment about not assigning a static IP address to the virutal-template and using ip unnumbered instead. I am not sure why this is but the example certainly says so.

Given the advice to use unnumbered let me approach my concern from a slightly different perspective. The problem is not so much that you used ip unnumbered but is the fact that you attempt to define a connected subnet on both loopback interfaces. Your first loopback is 192.168.1.57 255.255.255.252 and the second loopback is 192.168.1.58 255.255.255.252. When you use this default route on Side_B ip route 0.0.0.0 0.0.0.0 192.168.1.57 I am not sure whether the router will believe that the next hop is on the loopback interface or is over the multilink. Given the reminder in the example that the PPP negotiation will put a host route into the routing table, it may be that you example will work. Even if it does work my instinct is that trying to put the same subnet on the loopback of two routers is not a good practice.

The example is clear that one loopback interface is 192.168.10.2 255.255.255.0 and the other loopback interface is 192.168.20.1 255.255.255.0. Two separate networks certainly avoids the problem.

It may be that you wanted to configure it so that the multilink used the same subnet on both ends. That is certainly good practice for most serial connections. The use of unnumbered makes things work even when the ends of the connection are not in a common subnet.

It would be interesting to try your configuration and see whether it works properly or not. If you do try it please post back to the forum with the results.

HTH

Rick

New Member

Re: mlppp over 2 ds3s

Thanks. You are correct about why I used a connected subnet. I'll give it a shot as seperate networks. The mlppp is supposed to automatically inject a route for the link.

I've added statics as I'm running a BGP peer across this link.

The link is working - routing and forwarding.

The reason I've been questioning the link at all is that I'm not seeing more than 9 Mbps across the two.

I've begun to wonder if the system is misreading the link speed and only allowing 4.2 Mbps based on the 42xxx kpbs of the modem speed.

More testing this week.

147
Views
0
Helpful
5
Replies