Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Modem access via AUX port

I am trying to congire a 1800 router to allow modem "out of band" access.

I have configured the AUX port on line 5:

line aux 0

password xxxx

login

modem InOut

transport input all

speed 115200

flowcontrol hardware

I also attach a file with the sh line 5 output

internet-gw#sh line 5

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

* 5 AUX 115200/115200- inout - - - 0 0 6/16203007

-

Line 5, Location: "", Type: ""

Length: 24 lines, Width: 80 columns

Baud rate (TX/RX) is 115200/115200, no parity, 2 stopbits, 8 databits

Status: Ready, Active, No Exit Banner, Input Stopped, CTS Raised

Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

Modem Callout, Modem RI is CD

Modem state: Ready

Special Chars: Escape Hold Stop Start Disconnect Activation

^^x none - - none

Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch

00:10:00 never none not set

Idle Session Disconnect Warning

never

Login-sequence User Response

00:00:30

Autoselect Initial Wait

not set

Modem type is unknown.

Session limit is not set.

Time since activation: 00:51:51

Editing is enabled.

History is enabled, history size is 20.

DNS resolution in show commands is enabled

Full user help is disabled

Allowed input transports are pad telnet rlogin udptn.

Allowed output transports are pad telnet rlogin.

Preferred transport is telnet.

No output characters are padded

No special data dispatching characters

I have US Robotics modem connected externally, when I try to dial it I get no answer.

If there something I am missing?

9 REPLIES
Purple

Re: Modem access via AUX port

Do you mean that the call keeps ringing out ?

If so, then the problem is on the modem not the router. I would connect to the modem's serial port via a terminal emulation program and issue the AT command that configures it to answer after 2 rings or something. You will need to consult the modem manual for the AT command appropriate to the modem.

Paresh

New Member

Re: Modem access via AUX port

Yes it just ring out.

Is there a way I can configure the router to dialout of the aux so I can test that works?

Purple

Re: Modem access via AUX port

Try this:

http://www.cisco.com/warp/public/471/mod-aux-dialout.html

Pls do remember to rate posts.

Paresh

New Member

Re: Modem access via AUX port

I am now able to reverse telnet to the "modem"

If I run "at2 commands i get, ie

U.S. Robotics 56K Voice EXT NVRAM Settings...

Template Y0

DIAL=TONE B0 E1 F1 L2 M1 Q0 V1 X4

SPEED=57600 PARITY=N WORDLEN=8

&A3 &B1 &C1 &D2 &H1 &I0 &K1 &M4 &N0

&P1 &R2 &S0 &T5 &U0 &Y1

S00=000 S02=043 S03=013 S04=010 S05=008 S06=004 S07=060

S08=002 S09=006 S10=014 S11=070 S12=050 S13=000 S15=000

S19=000 S21=010 S22=017 S23=019 S25=005 S27=001 S28=008

S29=020 S30=000 S31=128 S32=002 S33=000 S34=000 S35=000

S36=014 S38=000 S39=011 S40=000 S41=004 S42=000

Strike a key when ready . . .

Does that indicate that the router and modem or talking?

Purple

Re: Modem access via AUX port

It does indeed...

Now if you type in 'ATS0=2' that should configure it to pick up after the second ring. Then enter in 'AT&W' to save the settings.

Then, try calling into it again..

Paresh

New Member

Re: Modem access via AUX port

Ok getting better.

The modem is answering. I am connecting from Hyperterm and I just get a flashing cursor.

Purple

Re: Modem access via AUX port

Your modem seems to be configured for a speed of 57600 whereas the aux port is configured for 115200. Can you configure the aux port speed to match the modem setting ?

Paresh

New Member

Re: Modem access via AUX port

I get this output whilst connected to the modem

at

RING

RING

Connect 9600/ARQ

x3xx3xx3xx

etc and no login prompt on my terminal session.

Current setting in config

line aux 0

password xxx

login

modem InOut

modem autoconfigure type default

transport input all

speed 57600

flowcontrol hardware

I also attach a copy of the output from "ati1 -11" commands in file.

New Member

Re: Modem access via AUX port

we swapped the modem and it worked at first. It seems very hit and miss. Does anyone know a good modem that works well with the aux port?

397
Views
3
Helpful
9
Replies
CreatePlease to create content