Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

More than 1 tunnel between the same 2 IP addresses/routers

Is it illegal to more than 1 tunnel between the same 2 IP addresses/routers.

What would be the effect of this configuration?

=========================================

On a router fred we have:

------------------------------------------------------------

interface Loopback1

ip address 172.25.249.1 255.255.255.252

interface Tunnel52

no ip address

decnet cost 2

tunnel source Loopback1

tunnel destination 10.50.31.241

interface Tunnel55

no ip address

decnet cost 6

tunnel source 172.25.249.1

tunnel destination 10.50.31.241

------------------------------------------------------------

and on router john we have:

------------------------------------------------------------

interface Loopback0

ip address 10.50.31.241 255.255.255.252

no ip directed-broadcast

interface Tunnel1

no ip address

no ip directed-broadcast

decnet cost 6

tunnel source 10.50.31.241

tunnel destination 172.25.249.1

interface Tunnel52

description GRE tunnel to zvtrnsdnr001

no ip directed-broadcast

decnet cost 2

tunnel source Loopback0

tunnel destination 172.25.249.1

10 REPLIES
Silver

Re: More than 1 tunnel between the same 2 IP addresses/routers

I can't verify it but I belive it should work, due to they are different tunnel interface. However, increasing tunnel interface will also increase the router loading, be consider before implement too many tunnel interfaces in a router.

Why not try it and tell us the result ? Please try to use same source w/ LB or IP.

Silver

Re: More than 1 tunnel between the same 2 IP addresses/routers

It will work but i remember that 2 tunnels between the same routers will actually create problems , with the traffic for one tunnel actually getting routed through the other. So it is quite possible that one tunnel may carry all traffic and other may have no traffic though your routing may be fine.

Hall of Fame Super Silver

Re: More than 1 tunnel between the same 2 IP addresses/routers

I am not sure that it will work to try to have two tunnels with the same source address and the same destination address. And even if it did work I am puzzled why you would want to do this? Especially since both tunnels are configured to carry only Decnet traffic. Perhaps Alphonse can clarify why they are trying to do this. If we knew what problem they are trying to solve we might find a better solution.

HTH

Rick

New Member

Re: More than 1 tunnel between the same 2 IP addresses/routers

I was told by Cisco TAC you can't have two tunnels with the same destination.

Hall of Fame Super Silver

Re: More than 1 tunnel between the same 2 IP addresses/routers

Christopher

Thanks for confirming my opinion that two tunnels from the same router to the same destination would not work. Perhaps Alphonse can explain what problem they are trying to solve and perhaps we can find some way to achieve their objective.

HTH

Rick

New Member

Re: More than 1 tunnel between the same 2 IP addresses/routers

I will explain what is happening. This setup has been working fine for DECnet for many many years. Now we have a problem where DECnet adjacency on Tunnel 52 flaps every few seconds. After doing a few debugs and troubleshooting we noticed that hello messages are exchanged between these 2 routers without obeying the default hello interval of 15 seconds. Hello messages are sent every 1 or 2 second instead of 15 seconds. Then one engineer pointed out saying that the problem could be due to these multiple tunnels and customer was asked to remove one tunnel.

But customer says this configuration has been working fine for over 5 years and why the problem now? The config has defintely not been changed for 5 years. The Tunnel 52 itself is fine and is not dropping data because I can do IP ping from tunnel source to tunnel destination IP address on Tunnel 52 without any packet loss of even large packets.

Silver

Re: More than 1 tunnel between the same 2 IP addresses/routers

Thanks for the detail info. If it works for 5 years w/o modification. I suspect there may be external factor to cause the problem.

What is the impact if remove one tunnel ? Did you enable the Decnet outside the tunnel in same interface ?

Any IOS upgrade recently ?

New Member

Re: More than 1 tunnel between the same 2 IP addresses/routers

What is the impact if remove one tunnel ?

Planning an outage to remove one tunnel

============================================

Did you enable the Decnet outside the tunnel in same interface ?

What do you mean by DECnet outside the tunnel?

Silver

Re: More than 1 tunnel between the same 2 IP addresses/routers

What I mean is there any chance that some configuration will cause the non-sync. hello interval. However, if the router config. not changed for five years, I don't know the reason.

However, do you also confirm the remote router config also not changed for a long time. i.e. the configuration at both tunnel end routers.

Any IOS upgrade / downgrade recently ?

Wait for your result after remove one tunnel.

Hall of Fame Super Silver

Re: More than 1 tunnel between the same 2 IP addresses/routers

If you say that it has been working fine in the past I will believe it. I suspect that what has been happening is that the first tunnel works and that the second tunnel does not.

If the problem is on tunnel 52, have you tried shutting down tunnel 52 and see if the other tunnel picks up the traffic and works?

When someone says that something has been working and then stopped working I wonder what has changed. If there has been no change in the config, is it possible that one (or both) routers have had a code upgrade or some other kind of maintenance?

Also in looking again at the part of the config that you posted I notice that on router John that tunnel 52 does not include the no ip address command while the other tunnel interfaces do have this. I wonder if this is just an error of cut and paste to create the posting or if it is really different in the config.

HTH

Rick

108
Views
3
Helpful
10
Replies