Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

MPLS LDP-IGP not working

Hello.

I have two LSRs connecting via single link. I want to check LDP-OSPF synchronization. But it doesnt work. My config for side A:

A#sh run | s ospf

router ospf 1

mpls ldp sync

mpls ldp autoconfig area 0

log-adjacency-changes

network 1.1.1.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 0

network 192.168.15.0 0.0.0.255 area 0

network 192.168.0.0 0.0.255.255 area 0

Interface

A#sh run int fa2/1

Building configuration...

Current configuration : 120 bytes

!

interface FastEthernet2/1

ip address 192.168.5.1 255.255.255.0

duplex auto

speed auto

mpls ip

mpls mtu 1504

end

Side B:

router ospf 1

log-adjacency-changes

network 3.3.3.0 0.0.0.255 area 0

network 10.1.3.0 0.0.0.255 area 0

network 192.168.15.0 0.0.0.255 area 0

network 192.168.0.0 0.0.255.255 area 0

Interface:

B#sh run int fa2/1

Building configuration...

Current configuration : 120 bytes

!

interface FastEthernet2/1

ip address 192.168.5.2 255.255.255.0

duplex auto

speed auto

mpls ip

mpls mtu 1504

end

And OSPF starts immediatelly(((

*Jul 22 09:04:04.020: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on FastEthernet2/1 from LOADING to FULL, Loading Done

A#

*Jul 22 09:04:25.716: %LDP-5-NBRCHG: LDP Neighbor 3.3.3.3:0 (2) is UP

Bedug for synchronization:

*Jul 22 08:56:03.100: LDP-SYNC: Fa2/1, 3.3.3.3: Peer unreachable; set LDP_CTX_HANDLE_ROUTEUP

*Jul 22 08:56:03.104: LDP-SYNC: Fa2/1, OSPF 1: notify status (required, not achieved, no delay, holddown 30000) internal status (not achieved, timer not running)

*Jul 22 08:56:07.992: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on FastEthernet2/1 from LOADING to FULL, Loading Done

So as you can see no impact on OSPF process(((

Please help me what can be wrong

Everyone's tags (3)
4 REPLIES

MPLS LDP-IGP not working

I found the reason. Everything works correctly)

New Member

MPLS LDP-IGP not working

Hi,

Can you provide the logs & debug outputs for working ldp-igp synch? It will help the other guys having doubts regarding  the same and can compare the same.

Regds,

Ankit Gupta

Ankit Gupta Cisco Systems India
New Member

MPLS LDP-IGP not working

You must look for this:

p1#debug mpls ldp igp sync

LDP-IGP Synchronization debugging is on

*Jul 25 05:26:41.737: %OSPF-5-ADJCHG: Process 1, Nbr 9.0.0.1 on Ethernet0/1 from LOADING to FULL, Loading Done

*Jul 25 05:26:46.785: LDP-SYNC: Peer became reachable on Et0/1, peer 9.0.0.1

*Jul 25 05:26:46.785: LDP-SYNC: Et0/1, OSPF 1: notify status (required, not achieved, delay, holddown infinite) internal status (not achieved, timer not running)

*Jul 25 05:26:46.785: ldp: Check routeup needs; clear routeup needs

*Jul 25 05:26:46.841: LDP-SYNC: Et0/1: No session or session has not send initial update, ignore adj joining event.

*Jul 25 05:26:46.841: %LDP-5-NBRCHG: LDP Neighbor 9.0.0.1:0 (1) is UP

*Jul 25 05:26:46.841: LDP-SYNC: Et0/1: session 9.0.0.1:0 came up, sync_achieved up

*Jul 25 05:26:46.841: LDP-SYNC: Et0/1, OSPF 1: notify status (required, achieved, no delay, holddown infinite) internal status (achieved, timer not running)

show mpls ldp igp sync

    Ethernet0/1:

        LDP configured; LDP-IGP Synchronization enabled.

        Sync status: sync achieved; peer reachable.

        Sync delay time: 0 seconds (0 seconds left)

        IGP holddown time: infinite.

        Peer LDP Ident: 9.0.0.1:0

        IGP enabled: OSPF 1

show ip ospf mpls ldp int e0/1

Ethernet0/1

  Process ID 1, Area 1

  LDP is not configured through LDP autoconfig

  LDP-IGP Synchronization : Required

  Holddown timer is not configured

  Interface is up

Ankit Gupta Cisco Systems India

MPLS LDP-IGP not working

Please look at my initial question. There you can see my debug.

So, why i couldn't hold on OSPF, because LDP tried to set the session between loopbacks interfaces and those were unreachable since side A had no another way to reach side B. In this case OSPF cames immidiatelly to try to create LDP session. If no LDP sess is created, OSPF maintains. But if transport addresses are changed to direct IP of physical interfaces (so LDP can create session without OSPF but via direct address), OSPF waits for LDP to come up as it should be.

580
Views
0
Helpful
4
Replies
CreatePlease to create content