Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

MPLS LSP Problem

Hello, I am facing a strange problem. I have delpoyed a network using 5 routers

R1 ----> R2 ---> R3 ---->R4 --> R5

R1 is conencted to R2 using POS STM1

R2 is connected to R3 using GigE

R3 us connecred to R4 using GRE Tunnel over internet

R4 is connected to R5 using GigE

i can see all of the network connected with proper ldp neighbours; all of the routers are able to ping and trace eachother and i can see the lables for all of the remotes

when i try pinging MPLS LSP from R2 to R4 using ping mpls ipv4 <targetip/mask> command, it is stopping at R4 and cannot reach R4 and returns f: FEC mismatch

but when i try the same from R2 to R5, it is going through.

#tr mpls ip 10.1.41.2/32

Tracing MPLS Label Switched Path to 10.1.41.2/32, timeout is 2 seconds

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,

  'L' - labeled output interface, 'B' - unlabeled output interface,

  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,

  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,

  'P' - no rx intf label prot, 'p' - premature termination of LSP,

  'R' - transit router, 'I' - unknown upstream index,

  'X' - unknown return code, 'x' - return code 0

Type escape sequence to abort.

  0 10.31.71.2 MRU 1500 [Labels: 68 Exp: 0]

L 1 10.31.71.1 MRU 1480 [Labels: implicit-null Exp: 0] 232 ms

f 2 10.31.71.1 4 ms

f 3 10.31.71.1 0 ms

f 4 10.31.71.1 4 ms

f 5 10.31.71.1 0 ms

f 6 10.31.71.1 0 ms

#tr mpls ip 10.1.41.1/32

Tracing MPLS Label Switched Path to 10.1.41.1/32, timeout is 2 seconds

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,

  'L' - labeled output interface, 'B' - unlabeled output interface,

  'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,

  'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,

  'P' - no rx intf label prot, 'p' - premature termination of LSP,

  'R' - transit router, 'I' - unknown upstream index,

  'X' - unknown return code, 'x' - return code 0

Type escape sequence to abort.

  0 10.31.71.2 MRU 1500 [Labels: 69 Exp: 0]

L 1 10.31.71.1 MRU 1476 [Labels: 126 Exp: 0] 192 ms

I 2 10.1.41.21 MRU 1504 [Labels: implicit-null Exp: 0] 192 ms

! 3 10.1.41.9 188 ms

Can anyone suggest what course of troubleshooting i should opt?

2 REPLIES
Cisco Employee

MPLS LSP Problem

Hello Shaheer,

It is a blind shot from me at this point but if you are using OSPF, make sure that the loopbacks are configured with /32 netmasks. Otherwise, a discrepancy occurs: OSPF advertises the loopbacks as /32 networks while LDP advertises the label mappings using the real loopback netmasks. That leads to missing label mappings.

If this is not the case, is it possible to display the relevant parts of the configuration on R4?

Best regards,

Peter

Community Member

MPLS LSP Problem

Hi Peter,

find below the config from R4; the strange thing is that ping is properly responding from R4 to R2 and R5 to R4

---------------------

ip cef

!

interface Loopback742000

ip address 10.1.41.6 255.255.255.255

!

interface Loopback742322

ip address 12.18.18.49 255.255.255.255

!

interface Loopback742742

ip address 10.1.41.2 255.255.255.255

!

interface Tunnel742322

description Tunnel between London P-1 and Saudi P-2 Mobily

ip address 10.1.41.21 255.255.255.252

mpls label protocol ldp

mpls ip

keepalive 10 5

tunnel source 12.18.18.49

tunnel destination 10.31.70.32

!

router ospf 65

router-id 10.1.41.2

redistribute connected subnets route-map OSPF-Distribution

network 10.1.41.21 0.0.0.0 area 0

!

mpls ldp router-id Loopback742000 force

---------------------------------------------

331
Views
0
Helpful
2
Replies
CreatePlease to create content