Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS-TE and OSPF: Tunnel Will Not Come Up

Please see attachements.

I'm trying to build three mpls-te tunnels (LSP): the first from ms to sa1,  the second from ms to sa1 going through sa26, and the third from ms to sa1 going through sa6 (not built yet). I was able to get Tunnel1 up/up, but Tunnel2 is up/down.  Is my configuration correct? Obviously not, since tunnel2 is Up/Down.

My main goal is to load balance the traffic between these three tunnels. Also how can to test or validate that traffic is being load balancing properly?

Thanks in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Hello David,

I've probably given a too broad answer.

I try to give more focused answers

>> My goal is to have 50% of all traffic go to tunnel1 and 50% to tunnel2.

As I wrote in my first post there is traffic limiting related to bandwidth in a tunnel.

You can use 1 kbps of BW or 50 Mbps with same result.

If you want to have both tunnels up/up  BW_T1 + BW_T2 < 75000 kbps

ip rsvp bandwidth (default uses 75% of 100Mbps?)

yes as explained in command reference link, the first link in my first post.

>> If you enter the ip rsvp bandwidth command without any bandwidth values (for example, ip rsvp bandwidth followed by pressing the Enter key), a default bandwidth value (that is, 75% of the link bandwidth) is assumed for both the interface-kbps and single-flow-kbps arguments.

see http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_i1.html#wp1024341

tunnel mpls traffic-eng path-option 50 dynamic

>> this means a dynamic path is used with priority 50, the lowest value wins. This is typically used as a backup path if a primary explicit path cannot be used for example for lack of resources or because a link or a node is down and it is in the list of the explicit path

about ip rsvp resource-provider none

http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_i2.html#wp1028667

as far as I understand it is not closely related to MPLS TE. I've never used if just to make an example.

Edit:

about path choices of the two tunnels:

tunnel1 uses a dynamic path so it uses the outgoing interface on the best path to tunnel destination

tunnel2 would like to use an explicit path, if the explicit path is correctly describing the desired path it will be used (desired path would out anothe FE) but if the explicit path is not accepted a dynamic path will be used with the risk to try to use the same interface.

I will give a look at your topology

I understand you would like to have tunnel2 going via sa26 and tunnel1 on the direct path.

For some reason, the explicit path is not accepted and both tunnels try to used shortest path.

post sh mpls traffic-eng tunnel2 we should see some information about path calculation.

Hope to help

Giuseppe

Hall of Fame Super Silver

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Hello David,

MPLS TE call admission control works on attempts to setup tunnels.

My guess is that tunnel1 was already up when you have changed rsvp bandwidth on interfaces.

To see this do the following:

shut tunnel1

wait 20-30 seconds

try to unshut tunnel1

this time the tunnel should not be able to come up/up for lack of resources.

Hope to help

Giuseppe

7 REPLIES
New Member

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

The problem was the "tunnel mpls traffic-eng bandwidth 50000" statement.

After I reduced it to 25000 the tunnel came up. My problem is resolved, but I"m not surewhy?

What does that config statement do? Is it related to rsvp?

Hall of Fame Super Silver

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Hello David,

with the command

tunnel mpls traffic-eng bandwidth 50000

you are asking to try to setup a tunnel that will use 50000 kbps = 50 Mbps.

RSVP messages will try to setup a path, but tunnel1 is already setup and has taken resources: if exit interface is an FE there is no space for second tunnel.

on physical interface the command that can tell the total of BW that can be used is:

ip rsvp bandwidth

that accepts parameters see

http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_i1.html#wp1024341

MPLS TE implements call admission control based on this parameter: a new tunnel can be setup if a path end-to-end with the requested resources is available.

To be noted, and this is a big difference with ATM, that this bandwidth parameter has an administrative role, that is on a tunnel with 2 Mbps of declared bandwidth you can put 50 Mbps of traffic, after it has been successfully setup!!

A feature called auto-bandwidth for MPLS TE has been introduced:

http://www.cisco.com/en/US/docs/ios/mpls/configuration/guide/mp_te_auto_bandwdth_ps6441_TSD_Products_Configuration_Guide_Chapter.html

But in real implementations it is important to control at edge what is put on each tunnel to avoid problems.

MPLS TE most liked features are those related to path, link, node protection where with suitable links ( SDH/SONET) or GE links they can provide faster convergence.

http://www.cisco.com/en/US/docs/ios/mpls/configuration/guide/mp_link_node_prot_ps6441_TSD_Products_Configuration_Guide_Chapter.html

Hope to help

Giuseppe

New Member

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Hi Giuseppe,

I'm still very confused...sorry.

I've pasted a copy of the configuration, can you help me understand my questions in the ( ).\

My goal is to have 50% of all traffic go to tunnel1 and 50% to tunnel2.

Thanks a million.

----------------------------------------------------

interface Tunnel1 (how does this tunnel know to use interface fa1/0?)
description lsp rtr1 to rtr3
ip unnumbered Loopback0
tunnel destination 10.0.1.12
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 0 0
tunnel mpls traffic-eng bandwidth  50000 (this is only half of fa1/0, right?)
tunnel mpls traffic-eng path-option 50 dynamic (I don't understand this statement?)
tunnel mpls traffic-eng record-route
no routing dynamic
!
interface Tunnel2 (how does this tunnel know to use interface fa0/0?)
description lsp rtr1 to rtr2 to rtr3
ip unnumbered Loopback0
tunnel destination 10.0.1.12
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 0 0
tunnel mpls traffic-eng bandwidth  50000 (this is only half of fa0/0?)
tunnel mpls traffic-eng path-option 1 explicit name ms_sa26_sa1
tunnel mpls traffic-eng path-option 50 dynamic
tunnel mpls traffic-eng record-route
no routing dynamic
!
interface FastEthernet0/0
description to rtr2
ip address 10.0.3.250 255.255.255.252
speed 100
duplex full
mpls traffic-eng tunnels
ip rsvp bandwidth (default uses 75% of 100Mbps?)
ip rsvp resource-provider none (what does this line mean?)
!
interface FastEthernet1/0
des to rtr3
ip address 119.0.0.1 255.255.255.252
speed 100
full-duplex
mpls traffic-eng tunnels
ip rsvp bandwidth (default uses 75% of 100Mbps?)
ip rsvp resource-provider none

Hall of Fame Super Silver

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Hello David,

I've probably given a too broad answer.

I try to give more focused answers

>> My goal is to have 50% of all traffic go to tunnel1 and 50% to tunnel2.

As I wrote in my first post there is traffic limiting related to bandwidth in a tunnel.

You can use 1 kbps of BW or 50 Mbps with same result.

If you want to have both tunnels up/up  BW_T1 + BW_T2 < 75000 kbps

ip rsvp bandwidth (default uses 75% of 100Mbps?)

yes as explained in command reference link, the first link in my first post.

>> If you enter the ip rsvp bandwidth command without any bandwidth values (for example, ip rsvp bandwidth followed by pressing the Enter key), a default bandwidth value (that is, 75% of the link bandwidth) is assumed for both the interface-kbps and single-flow-kbps arguments.

see http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_i1.html#wp1024341

tunnel mpls traffic-eng path-option 50 dynamic

>> this means a dynamic path is used with priority 50, the lowest value wins. This is typically used as a backup path if a primary explicit path cannot be used for example for lack of resources or because a link or a node is down and it is in the list of the explicit path

about ip rsvp resource-provider none

http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_i2.html#wp1028667

as far as I understand it is not closely related to MPLS TE. I've never used if just to make an example.

Edit:

about path choices of the two tunnels:

tunnel1 uses a dynamic path so it uses the outgoing interface on the best path to tunnel destination

tunnel2 would like to use an explicit path, if the explicit path is correctly describing the desired path it will be used (desired path would out anothe FE) but if the explicit path is not accepted a dynamic path will be used with the risk to try to use the same interface.

I will give a look at your topology

I understand you would like to have tunnel2 going via sa26 and tunnel1 on the direct path.

For some reason, the explicit path is not accepted and both tunnels try to used shortest path.

post sh mpls traffic-eng tunnel2 we should see some information about path calculation.

Hope to help

Giuseppe

New Member

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Hi Giuseppe,

Please see my attachment.

You said that "If you want to have both tunnels up/up  BW_T1 + BW_T2 < 75000 kbps"

In the example below, I have tu1+tu2 =150mbps, but i've reserved only 100mbps (fa0/0+fa1/0) on purpose to replicate the problem.

Shouldn't my tunnel be DOWN since I don't have enough bandwidth for the tunnels?

As you can see both tu1 and tu2 are still up/up. I guess I'm still not understanding the relationship of how my phyiscal interface works witht the virtual tunnels. Thank you.

Hall of Fame Super Silver

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Hello David,

MPLS TE call admission control works on attempts to setup tunnels.

My guess is that tunnel1 was already up when you have changed rsvp bandwidth on interfaces.

To see this do the following:

shut tunnel1

wait 20-30 seconds

try to unshut tunnel1

this time the tunnel should not be able to come up/up for lack of resources.

Hope to help

Giuseppe

New Member

Re: MPLS-TE and OSPF: Tunnel Will Not Come Up

Thanks Giuseppe. I can always rely on you to provide a clear and simple to understand explaination to a complicated topic.

443
Views
0
Helpful
7
Replies