Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS VPN Lab problem with redistribution of CE OSPF networks from the PE

Hi all,

 

I have been creating a GNS3 lab for MPLS VPN and I have the whole thing working end-to-end except that I can't get the PE to redistribute OSPF into BGP

As far as I can see I am doing this correctly but the only network that is redistributing across the WAN is the directly connected network between the CE and PE!

 

Same for both sides so if we can get PE1 side working I can just mirror the cfg for PE2

I have attached the GNS topology drawing and configs

 

Please let me know if you need anything more

 

Thanks in advance

 

Mitchell

Everyone's tags (3)
5 REPLIES
Silver

Could you put:network 10.0.1

Could you put:

network 10.0.1.1 0.0.0.0 area 0

under "router ospf 10 vrf RED"

On PE1 router offcourse...

 

Also check same thing on PE2 please...

HTH,

Dragan

HTH, Dragan
New Member

Hi Dragan,It isn't the

Hi Dragan,

It isn't the network statement as this is covered by the OSPF configuration on the fa1/0 interface itself.

I have however resolved the issue......

If interested I had to add the following to the PE routers:

PE2(config)#router bgp 65000
PE2(config-router)#address-family ipv4 vrf RED
PE2(config-router-af)#redistribute ospf 10 match external

Previously I didn't have the "match external" keywords

 

Cheers for the input

Mitchell

 

 

Silver

Yea great...I missed that -

Yea great...I missed that - you did redistributed loopbacks in OSPF and they are showing as E2 by default wink

Great work...

 

HTH,

Dragan

HTH, Dragan
New Member

Aha... I see why I had to add

Aha... I see why I had to add the "external keyword now"

I have done the following on the CE:

CE1(config)#router ospf 1
CE1(config-router)#no redistribute connected subnets
CE1(config-router)#network 192.168.1.0 0.0.7.255 area 0

 

I have don the following on the PE:

PE1(config)#router bgp 65000
PE1(config-router)#address-family ipv4 vrf RED
PE1(config-router-af)#$10 vrf RED match internal external 1 external 2
PE1(config-router-af)#redistribute ospf 10
 

And this has worked how I was planning from the start - All vrf RED routes redistributed from the CE OSPF showing as standard OSPF O routers and not extenal as before.

Thanks for the insight Dragan, much appreciated

 

Mitchell

Silver

Yes that's the reason behind

Yes that's the reason behind "external"...great...keep up with good labs wink

 

BR,

Dragan

HTH, Dragan
268
Views
5
Helpful
5
Replies
CreatePlease login to create content