Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS VPN over an OSPF Core with Frame Relay.

I have the following scenario going on for an MPLS Lab. The diagram below shows the topology:

lab.png

R1 through R6 are an MPLS core. R1 and R6 are PE routers, R2, R3, R4 and R5 are P routers. Each Frame relay network is a separate subnet.

The core is running OSPF and MPLS is enabled on all interfaces.

My problem has to do with the FR between R1, R2 and R3. In this Configuration, R3 is a spoke, and R1 and R2 are hubs that do not have a direct circuit between them. There is an FR map pointing to R3 for each router to reach the other.

With the OSPF core converged, the I've noticed that the R1 decides to reach R6 through R2 to R5, despite that they are not OSPF neighbors as they do not have a direct FR circuit. When this happens, the CE devices cannot ping each other across the MPLS VPN, and even R1 cannot ping the vrf routes received from R6 and vice versa.

When I take that R2 interface so that it does not neighbor with R3, R1 will then decide to reach R6 thorugh R3 to R4. In this case CE devices can ping each other and R1 can also ping vrf routes received from R6 and vice versa.

I'm not sure what the issue is here. Is the problem related to MPLS switching, with Frame Relay routing, or is this not even a valid scenario to begin with and the FR between R1, R2 and R3 have to be fully meshed?

Also good to note that I've seen it happen that when R3 and R2 have already neighbored, and then I get R1 to neighbor with R3, R1 does not receive any OSPF routes from R3 at all. I had to take down R2 in order for R1 to receive routes.

Any help is appreciated. Thanks

6 REPLIES

Re: MPLS VPN over an OSPF Core with Frame Relay.

hi hesham

could you please post the frame-relay and OSPF configuration from R1, R2, R3?

Marcel

New Member

Re: MPLS VPN over an OSPF Core with Frame Relay.

I have the following:

R1:

     int lo 0

     ip address 120.100.1.1 255.255.255.255

     ip ospf 1 area 0

     int se 0/0

     ip address 120.100.123.1 255.255.255.0

     mpls ip

     mpls label protocol ldp

     ip ospf 1 area 0

     encapsulation frame-relay

     no frame-relay inverse-arp

       frame-relay map ip 120.100.123.3 103 broadcast

       frame-relay map ip 120.100.123.2 103 broadcast

     rouster ospf 1

     router-id 120.100.1.1

R2:

int lo 0

     ip address 120.100.2.1 255.255.255.255

     ip ospf 1 area 0

     int se 0/0

     ip address 120.100.123.2 255.255.255.0

     mpls ip

     mpls label protocol ldp

     ip ospf 1 area 0

     encapsulation frame-relay

     no frame-relay inverse-arp

       frame-relay map ip 120.100.123.1 203 broadcast

       frame-relay map ip 120.100.123.3 203 broadcast

     rouster ospf 1

     router-id 120.100.2.1

R3:

int lo 0

     ip address 120.100.3.1 255.255.255.255

     ip ospf 1 area 0

     int se 0/0

     ip address 120.100.123.3 255.255.255.0

     mpls ip

     mpls label protocol ldp

     ip ospf 1 area 0

     encapsulation frame-relay

     no frame-relay inverse-ar

       frame-relay map ip 120.100.123.1 301 broadcast

       frame-relay map ip 120.100.123.2 302 broadcast

     rouster ospf 1

     router-id 120.100.3.1

Thank you!!

Re: MPLS VPN over an OSPF Core with Frame Relay.

Hmmm, isn't there somethig missing in your config? The default ospf network type is nonbroadcast on a serial link - and without configureing neighbor statements under the OSPF process on R3 OSPF won't establish any neighborships...

So there are two options:

1) On R3 configure neighbors:

router ospf 1

neighbor 120.100.123.1

neighbor 120.100.123.2

2) Change the network type to broadcast and make sure R3 will be the DR

R3:

int s0/0

ip ospf network broadcast

ip ospf priority 100

R1:

int s0/0

ip ospf network broadcast

ip ospf priority 0

R2:

int s0/0

ip ospf network broadcast

ip ospf priority 0

Regards

Marcel

New Member

Re: MPLS VPN over an OSPF Core with Frame Relay.

Hi

I have tried both methods and neither are working. I am completely baffled and have no idea what the issue could be. It is either something with MPLS switching or frame relay.

Having R3 as a hub is definitely causing an issue. If R1's routing table has R2 as the next hop and both R1 and R2 have a direct connection between them everything works. If I take R2 out then R1's routing table shows R3 as the next hop everything also works fine. The problem lies when R1's routing table shows R12as the next hop to R6, but it has to go through R3 as a frame relay hub, vrf routes cannot be pinged any more.

I have tried all sorts of debugs I can think of but cannot get the information I need to see how the packet is flowing. Do you at least know what debugs I can use to troubleshoot?

Thanks

Re: MPLS VPN over an OSPF Core with Frame Relay.

could you please post the following outputs from R1, R2, R3, R6:

sh frame map

sh ip ospf int

sh ip ospf nei

sh mpls int

sh mpls ldp nei

and also the bgp configurations

New Member

MPLS VPN over an OSPF Core with Frame Relay.

MPLS VPN over frame-relay appeared to have a hitch...at least with what I was doing.

The problem appeared to be with MP-BGP...the packets do not get tagged with the LDP header in a broadcast or non-broadcast OSPF network.  On your Frame-Relay interfaces, use the network type of point-to-multipoint so that a full adjacency is created and the specific /32's are injected.

Additionally, within BGP, you may have to use the command:

router bgp (your AS)

no bgp default ipv4-unicast

921
Views
0
Helpful
6
Replies
CreatePlease login to create content