Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

mpls

I have 2 router (7602 VXR) and configured mpls but it cannot see the neighbor,below are my configs. what could be a problem.

R1

!

ip cef

!

!

!

interface ATM3/0.100 point-to-point

ip address 165.148.120.2 255.255.255.252

no atm enable-ilmi-trap

mpls label protocol ldp

mpls ip

pvc 1/100

encapsulation aal5snap

!

!

router ospf 1

log-adjacency-changes

network 165.148.120.0 0.0.0.3 area 0

network 192.5.1.0 0.0.0.255 area 0

!

R2

!

ip cef

!!

interface ATM1/0.100 point-to-point

ip address 165.148.120.1 255.255.255.252

mpls label protocol ldp

mpls ip

pvc 1/100

encapsulation aal5snap

!

!

!

router ospf 1

log-adjacency-changes

network 165.148.120.0 0.0.0.3 area 0

network 192.1.1.0 0.0.0.255 area 0

!

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: mpls

Hello Lawrence,

you need

mpls ip

in global config mode

you can use

sh mpls int

sh mpls ldp disc

to troubleshoot LDP

sh mpls forwarding

Hope to help

Giuseppe

12 REPLIES
Hall of Fame Super Silver

Re: mpls

Hello Lawrence,

you need

mpls ip

in global config mode

you can use

sh mpls int

sh mpls ldp disc

to troubleshoot LDP

sh mpls forwarding

Hope to help

Giuseppe

New Member

Re: mpls

I tried all of above but still no luck, i'm so confused. I started with this problem ever since this morning

Hall of Fame Super Gold

Re: mpls

If you eliminate mpls, does it work ?

Re: mpls

Make sure you include the MPLS RouterID in your IGP (commonly forgotten) and consider using also the command "mpls ldp router-id" to make sure you know what your MPLS RouterID is supposed to be.

Hall of Fame Super Silver

Re: mpls

Hello Lawrence,

post the output of

sh mpls ldp discovery

on both routers

Hope to help

Giuseppe

New Member

Re: mpls

Hi everyone

My problem here was i completely forgot to include my loopback on the router protocol advertisements. if you can check I was using OSPF, little thing might cost you an arm and a leg.

Thanks for all the efforts in trying to help and I truly appreciate that.

Re: mpls

You might have rated a post with a 1.0 by mistake, but for your reference this is considered an insult in this forum...

New Member

Re: mpls

Hi Giuseppe Larosa

I wanted to rate you at 3 but I truly don't know what happened. I was only made aware now by maria if you can refer to other posts on these same topic.

No offence or sarcasm intended, I truly apologise and I tried to rectify this but the rating don't go under your name.

If you know me or have seen all my comments you can see that i truly appreciate people that take an effort to try and help others and please keep up the good work. Don't let little things disturb/shift your focus and never stop being good as you are at this stage.

Re: mpls

Don't worry. Most people that kept responding here understood this was a mistake. We also keep responding even in situations where the comments are not so good. I told you about this only to inform you to be more careful. I came here to rectify the 1.0 situation with my own vote since Guiseppe definitely does not deserve a 1.0 . I just didn't think of this earlier. I did the math when you said 3 (5+1)/2=3 and we are now all set, although Guiseppe's average will require more votes to be straight back, but I am sure he will rectify this soon on his own :-)

Also, I came here to comment on your technical issue. OSPF does not require the RouterID to be advertised by OSPF (OSPF internal procedures figure things out), unless you are trying to specifically ping the RID. MPLS on the other hand requires the MPLS RID to be in the IGP (OSPF in your case) or MPLS neighbors will not be formed. The loopback you mentioned is probably the MPLS RID. I am not saying this to emphasize how I detected your issue, but to make you aware of the reasons that caused the issue and why it was resolved. In every case you come across, try to make conclusions about such things.

Hall of Fame Super Silver

Re: mpls

Hello Lawrence,

no problem at all it was strange to see an answer rated 1 and flagged as solved

You are wellcome

Best Regards

Giuseppe

New Member

Re: mpls

Thanks, that made me feel better.

Maria thanks to you too.

Re: mpls

Guiseppe described very well the reason we understood it was a mistake. He said it was strange, but when I saw just the title of the conversation being resolved with one vote of 1.0, I thought that this case must be funny! :-)

Also, avoid marking your issue as resolved before it actually is, because it might cause some people to prefer to read something that has not been resolved yet and leave the resolved for later reading.

246
Views
18
Helpful
12
Replies