Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

MPPE encryption over a multi-link interface

Hi,

I am trying to implement encryption over a multi-link interface using MPPE. I am running EIGRP over the multi-link interface and using ms-chap for authentication. The problem is until the point I use MPPE, all works fine and eigrp routes are populated either side. But the moment I use MPPE encryption, EIGRP starts to flap often and the EIGRP routes get removed from the RIB on both routers.

R5

interface Multilink1

ip address 10.1.56.6 255.255.255.0

ppp authentication ms-chap

ppp chap hostname HOSTR6PAP

ppp chap password 0 password

ppp multilink

ppp multilink group 1

router eigrp 10

network 5.5.5.5 0.0.0.0

network 10.1.45.5 0.0.0.0

network 10.1.56.5 0.0.0.0

no auto-summary

R6

interface Multilink1

ip address 10.1.56.5 255.255.255.0

ppp authentication ms-chap

ppp chap hostname HOSTR5PAP

ppp chap password 0 password

ppp multilink

ppp multilink group 1

router eigrp 10

network 6.6.6.6 0.0.0.0

network 10.1.56.6 0.0.0.0

network 66.66.66.66 0.0.0.0

no auto-summary

Now the moment I add the command "ppp encrypt mppe 128 require" to R5 and R6, EIGRP starts to flap often and the eigrp routes get removed from the RIB. Could anybody please advise what am I failing to understand?

Regards,

Nilesh

Everyone's tags (4)
265
Views
0
Helpful
0
Replies
CreatePlease to create content