Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

MSDP RPF Rule

I would like to know which rpf rule in msdp will my following setup follow from the following

•Rule 1: Applied when the sending MSDP peer is also an interior (M)BGP peer.

•Rule 2: Applied when the sending MSDP peer is also an exterior (M)BGP peer.

•Rule 3: Applied when the sending MSDP peer is not an (M)BGP peer.

Step is

R3 s1/2 (13.0.0.2) connected to R1 s1/2 (13.0.0.1 (for Unicast)

R3 s1/0 (31.0.0.2) connected to R s1/0 (31.0.0.1) (multicast)

R3

interface Loopback0
ip address 33.33.33.33 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback10
ip address 40.0.0.1 255.255.255.255

router ospf 1
log-adjacency-changes
network 33.33.33.33 0.0.0.0 area 0
  default-information originate

router bgp 100
bgp log-neighbor-changes
neighbor 13.0.0.1 remote-as 200
neighbor 31.0.0.1 remote-as 200
  !
address-family ipv4
neighbor 13.0.0.1 activate
  no neighbor 31.0.0.1 activate
no auto-summary
no synchronization
network 40.0.0.1 mask 255.255.255.255
exit-address-family
!
address-family ipv4 multicast
neighbor 31.0.0.1 activate
  no auto-summary
no synchronization
network 33.33.33.33 mask 255.255.255.255
exit-address-family
!
ip http server
!
!
ip pim send-rp-announce Loopback0 scope 255
ip pim send-rp-discovery Loopback0 scope 255
ip msdp peer 50.0.0.1 connect-source Loopback10
!
!

R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 230.0.0.1
!
interface Loopback10
ip address 50.0.0.1 255.255.255.255

router ospf 1
log-adjacency-changes
network 11.11.11.11 0.0.0.0 area 0
!
router bgp 200
bgp log-neighbor-changes
neighbor 13.0.0.2 remote-as 100
  neighbor 31.0.0.2 remote-as 100
!
address-family ipv4
neighbor 13.0.0.2 activate
no neighbor 31.0.0.2 activate
no auto-summary
no synchronization
network 50.0.0.1 mask 255.255.255.255
exit-address-family
!       
address-family ipv4 multicast
neighbor 31.0.0.2 activate
no auto-summary
no synchronization
exit-address-family
!
ip http server
!
!
ip msdp peer 40.0.0.1 connect-source Loopback10

2 REPLIES
Hall of Fame Super Silver

Re: MSDP RPF Rule

Hello Ryel,

multicast traffic sourced by 33.33.33.33 should arrive on the second serial link. If so it should pass the RPF check.

The first link is used for unicast routing, including advertisements of the MSDP endpoints and so also for the MSDP session

MSDP role is only that of advertising possible sources of multicast traffic like 33.33.33.33.

I would say case 2, because RPF check can be passed thanks to MP-BGP AF ipv4 multicast that is used to be able to differentiate the path between unicast traffic and multicast traffic.

you can use sh  ip rpf 33.33.33.33 on R1 to check this.

Hope to help

Giuseppe

Re: MSDP RPF Rule

Hi ryle

in your intial post when you were having a problem with the setup and we got it resolved

https://supportforums.cisco.com/message/2007451#2007451

the RPF check was failing i think this is mostly becuase 33.33.33.33 is seen by R1 as RP as well

but it is not seen through the multicast link ( only though the unicast link) >> RPF failed

however if you stop the RP messages from beign exchanged between the two domains and allow only MSDP as the inter domain multicasting ( which is the best practice as will ) the 33.33.33.33 will not be aproblem as lon as you are using the directly connected interfaces between R3 and R1 as the MSDP connection source

in other words if you dont advertise it (33.33.) in MBGP your topology will work

good lcuk

1278
Views
0
Helpful
2
Replies
CreatePlease to create content