Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Multi home BGP and static routes

I have a router that has multihome BGP running on it. I was told that since we are running multihome BGP I need to create a static route for this to work.

Well I did that but I don't think I did it right as now the routes aren't learn via bgp but via static route. Attached is my config along with the static routes commands. The one highlighted in blue is the one I'm concerned about. I take the static route out and I cannot ping 10.128.184.105.

10 REPLIES
Silver

Re: Multi home BGP and static routes

That is correct, you need to have static route pointing to a null0 or loopback interface.

in the bgp config you then can use the redistribute static, this will put those routes into the bgp announcement.

Silver

Re: Multi home BGP and static routes

here is a link with sample config that explains this too.

http://www.cisco.com/warp/public/459/40.html

New Member

Re: Multi home BGP and static routes

ok I must not know how to look things up

I was trying to find something like this but wasn't able to thus the post. Thank you sir!!!! this is what I was looking for will read it and implement it. Thanks again!!!!!!

Silver

Re: Multi home BGP and static routes

I understand what you are saying. Everytime I look for something I never find it, then post what I need and someone finds it.

I just did a search on BGP Sample Configurations on Yahoo.com

New Member

Re: Multi home BGP and static routes

Sorry maybe I explained it wrong I have a single router that has mutlihomed BGP connections on it. The connection 10.128.184.105 is not directly connected I can get to it if I put a static route via the ethernet address using my loopback address as the update sourece. I have the static route how do I get it to advertise over the BGP connection I read over the link but maybe I'm missing something.

Silver

Re: Multi home BGP and static routes

a static route will ensure that the route will never go down, if pointing to null0, and will make sure that the route will always be announced, it also helps with route flapping too. Keep in mind that the router has to have some way of knowing how to get to the network. If the router does not know how to route it will not be announced.

It is not a requirement but a good practice. I have had this issue and not 100% sure why it happens, I just know that if my routes do not announce I add the static route of the block pointing to null0 and it forces the redistibution of the route.

New Member

Re: Multi home BGP and static routes

Sorry I just confused myself completely. Ok so what you are telling me is that because I have a single router that has multihomed BGP connection I will need to add a static route for this connection. I'm peering with AS64637 and address of 10.128.184.105 and to get to that IP I need to go through the ethernet address of 172.19.80.10. So I will need a static route to point to that:

ip route 10.128.184.105 255.255.255.255 172.19.80.10

now all I need to do is redistribute that into BGP so that the peers will connect

right? So inorder for me to redistribute I need to do something like

redistribute static

This will go under my BGP statements. Thanks for putting up with me I appreciate it!!

Silver

Re: Multi home BGP and static routes

I would recommend pointing the static to null0

ip route 10.128.184.105 255.255.255.255 null0

router bgp XXXXX

redistribute static

then verify the announcement

sh ip bgp neigh x.x.x.x adv

This will show you which routes are being advertised to this neighbor.

You might want to use a prefix-list and route-map to specify this announcement out the correct neighbor unless you want this announced to all peers.

does that make sense?

I am a little rusty with BGP, been a few years since I have had to look at it, like 4 years

Silver

Re: Multi home BGP and static routes

not sure if this explains it but saw this and thought it was interesting to note

router bgp 10

neighbor 1.1.1.1 remote-as 11

neighbor 1.1.1.1 update-source loopback 0

!--- Use the IP address of the loopback interface for TCP connections.

neighbor 1.1.1.1 ebgp-multihop

!--- You must configure ebgp-multihop whenever the eBGP connections

!--- are not on the same network address.

router eigrp 12

network 2.0.0.0

network 150.10.0.0

network 160.20.0.0

no auto-summary

Note: You can use static routes in the place of a routing protocol in order to introduce two equal-cost paths to reach the destination. In this case, the routing protocol is EIGRP.

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml

New Member

Re: Multi home BGP and static routes

You know what the 10.128.184.105 is a route advertised by the distant end and not me I have maybe if I'm still confused I will open up a TAC case as I have taken up enough of your time.

300
Views
0
Helpful
10
Replies
CreatePlease to create content