Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multicast Across The Frame

I am having a multicast issue. I can receive the stream on all of my Vlans internally, but the issue comes in when our satelite sites try to receive the stream across the Frame. Can anyone help me I think my issue is in the configuration on the satelite site router can someone help me with the config or point me in the direction of a standard config. Thanks.

8 REPLIES
VIP Purple

Re: Multicast Across The Frame

Hello,

when you say frame, does that mean Frame Relay ? If possible, can you post the configuration of your router ?

Regards,

GP

New Member

Re: Multicast Across The Frame

Yes, I am talking about the frame-relay all of our sites are connected to the frame-relay. Also we have made the 6509 here at HQ the RP for the whole MCast network. I am posting the config with all the sections that have multicast lines in it....

no ip bootp server

ip multicast-routing

interface FastEthernet0/0

ip address 15.1.1.2 2.2.5.0

ip access-group 199 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

speed 100

full-duplex

no cdp enable

!

interface Serial0/0

description Frame Relay

bandwidth 256

no ip address

ip pim sparse-mode

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0.5 point-to-point

description EPVC TO AT&T

bandwidth 256

ip address 1.1.5.1 5.2.2.2

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

no cdp enable

frame-relay interface-dlci 501 IETF

ip classless

no ip http server

ip pim rp-address 15.1.1.2

Also I am posting the MCast routing table....

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report

Outgoing interface flags: H - Hardware switched

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.254), 2w2d/00:01:57, RP 1.1.1.2, flags: SJC

Incoming interface: Serial0/0.5, RPF nbr 0.0.0.0

Outgoing interface list:

FastEthernet0/0, Forward/Sparse, 2w2d/00:01:57

(*, 224.0.1.40), 7w0d/00:02:59, RP 1.1.1.2, flags: SJCL

Incoming interface: Serial0/0.5, RPF nbr 0.0.0.0

Outgoing interface list:

FastEthernet0/0, Forward/Sparse, 7w0d/00:02:59

(*, 224.0.1.60), 7w0d/00:02:54, RP 1.1.1.2, flags: SJC

Incoming interface: Serial0/0.5, RPF nbr 0.0.0.0

Outgoing interface list:

FastEthernet0/0, Forward/Sparse, 7w0d/00:02:54

Please let me know your thoughts on this. Just to recap all I can get the stream going to everybody here at HQ but at our sites in different locations I can't get the feed to any of those sites.

Bronze

Re: Multicast Across The Frame

Hi,

check with your provider if there are any intermediate devices unable (or unconfigured) to forward multicast traffic. If that is the case, you will need to build a tunnel over which to route the multicast traffic. Post the config of the remote site as well, and I´ll help you with the details.

Another question: is there IP reachability from your remote sites to the RP ? Can the remote sites ping the RP (address) ?

Nethelper

New Member

Re: Multicast Across The Frame

Ureka! My provider does not forward multicast traffic they said I have to build a GRE Tunnel. What is a gre tunnel? and what is it used for?

Bronze

Re: Multicast Across The Frame

Hello,

basically, a GRE tunnel is a way to get traffic through a network of devices with actually configuring those devices to support, in your case, multicast traffic. Since I do not know the exact configurations of your routers, here is a sample configuration:

Router1

!

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Tunnel0

ip addresss 192.168.1.1 255.255.255.252

ip pim sparse-mode

tunnel source Loopback0

tunnel destination 172.16.1.2

!

ip mroute 0.0.0.0 0.0.0.0 Tunnel0

Router2

!

interface Loopback0

ip address 2.2.2.2 255.255.255.0

!

interface Tunnel0

ip addresss 192.168.1.2 255.255.255.252

ip pim sparse-mode

tunnel source Loopback0

tunnel destination 172.16.1.1

!

ip mroute 0.0.0.0 0.0.0.0 Tunnel0

In this example, network 172.16.1.0/30 is used for the IP addresses of the interfaces connecting your two routers. The tunnel IP addresses are arbitrary. If you have Loopback interfaces configured on your routers, you can use these addresses, otherwise it is recommended to create Loopback interfaces, the IP addresses are arbitrary as well.

Let me know if you run into trouble.

Regards,

Nethelper

New Member

Re: Multicast Across The Frame

One more thing, I have 80+ sites and 1 RP am I to build 80 tunnels going to one switch (I am referring to the 6509 at HQ). Meaning are all my remote sites supposed to have 80 separate tunnels going to one switch or can one tunnel from the 6509 in HQ service all of the remote sites.

Bronze

Re: Multicast Across The Frame

Hello,

unfortunately, tunnels are point-to-point links, so you indeed would need to configure 80+ tunnel endpoints on the 6509, and one tunnel interface each on the remote sites. The 6509 should be able to handle this easily though.

Regards,

Nethelper

New Member

Re: Multicast Across The Frame

Thanks for all the help.

110
Views
5
Helpful
8
Replies
CreatePlease login to create content