Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

multicast problem

We are currently trying to get a multicast setup to work, but to no avail. Below the setup of the configuration.

                                                  ##################                                      ##############
multicast source <--> gi0/0/0    # Cisco ISR 2911      #    gi0/0 <--> gi2/0/12    # Cisco 3750     #    --> connected in a star to several 2960 switches
                                                  ##################                                      # IP Base           #
                                                                                                                            ##############   

The router has a separate VRF for the multicast connections, which includes the interfaces gi0/0 and gi0/0/0, both L3 interfaces. Static routing is configured for the multicast
 source and the networks defined on the 3750 switch. The multicast source entries are learned by IGMP v3 and PIM-SM is configured on both interfaces. The router is further configured as static RP for it's gi0/0 interface.
The 3750 switch uses PIM stub routing for the multicast routing. Interface gi2/0/12 is configured as sparse-dense mode and the SVI interfaces for the MC receivers are configured as passive mode. IGMP snooping is enabled on the SVI interfaces and build the tree with the help of IGMPv3 reports and join messages. The PIM routing and IGMP subscription looks fine, but the receivers do not revceive the stream.
An ip packet debug on the switch reveals the following output, which likely indicates the stream cannot be correctly routed:

Sep 14 09:12:28.556: FIBipv4-packet-proc: route packet from GigabitEthernet2/0/12 src 10.18.15.23 dst 239.232.223.21
Sep 14 09:12:28.564: FIBfwd-proc: Default:224.0.0.0/4 multicast entry
Sep 14 09:12:28.564: FIBipv4-packet-proc: packet routing failed
Sep 14 09:12:28.564: FIBipv4-packet-proc: route packet from GigabitEthernet2/0/12 src 10.18.15.23 dst 239.232.223.21
Sep 14 09:12:28.564: FIBfwd-proc: Default:224.0.0.0/4 multicast entry
Sep 14 09:12:28.564: FIBipv4-packet-proc: packet routing failed
Sep 14 09:12:28.564: FIBipv4-packet-proc: route packet from GigabitEthernet2/0/12 src 10.18.15.23 dst 239.232.223.21
Sep 14 09:12:28.564: FIBfwd-proc: Default:224.0.0.0/4 multicast entry
Sep 14 09:12:28.564: FIBipv4-packet-proc: packet routing failed

Does anybody have any clue what the cause could be of this behavior?

######################

# Cisco 2911 Router relevant configuration

ip vrf IPTV
ip multicast-routing vrf IPTV

class-map type multicast-flows classMapTelenetMulticastIPs
 group 239.232.209.1 to 239.232.209.254 source 10.18.15.23
 group 239.232.223.1 to 239.232.223.254 source 10.18.15.23
exit

interface GigabitEthernet0/0
 description IPTV_L3portCSW1-gi2/0/12
 ip vrf forwarding IPTV
 ip address 172.28.20.129 255.255.255.252
 ip pim sparse-mode
 duplex full
 speed 1000
exit

interface GigabitEthernet0/0/0
 ip vrf forwarding IPTV
 ip address 195.130.130.242 255.255.255.240
 ip pim sparse-mode
 ip igmp static-group class-map classMapTelenetMulticastIPs
 ip igmp version 3
 duplex full
 speed 1000
 media-type rj45
exit

ip pim vrf IPTV rp-address 172.28.20.129
ip pim vrf IPTV register-source GigabitEthernet0/0/0
ip pim vrf IPTV ssm default

ip route vrf IPTV 0.0.0.0 0.0.0.0 Null0 name defRouteBlackHole
ip route vrf IPTV 10.18.15.23 255.255.255.255 GigabitEthernet0/0/0 195.130.130.241 name IPTV-BCC-source
ip route vrf IPTV 10.20.16.0 255.255.240.0 GigabitEthernet0/0 172.28.20.130 name IPTV-Receivers

#####

# Cisco 2911 Router output

RTR2#sh ip mroute vrf IPTV 239.232.209.21
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.232.209.21), 01:07:41/00:03:13, RP 172.28.20.129, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet0/0, Forward/Sparse, 00:02:30/00:03:13
    GigabitEthernet0/0/0, Forward/Sparse, 01:07:41/00:01:17

(10.18.15.23, 239.232.209.21), 01:07:41/00:01:37, flags: T
  Incoming interface: GigabitEthernet0/0/0, RPF nbr 195.130.130.241
  Outgoing interface list:
    GigabitEthernet0/0, Forward/Sparse, 00:02:30/00:03:15

##

RTR2#sh ip mfib vrf IPTV active 
Active Multicast Sources - sending >= 4 kbps
VRF IPTV
Group: 239.232.209.21
  Source: 10.18.15.23,
   SW Rate: 938 pps/9850 kbps(1sec), 3435 kbps(last 4111 sec)

##

RTR2#sh ip mroute vrf IPTV 239.232.209.21 count 
Use "show ip mfib count" to get better response time for a large number of mroutes.

IP Multicast Statistics
593 routes using 339394 bytes of memory
510 groups, 0.16 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.232.209.21, Source count: 1, Packets forwarded: 25131, Packets received: 31026
  RP-tree: Forwarding: 0/0/0/0, Other: 0/0/0
  Source: 10.18.15.23/32, Forwarding: 25131/939/1344/10104, Other: 31026/0/5895


######################

# Cisco 3750 Switch relevant configuration

ip multicast-routing distributed

interface GigabitEthernet2/0/12
 description IPTV_L3portRTR2-gi0/0
 no switchport
 ip address 172.28.20.130 255.255.255.252
 ip pim sparse-mode
exit

interface Vlan720
 description IPTV-receivers
 ip address 10.20.20.1 255.255.255.0
 ip helper-address 10.1.5.210
 ip helper-address 10.20.5.210
 ip pim passive
 ip igmp version 3
exit

ip pim rp-address 172.28.20.129
ip pim ssm default

ip route 10.18.15.23 255.255.255.255 GigabitEthernet2/0/12 172.28.20.129 name IPTV-BCC-via-RTR2_gi0/0
ip route 195.130.130.240 255.255.255.240 GigabitEthernet2/0/12 172.28.20.129 name IPTV-via-RTR2_gi0/0

#####

# Cisco 3750 Switch output

CSW1#show ip mroute 239.232.209.21
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, 
       Z - Multicast Tunnel, z - MDT-data group sender, 
       Y - Joined MDT-data group, y - Sending to MDT-data group, 
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.232.209.21), 00:32:51/stopped, RP 172.28.20.129, flags: SJC
  Incoming interface: GigabitEthernet2/0/12, RPF nbr 172.28.20.129
  Outgoing interface list:
    Vlan720, Forward/Sparse-Dense, 00:01:31/00:02:57

(10.18.15.23, 239.232.209.21), 00:32:51/00:02:57, flags: JT
  Incoming interface: GigabitEthernet2/0/12, RPF nbr 172.28.20.129
  Outgoing interface list:
    Vlan720, Forward/Sparse-Dense, 00:01:31/00:02:57

##

CSW1#show ip mroute 239.232.209.21 count 
IP Multicast Statistics
5 routes using 2616 bytes of memory
4 groups, 0.25 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.232.209.21, Source count: 1, Packets forwarded: 560, Packets received: 375
  RP-tree: Forwarding: 1/0/1/0, Other: 0/0/0
  Source: 10.18.15.23/32, Forwarding: 559/1/901/0, Other: 375/0/0

Everyone's tags (1)
3 REPLIES
New Member

After some more debugging

After some more debugging (debug ip mrouting), we also see the following behaviour:

Sep 16 11:36:53.384: MRT(0): Update (*,239.232.209.21), RPF GigabitEthernet2/0/12/172.28.20.129
Sep 16 11:36:53.384: MRT(0): Set the C-flag for (*, 239.232.209.21)
Sep 16 11:36:53.384: MRT(0): WAVL Insert interface: Vlan720 in (* ,239.232.209.21) Successful
Sep 16 11:36:53.384: MRT(0): Add Vlan720/239.232.209.21 to the olist of (*, 239.232.209.21), Forward state - MAC not built
Sep 16 11:36:53.384: MRT(0): WAVL Insert interface: Vlan720 in (10.18.15.23,239.232.209.21) Successful
Sep 16 11:36:53.384: MRT(0): Add Vlan720/239.232.209.21 to the olist of (10.18.15.23, 239.232.209.21), Forward state - MAC not built
Sep 16 11:37:00.565: MRT(0): Update (*,239.232.209.21), RPF GigabitEthernet2/0/12/172.28.20.129
Sep 16 11:37:00.565: MRT(0): Update Vlan720/239.232.209.21 in the olist of (*, 239.232.209.21), Forward state - MAC not built
Sep 16 11:37:00.565: MRT(0): Update Vlan720/239.232.209.21 in the olist of (10.18.15.23, 239.232.209.21), Forward state - MAC not built

Googling around does not provide any clue till now...

New Member

After adjusting some

After adjusting some configuration the stream is now flowing to the receivers. The above messages (Forward state - MAC not built) however are still present, so I assume these can be ignored.

New Member

Hello, may I ask what

Hello, may I ask what adjustments you made? We're having the same problem today with "Default:224.0.0.0/4 multicast entry FIBipv4-packet-proc: packet routing failed", and we're trying to figure out what the issue is.

Thanks.

391
Views
0
Helpful
3
Replies
CreatePlease to create content