Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multicast routing help needed..

My customer has a webcast server in one of their data cetners that needs to send multicasts out to all of their offices over the WAN. So far, I have been unable to get this to work. All of their locations connect into our MPLS and have their own VRF for the entire company. The source server as well as each site is on a different vlan. Below is the config i am using for each site, as well a mtrace from a client router. If you have any questions please let me know. Any information you can provide me on getting this to work will be appreciated.

422GEN139-rtr-2801#mtrace 10.2.19.205 10.254.190.130 239.192.19.76

Type escape sequence to abort.

Mtrace from 10.2.19.205 to 10.254.190.130 via group 239.192.19.76

From source (?) to destination (?)

Querying full reverse path...

0  10.254.190.130

-1  10.254.190.1 PIM/Static  [default]

-2  192.168.112.254 PIM Reached RP/Core [10.2.19.205/32]

//CPE device (site with server)

conf t

ip multicast-routing

interface Tunnel0

!! GRE_Tunnel_IP_ADDRESS

ip address 192.168.112.3 255.255.255.0

ip mtu 1400

ip pim sparse-mode

ip nhrp map 192.168.112.254 1.187.8.1                                   !! HUB_GRE_IP_ADDRESS / HUB_LOOPBACK_ADDRESS

ip nhrp network-id 100                                                 !! SAME FOR ALL ROUTERS

ip nhrp nhs 192.168.112.254                                       !! HUB_GRE_IP_ADDRESS

tunnel source 1.187.9.6                                                !! GRE_SOURCE_IP_ADDRESS

tunnel destination 1.187.8.1                                       !!GRE_DESTINATION_IP_ADDRESS

!! Configure PIM SPARSE MODE on LAN interface

interface FastEthernet0/0 

ip address 10.254.244.1 255.255.255.0

ip pim sparse-mode

!! RP Address - HUB_LOOPBACK_INTERFACE.  ALL Multicast routers (including customer multicast routers) need to be configured same RP address. Check if they are using automatic RP assignment (AUTO RP or BSR). Here I assigned RP manually.

ip pim rp-address 1.187.8.1  

!! RP address should be reachable through GRE tunnel for RPF check

ip mroute 1.187.8.1 255.255.255.255 Tunnel0

// HUB/RP router

conf t

ip multicast-routing

interface Loopback0

ip address 1.187.8.1 255.255.255.255

ip pim sparse-mode

interface Tunnel0

ip address 192.168.112.254 255.255.255.0

ip mtu 1400

ip pim nbma-mode                                         !! PIM NBMA mode need to be configured on HUB

ip pim sparse-mode

ip nhrp map multicast dynamic

ip nhrp network-id 100

tunnel source 1.187.8.1

tunnel mode gre multipoint                        !! GRE multipoint mode is on HUB

ip pim rp-address 1.187.8.1

!! Multicast Source address should be reachable through GRE tunnel for RPF check

ip mroute 10.254.244.100 255.255.255.255 192.168.112.3

//CPE device (END USER)

conf t

ip multicast-routing

interface Tunnel0

!! GRE_Tunnel_IP_ADDRESS

ip address 192.168.112.6 255.255.255.0

ip mtu 1400

ip pim sparse-mode

ip nhrp map 192.168.112.254 1.187.8.1                                   !! HUB_GRE_IP_ADDRESS / HUB_LOOPBACK_ADDRESS

ip nhrp network-id 100                                                 !! SAME FOR ALL ROUTERS

ip nhrp nhs 192.168.112.254                                       !! HUB_GRE_IP_ADDRESS

tunnel source 1.187.8.24                                              !! GRE_SOURCE_IP_ADDRESS

tunnel destination 1.187.8.1                                       !!GRE_DESTINATION_IP_ADDRESS

!! Configure PIM SPARSE MODE on LAN interface

interface FastEthernet0/0 .1

ip address 10.254.120.1 255.255.255.0

ip pim sparse-mode

interface FastEthernet0/0 .5

ip address 10.252.120.1 255.255.255.0

ip pim sparse-mode

interface FastEthernet0/0 .66

ip address 10.250.120.1 255.255.255.0

ip pim sparse-mode

!! RP Address - HUB_LOOPBACK_INTERFACE.  ALL Multicast routers (including customer multicast routers) need to be configured same RP address. Check if they are using automatic RP assignment (AUTO RP or BSR). Here I assigned RP manually.

ip pim rp-address 1.187.8.1  

!! RP address should be reachable through GRE tunnel for RPF check

ip mroute 1.187.8.1 255.255.255.255 Tunnel0

292
Views
0
Helpful
0
Replies