Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multicasting... not working

Hi guys,

I am busy setting up a router that connects to an Arista switch. We need to provide multicast to the clients on myside of the network... So far i havent been able to get anything to work could you advise me further maybe ?

The people controlling the switch arent very helpfull with info.

Effectively i need to provide data from the multicast group 224.16.0.1 - the arista switches ip is 10.10.10.2 

 

Here is my config:


Current configuration : 3486 bytes
!
! Last configuration change at 08:51:02 UTC Fri Jul 11 2014 by csadmin
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname filmriss01
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
!
ip cef
!
!
!
!
!
!
ip domain name yourdomain.com
ip multicast-routing
no ipv6 cef
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-2366338758
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2366338758
 revocation-check none
 rsakeypair TP-self-signed-2366338758
!
!
crypto pki certificate chain TP-self-signed-2366338758
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32333636 33333837 3538301E 170D3133 31323035 30393237
  33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 33363633
  33383735 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B869 EC844B73 36D55E8F 80831DAA 5460C3DE 39637ED2 5404AF0E 4987EFD7
  F83BE670 6BDEFE9D 68472D05 2A7C67E3 963CD22B A4693EC9 BE546F17 14F3F995
  B7F91091 ECF2115E 8866CB8D BE454C3F 7BD3738A 9B1364B1 D1A5E192 64D8B3B1
  5234446E 8089E1F7 66C7FEC0 4CE9B4E1 23DB9A1F 6F971047 49BC9DF8 5B2DF371
  059D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 146ABEF2 46CA3A71 BB54D1EE 8E9B4F6C F4BE214D 27301D06
  03551D0E 04160414 6ABEF246 CA3A71BB 54D1EE8E 9B4F6CF4 BE214D27 300D0609
  2A864886 F70D0101 05050003 81810091 84B2FE33 023CFC38 89A1D05C 56BFD18A
 1012F5F8 2810874B 86EF6B90 D0ACF995 A83AF958 CF10CC3E 7D488ECA 523F85BE
  EDFE51FA 5F5E6C87 48748603 29B35579 ED5CD6AF 609854BB F36EB395 A0197CDE
  E55237E6 009601AF 15388F1F 6551408A 66786BE8 CF8FC175 5F1F82DC 7D672AF2
  32719387 2889E930 58297017 5CDBC6
        quit
license udi pid CISCO1941/K9 sn FCZ1749C3JA
!
!
username csadmin privilege 15 secret 4 wcJZ1e5HN/8BmBhtmA3AdeQ3GIT.XcCPTFnmGp2do1Q
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Local clients
 ip address 172.16.1.240 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface GigabitEthernet0/1

decriptsion link to arista
 ip address 10.10.10.1 255.255.255.252
 ip pim sparse-mode
 ip ospf network point-to-point
 duplex auto
 speed auto
!
router ospf 1
 router-id 10.10.10.1
 redistribute static
 network 172.16.1.0 0.0.0.255 area 0.0.0.100
!
ip default-gateway 10.10.10.2
ip forward-protocol nd
!
ip http server
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip pim rp-address 10.10.10.2
ip route 0.0.0.0 0.0.0.0 10.10.10.2
!
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 23 permit 172.16.1.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

 

 

 

PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.10.10.2        GigabitEthernet0/1       16:56:14/00:01:28 v2    1 / DR G

 

PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.10.10.2        GigabitEthernet0/1       16:56:14/00:01:28 v2    1 / DR G

 

They have given me the port conf from the arista that i am connected to:

interface Ethernet23
   description Uplink
   no switchport
   ip address 10.10.10.2/30
   ip ospf network point-to-point
   ip pim sparse-mode
!

Any ideas ?

 

 

 

Everyone's tags (1)
85
Views
0
Helpful
0
Replies
CreatePlease login to create content