Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Multihoming with BGP and load sharing

Hi Guys,

Got 2 t1's to ISP A and metro ethernet to ISP B

running bgp, and have the 2 t1's using load sharing however they dont seem to be sharing the traffic..can anyone point me in direction of any sample configs, or some things that need to be done to make this work?

thanks!

6 REPLIES

Re: Multihoming with BGP and load sharing

Hi,

The easiest way to get the Load Sharing on the Internet Links is to divide the traffic from the point of origin i.e. using the VLAN-s / Proxy Servers from where the traffic is originating and then pointing it to the respective T-1s.

Also, if you want to you want to use the Fault-Tolerance you may do some additional config (using the PBR with Static Route Redist.) as the moment one of the T-1 would go down, the Router would purge the static route from the Routing Table and then same could be injected into the WAN-Edge switch.

Also, if you want to go ahead with Loab Balancing, Load Sharing and Fault Tolerance all in one, I guess the best bet would be to use a Raware Device for this.

Please get back if you want more details on the Load Sharing using the PBR, we have been using the same in one of our customer's side.

Regards,

Wilson Samuel

Silver

Re: Multihoming with BGP and load sharing

Hi ,

Can i have the exact topology of the network .

I can give one example for load sharing.

This scenario shows how to achieve load sharing when multiple links exist between a remote AS and a local AS. These links are terminated in one router at the local AS and on multiple routers at remote ASs in a single-homed BGP environment. The Network Diagram is an example of such a network.

ISP A

Topology : Router A ---- Router B

---- Router C

AS-11 AS-10

This sample configuration uses the maximum-paths command. By default, BGP chooses one best path among the possible equal-cost paths that are learned from one AS. However, you can change the maximum number of parallel equal-cost paths that are allowed. In order to make this change, include the maximum-paths paths command under the BGP configuration. Use a number between 1 and 6 for the paths argument.

config A :

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Serial 0

ip address 160.20.20.1 255.255.255.0

!

!

interface Serial 1

ip address 150.10.10.1 255.255.255.0

!

!

router bgp 11

neighbor 160.20.20.2 remote-as 10

neighbor 150.10.10.2 remote-as 10

network 1.0.0.0

maximum-paths 2

!--- This command specifies the maximum number of paths

!--- to install in the routing table for the specific destination.

config of B:

interface Ethernet0

ip address 2.2.2.1 255.255.255.0

!

interface Serial 0

ip address 160.20.20.2 255.255.255.0

!

!

router bgp 10

neighbor 160.20.20.1 remote-as 11

network 2.0.0.0

auto-summary

config of C:

interface Ethernet0

ip address 2.2.2.2 255.255.255.0

!

interface Serial 1

ip address 150.10.10.2 255.255.255.0

!

!

router bgp 10

neighbor 150.10.10.1 remote-as 11

network 2.0.0.0

auto-summary

Thn verify usinh show ip route command.

Hope it helps you.

thanks,

satish

New Member

Re: Multihoming with BGP and load sharing

Hi Thanks for the replies..

topology is like this

ISP A ---T1--- CUSTOMER R1

---T1--- CUSTOMER R1

ISP B ---ETH--- CUSTOMER R1

everything with bgp is working fine..it is just the 2 t1's set for load sharing are not balancing out

Re: Multihoming with BGP and load sharing

Hi

Pls see whether " load-sharing per-packet " is configured in two links . By default load-sharing per-destination " only happens.

Check with your SP also for the config at his end.

regards

vanesh k

New Member

Re: Multihoming with BGP and load sharing

fixed the problem thanks for ideas everyone

Re: Multihoming with BGP and load sharing

Hi,

If got fixed, please rate the thread also.

:-)

Regards,

Wilson Samuel

142
Views
0
Helpful
6
Replies
CreatePlease to create content