Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multilink Config Differences

Below are two different MLPPP configurations. One uses a virtual-template with ip unnumbered and the other a multilink interface with /30's.

For bonding multiple T1's together from the CE to PE, what is the best method? In order to enable Qos, is the multilink interface better? I am running IOS 12.4 on the PE and peering with the CE running BGP.

****Configuration #1****

multilink virtual-template 1

!

interface Virtual-Template1

ip unnumbered Loopback0

ppp authentication chap

ppp multilink

!

interface Serial0/0/0:1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

!

interface Serial0/0/1:1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

****Configuration #2****

interface Multilink1

ip address 10.xxx.xxx.xxx 255.xxx.xxx.xxx

ppp multilink

ppp multilink group 1

!

interface Serial0/0/0

no ip address

ppp multilink

ppp multilink group 1

encapsulation ppp

no fair-queue

!

interface Serial0/1/0

no ip address

ppp multilink

ppp multilink group 1

encapsulation ppp

no fair-queue

1 REPLY
Purple

Re: Multilink Config Differences

Hi,

The two configurations are essentially doing the same thing. One possible subtle difference is that when you use the virtual-template form, the multilink bundle will be named based on the authenticated username (since you are using chap). This would mean that any link authenticating with that username would be made a part of the same spawned interface. With the 'interface multilink' configuration, a serial interface would only be joined into a bundle if its group ID matched the group ID of the multilink interface.

Hope that helps - pls rate the post if it does.

Paresh

102
Views
4
Helpful
1
Replies