Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

multilink interface problem/Question

Dear all,

I am first time using the multilink interface for connecting the two remote sites.

And I will deploy these configuration next week on point-to-point link.

I would like to ask from experts that are these configuration works or not. This link will be used for data but prority is VOIP.

Router 1 ( 1760V ) and router 2 Is ( 2611XM)

Configuration of 1760 is

class-map match-all VOIP

match access-group 111

!

!

policy-map LLQ

class VOIP

set ip precedence 5

priority 48

class class-default

fair-queue

!

interface Multilink1

ip address 192.168.234.58 255.255.255.248

service-policy output LLQ

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 18

ppp multilink group 1

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 172.16.73.1 255.255.255.0

no ip proxy-arp

speed auto

full-duplex

!

interface Serial0/0

bandwidth 64

no ip address

no ip proxy-arp

encapsulation ppp

no ip route-cache cef

no ip route-cache

no fair-queue

ppp multilink

ppp multilink group 1

!

ip classless

ip route 10.0.0.0 255.0.0.0 192.168.234.57

!

!

!

access-list 111 permit udp any any range 16384 32767

access-list 111 permit tcp any any eq 1720

Now configuration of remote router 2611 XM is

class-map match-all VOIP3

match access-group 111

!

policy-map LLQ3

class VOIP3

set ip precedence 5

bandwidth 48

class class-default

fair-queue

!

interface Multilink3

ip address 192.168.234.57 255.255.255.248

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 20

ppp multilink interleave

ppp multilink group 3

service-policy output LLQ3

ip rtp header-compression iphc-format

!

interface Serial0/2

bandwidth 64

no ip address

no ip proxy-arp

encapsulation ppp

no ip route-cache cef

no ip route-cache

no fair-queue

ppp multilink

ppp multilink group 3

ip route 172.16.73.0 255.255.255.0 192.168.234.58

access-list 111 permit udp any any range 16384 32767

access-list 111 permit tcp any any eq 1720

Looking forward for help thanks

7 REPLIES
VIP Purple

Re: multilink interface problem/Question

Hello,

are these the full configurations of both routers ? I am just asking because you have only one serial interface per router, in which case the multilink would not be necessary. Are you planning to add a second interface, and a second connection between both routers ?

Regards,

GP

New Member

Re: multilink interface problem/Question

No this is not full configuration.

on cisco 2611 i also have 2 more interfaces and it will connect to other 2 other sites ( not this one ). but there is only one link between ( 1760 and 2611xm).

I have also implement QOS (using LLQ/IP priority) for voice thats why i implemented PPP multilink on serial interface.

My question is after connecting router with the line.

Is this configuration works??

VIP Purple

Re: multilink interface problem/Question

Hello,

yes, the config will work. Although, as stated, the multilink interface is not necessary if you only have one link between the sites, and causes unnecessary CPU and memory utilization.

Regards,

GP

Re: multilink interface problem/Question

Hi

I see that you are interested in using TCP,RTP header compression in addition with LFI and LLQ.

In this case if ur much concerned with VOIP traffic i would suggest to give a go with auto qos feature.

That feature is designed only keeping VOIP traffic in mind..

do find the link which talks more about the same..

http://www.cisco.com/en/US/partner/tech/tk543/tk759/technologies_white_paper09186a00801348bc.shtml

your config looks fine except the slight mismatch in the fragment delay on both the sides ..

At ur 1760 its defined as 18 and and in ur 2621 its defined as 20..any specific design consideration behind that ??

regds

New Member

Re: multilink interface problem/Question

As far as i know we cannot use Autoqos function in 1700 series routers , i checked it from below link

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080455a3d.html#wp1039216

Secondly i was not able to open below link because it requires athentication ( and i am a normal user in cisco.com)

http://www.cisco.com/en/US/partner/tech/tk543/tk759/technologies_white_paper09186a00801348bc.shtml

There is no special reason that i use 18 and 20 fragment delay .

Do it needs to be same in both ends ??

Re: multilink interface problem/Question

Hi

Sorry about the link ,pls do have a look on this ..

http://www.cisco.com/en/US/tech/tk543/tk759/technologies_white_paper09186a00801348bc.shtml

regarding the delay its the time interval specified to place a fragment on the wire.

By default its 30 and u cna tweak it accordingly and i would suggest to keep it either 18 or 20 on both the sides..

regds

Re: multilink interface problem/Question

Hi,

Why are you using multilink for just only a single link. Multilink is used for bundling up multiple links for load-balancing.

Config looks OK and it should work. Just only one this to note is that you rae using different multilink groups on the route. Make it multiink 1 on both the sides.

HTH,

-amit singh

250
Views
3
Helpful
7
Replies
CreatePlease to create content