Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Multilink problems

All we have experienced a problem, bonding T1's using multilink ppp. Seems testing the lines individually they test 1.5/1.5 or there about. Multilinked the Upload speed is really bad (speed varies).

5 REPLIES

Re: Multilink problems

hi

how do u measure the upload speed ? wht kinda mechanism ur using to check out the same ?

have you checked up whether the load is getting equally balanced in all the links which are under the multilink bundle ?

any qos policies being defined in your router and any policies being binded under this multilink interface ??

also paste the config of your router without any sensitve infos on that ..

regds

Re: Multilink problems

We are using different speed test sites, and an ftp server on our network. How can i verify to see if the load is getting balanced in all the links? No qos is being done. Here is a copy of the config: custname#show run

Building configuration...

Current configuration : 1506 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname custname

!

boot-start-marker

boot-end-marker

!

enable password 7 **********

!

memory-size iomem 15

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Multilink1

description (4 T-1's)

ip address a.b.c.d 255.255.255.252

ppp multilink

ppp multilink links maximum 4

ppp multilink links minimum 1

ppp multilink group 1

!

interface Ethernet0/0

description AVAILABLE

no ip address

shutdown

full-duplex

!

interface Serial0/0

description DS1-

ip unnumbered Multilink1

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/1

description DS1-

ip unnumbered Multilink1

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink group 1

!

interface FastEthernet1/0

description custname LAN

ip address a.b.c.d 255.255.255.224

duplex auto

speed auto

!

interface Serial1/0

description DS1-

ip unnumbered Multilink1

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial1/1

description DS1-

ip unnumbered Multilink1

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink group 1

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 a.b.c.d

!

!

!

!

!

!

!

line con 0

password 7 **********

login

line aux 0

line vty 0 4

password 7 **********

login

!

!

end

custname#

Hall of Fame Super Silver

Re: Multilink problems

Michelle

I am not sure that it is a problem, but I am puzzled why each serial link has ipunnumbered to multilink. It seems to me that the multilink should have an address (as you do) and that the physical links in the bundle should have no ip address.

And I am not sure that this would contribute to the symptoms that you describe.

HTH

Rick

Re: Multilink problems

I will try removing that, do you see anything else that could attribute to the problems that we are experiencing?

Hall of Fame Super Silver

Re: Multilink problems

Michelle

Other than the possible question of IP addresses on the physical serial interfaces I think the configuration looks pretty straightforward and I do not see what would cause your symptoms. (I assume where you have:

ip route 0.0.0.0 0.0.0.0 a.b.c.d

you really mean the next hop is a.b.c.e since a.b.c.d is your end of the multilink.)

Is there a possibility that the issue is not on your end but is on the router on the other end? Do you have access to its config?

On what platform are you running and what release of IOS? Is there a possible IOS problem in that version about multilink? Without knowing what you are running I took a look in the Bug Toolkit on the Cisco web site and found bug CSCec25813 which indicates that in some conditions packets are not CEF switched which could impact performance.

HTH

Rick

165
Views
0
Helpful
5
Replies