Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Multilink

Hi,

I have got to multilink 2 circuits for one of my project. Any idea what are the changes to be done to configure the multilink?

Thanks

12 REPLIES
Silver

Re: Multilink

are using multilink for PPP?

if yes check this

http://www.hassairi.50megs.com/#multilink

Community Member

Re: Multilink

Thanks! I will have to configure the multilink for the serial interfaces which is terminated on different routers in same location. So is it enough if I put in the above mentioned configuration or should I use any cable to interconnect these two interfaces as they are on different routers?

Community Member

Re: Multilink

Hi Veena ,

Let me give you a basic example on how to bundle that two circuits that you have.

interface Multilink456

ip address A.B.C.1 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 456

!

interface Serial0/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 456

!

interface Serial0/1

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 456

Regards ,

Jay O.

Re: Multilink

HI Veena, [PLS RATE ALL HELPFUL POSTS]

interface Multilink1

description *****MULTILINK in Mumbai*****

ip address x.x.x.x

ppp multilink

ppp multilink group 1

!

!

interface Serial0/3/0

description **CIR 1**

bandwidth 2048

ip address x.x.x.x

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/3/1

description **CIR 2**

bandwidth 2048

ip address x.x.x.x

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Multilink1

description *****MULTILINK in Chennai*****

ip address x.x.x.x

ppp multilink

ppp multilink group 1

!

!

interface Serial0/3/0

description **CIR 1**

bandwidth 2048

ip address x.x.x.x

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/3/1

description **CIR 2**

bandwidth 2048

ip address x.x.x.x

encapsulation ppp

ppp multilink

ppp multilink group 1

!

PLS RATE ALL HELPFUL POSTS

Best Regards,

Guru Prasad R

Community Member

Re: Multilink

thanks for the reply:) I do have one more doubt. The routers(say routerA) where multilink has to be carried out is used for the GRE tunnel i.e, the router is used as an intermediate hop to reach the customer router(routerB where the GRE is terminated). So should I make any routing changes on the routerA apart from configuring the multilink?

Community Member

Re: Multilink

Consider the multilink interface as a usual physical interface.

you can enable a routing protocol, meaning routers can form adjacencies with this multilink interface. Then you can make sure that, from this router you can ping both, the destination and the soorce of the GRE tunnel.

In case your multilink enabled router is the beginning of the GRE tunnel, then you will just need something like this:

interface tunnel0

ip address y.y.y.y 255.255.255.252

tunnel source multilink1

tunnel destination x.x.x.x

Community Member

Re: Multilink

that was helpful Chris! In my case,the two circuits are terminated on the two diff routers and is it possible for me to go in for the multilink in this kind of situation? The reason being, I was going through the queries regarding the multilink in netpro and apparently some one has mentioned that in order to configure multilink, the circuits should terminate on the same router/device..is this right?

Re: Multilink

HI Veena, [Pls Rate if HELPS]

Configuring Multilink PPP, the Links need to terminated in the same Router device.

On top of that, the Circuit Size should be same in terms of Bandwidth and other parameters. Because MLPPP will share the overall Bandwidth in the Bundled Physical Circuits.

Pls Rate if HELPS

Best Regards,

Guru Prasad R

Community Member

Re: Multilink

Thanks! And is it mandatory that we configure the multilink on both the ends?

For eg: Router A======Router B ..Can I just configure it only on router A?

Re: Multilink

HI Veena,

In several Replies in the same POST you have seen the Multilink is configured on both the ends.

It is mandatory to configure MLPPP on both the ends since all traffic will be routed only via the Logical MLPPP interface which needs source and destination Ends.

Do RATE ALL HELPFUL POSTS

Best Regards,

Guru Prasad R

Community Member

Re: Multilink

Veena,

A multilink interface is a virtual interface grouping many physical interfaces.

So you can only configure multilink interfaces on the routers where the physical line ends:

Router1====<2xleased lines>====Router2

Multilink allows you to use your available bandwidth in an efficient maner.

Re: Multilink

HI Veena,

Router A ===GRE Tunnel== Router B

If above is the Architecutre, normally in MLPPP setup all traffic will go only via the MLPPP logical Interface and not via any other Physical interface unless and until the statically routed.

Hope this is Informative.

Do Rate if HELPS

Best Regards,

Guru Prasad R

164
Views
9
Helpful
12
Replies
CreatePlease to create content