Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multiple GRE Tunnels with same source and destination address

Hi,

We have the following problem :

We have two sites, site A and site B which are interconnected as following :

(Site A)--Router A---Firewall A---------WAN--------Firewall B---Router B-----(Site B)

The two routers are 3825 Cisco Routers.

On each of theses routers, there are multiple VRF created in order to separate user traffic.

Each Cisco router is interconnected with its firewall by an ip adress in the global routing table.

We wanted to create as much GRE tunnel as VRF.However, all the GRE tunnel must have the same source and destination address which is the address of the interface linked to the firewall (address in the global routing table).

Here is an exemple of our configuration :

interface Tunnel 1

ip vrf forwarding vrf_1

ip address 10.0.0.1 255.255.255.0

keepalive 10 3

tunnel destination GigabitEthernet 0/1

tunnel destination 93.2.3.2

interface Tunnel 2

ip vrf forwarding vrf_2

ip address 11.0.0.1 255.255.255.0

keepalive 10 3

tunnel destination GigabitEthernet 0/1

tunnel destination 93.2.3.2

interface Tunnel 3

ip vrf forwarding vrf_3

ip address 11.0.0.1 255.255.255.0

keepalive 10 3

tunnel destination GigabitEthernet 0/1

tunnel destination 93.2.3.2

When we set up a unique Tunnel, it works very well (Interfave Tunnel up).

But as soon as we create another tunnel with the same source and destination address, these tunnels fall down.

So, is it impossible to create Tunnels with the same source and destination address? So is there any other solution to fix our problem?

Thanks you very much for your responses

Best Regards

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Multiple GRE Tunnels with same source and destination addres

Use "tunnel key".

2 REPLIES
Hall of Fame Super Gold

Re: Multiple GRE Tunnels with same source and destination addres

Use "tunnel key".

New Member

Re: Multiple GRE Tunnels with same source and destination addres

Thank you very much! This command solved our problem.

455
Views
0
Helpful
2
Replies