Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multiple IP`s on a single interface

Hi,

 

I have a problem with connecting my router 2800 to another router 2800.

 

Both routers only have one interface FastEthernet 0/0 available, the other one os allready taken. This part is simple I put the ips on both interfaces and the connect to each other.

 

Here comes the problem. The first router is a mobile router, Its not allways connected to the same second router. I have about 15 secoond router (all are the same 2800 series with same ios). So I would like to connect to all my second routers withot reconfiguring the first one each time I go to another one.

 

example:

 

Router 1 (the mobile one)

Interface FastEthernet 0/0

ip address 10.0.0.1 255.255.255.252

 

Router 2

Interface FastEthernet 0/0

ip address 10.0.0.2 255.255.255.252

 

Router 3

Interface FastEthernet 0/0

ip address 10.0.0.6 255.255.255.252

 

Router 4

Interface FastEthernet 0/0

ip address 10.0.0.10 255.255.255.252

 

 

 

I tried with entering secondary ip address but I only worked one way, I could ping the the first router but the first could ping the second router and the EIGRP didn`t work.

interface FastEthernet0/0

ip address 10.0.0.1 255.255.255.252

ip address 10.0.0.5 255.255.255.252 secondary

ip address 10.0.0.9 255.255.255.252 secondary

 

I tried using subinterfaces but I didnt even get a ping through.

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 2
 ip address 10.0.0.1 255.255.255.252
!
interface FastEthernet0/0.2
 encapsulation dot1Q 3
 ip address 10.0.0.5 255.255.255.252

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hello,You can achieve this

Hello,

You can achieve this with sub-interfaces. Take for instance the below scenario.

R1 has multiple sub-interfaces - one physical interface that can be attached to one interface of another router at any time, and also form an EIGRP neighborship. This instance I will connect R1 and R2 but using multiple IP's to demonstrate that neighborship is formed on both interfaces.

 

Here is R1

R1#show ip int brie

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES TFTP   up                    up      

FastEthernet0/0.1          1.1.1.1         YES manual up                    up      

FastEthernet0/0.2          2.2.2.1         YES manual up                    up

 

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.1

 encapsulation dot1Q 1 native

 ip address 1.1.1.1 255.255.255.0

!

interface FastEthernet0/0.2

 encapsulation dot1Q 2

 ip address 2.2.2.1 255.255.255.0

 

router eigrp 100

 network 1.1.1.1 0.0.0.0

 network 2.2.2.1 0.0.0.0

 no auto-summary

 

I have connected R2 with multiple IP's exactly the same.

R2

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.1

 encapsulation dot1Q 1 native

 ip address 1.1.1.2 255.255.255.0

!

interface FastEthernet0/0.2

 encapsulation dot1Q 2

 ip address 2.2.2.2 255.255.255.0

 

router eigrp 100

 network 1.1.1.2 0.0.0.0

 network 2.2.2.2 0.0.0.0

 no auto-summary

 

See the EIGRP adjacencies here:

R1

R1#show ip eigrp neigh

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   2.2.2.2                 Fa0/0.2           11 00:06:30   26   200  0  8

0   1.1.1.2                 Fa0/0.1           11 00:07:26   27   200  0  5

 

R2

R2#show ip eigrp neighbors 

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   2.2.2.1                 Fa0/0.2           11 00:07:22 1281  5000  0  7

0   1.1.1.1                 Fa0/0.1           14 00:08:18   35   210  0  4

 

In your case Router 1 (the mobile one) should match the sub-interface encapsulation and tag of the respective routers.

i.e.

R1 (dot1q tag 2 is to R2)

R1 (dot1q tag 3 is to R3)

Making sure its the same on both sides.

Hope this satisfies the requirement and helps.

If you have already tried the above, please check ip addressing is correct and that EIGRP config is also correct. And lastly, if this still doesn't work, try having one connection as native - I don't believe this should make a difference but the IOS might behave this way for odd reasons.

I just tested the above and works fine.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
8 REPLIES
Hall of Fame Super Blue

You could use DHCP on the

You could use DHCP on the mobile router interface and then configure an IP pool on each of your other routers eg. -

mobile router -

int fa0/0

ip address dhcp

router eigrp 10

network 10.0.0.0 0.0.0.255 <-- this needs to cover all the /30s on the other routers so whichever 10.0.0.x IP the mobile router gets this network statement covers it

using router 3 as an example -

ip dhcp pool MOBILE

network 10.0.0.4 255.255.255.252

ip dhcp excluded-address 10.0.0.6

router eigrp 10

network 10.0.0.4 0.0.0.3

then each time the mobile router was reconnected to another router it would pick up the correct 10.x.x.x address for that subnet and then form an EIGRP neighborship.

Jon

New Member

Sweet suggestion did not

Sweet suggestion did not think of that.

 

But unfortunately our company security policy does not allow DHCP addressing I can only use static IP addresses.

 

Thx for the suggestion

Hall of Fame Super Blue

I understand about tehe

I understand about the security policy.

Don't forget though that you could always do a manual binding in the the DHCP pool so only the mobile router could actually get that IP.

I appreciate that still may not be acceptable.

What's not clear is what is connected to each router on their fa0/0 interfaces if they are not connected to the mobile router ?

If it is nothing then why not simply increase the subnet mask for the connection ?

Jon

I agree with Jon Marshall,It

I agree with Jon Marshall,

It is simple to have the mask 255.255.255.224.

BR

Thanveer

"Please rate the helpful posts"

Regards Thanveer "Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."
Silver

The problem is that using

The problem is that using those ip address, interfaces of different routers are on different subnets, so thay have no route for the others networks; for example router with address 10.0.0.10 255.255.255.252 doesn't konw how to route to network 10.0.0.1 255.255.255.252

When using secondary ip you have to ping specifing the secondary ip source on R1, otherwise it use primary ip:   ping 10.0.0.6 sou 10.0.0.5

 

EIGRP does not make neighborship on seconadry ip address, it can advertise seconadry network but neighborship is built only on primary ip address

 

Subinterf doesn't help you: you have exactly the same ip addressing and problems) but using 802.1q encasulation between routers

 

Bye,

e

 

New Member

Yes I realize that using

Yes I realize that using secondary ip addresses or subinterfaces does not work. I am looking for someone that can help me solve my problem or steer me in the right direction, like Jon Marshall that suggested that I try with DHCP (thx again for that Jon).

 

But thank you for explaining why my solutions don`t work.

Hello,You can achieve this

Hello,

You can achieve this with sub-interfaces. Take for instance the below scenario.

R1 has multiple sub-interfaces - one physical interface that can be attached to one interface of another router at any time, and also form an EIGRP neighborship. This instance I will connect R1 and R2 but using multiple IP's to demonstrate that neighborship is formed on both interfaces.

 

Here is R1

R1#show ip int brie

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES TFTP   up                    up      

FastEthernet0/0.1          1.1.1.1         YES manual up                    up      

FastEthernet0/0.2          2.2.2.1         YES manual up                    up

 

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.1

 encapsulation dot1Q 1 native

 ip address 1.1.1.1 255.255.255.0

!

interface FastEthernet0/0.2

 encapsulation dot1Q 2

 ip address 2.2.2.1 255.255.255.0

 

router eigrp 100

 network 1.1.1.1 0.0.0.0

 network 2.2.2.1 0.0.0.0

 no auto-summary

 

I have connected R2 with multiple IP's exactly the same.

R2

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.1

 encapsulation dot1Q 1 native

 ip address 1.1.1.2 255.255.255.0

!

interface FastEthernet0/0.2

 encapsulation dot1Q 2

 ip address 2.2.2.2 255.255.255.0

 

router eigrp 100

 network 1.1.1.2 0.0.0.0

 network 2.2.2.2 0.0.0.0

 no auto-summary

 

See the EIGRP adjacencies here:

R1

R1#show ip eigrp neigh

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   2.2.2.2                 Fa0/0.2           11 00:06:30   26   200  0  8

0   1.1.1.2                 Fa0/0.1           11 00:07:26   27   200  0  5

 

R2

R2#show ip eigrp neighbors 

IP-EIGRP neighbors for process 100

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   2.2.2.1                 Fa0/0.2           11 00:07:22 1281  5000  0  7

0   1.1.1.1                 Fa0/0.1           14 00:08:18   35   210  0  4

 

In your case Router 1 (the mobile one) should match the sub-interface encapsulation and tag of the respective routers.

i.e.

R1 (dot1q tag 2 is to R2)

R1 (dot1q tag 3 is to R3)

Making sure its the same on both sides.

Hope this satisfies the requirement and helps.

If you have already tried the above, please check ip addressing is correct and that EIGRP config is also correct. And lastly, if this still doesn't work, try having one connection as native - I don't believe this should make a difference but the IOS might behave this way for odd reasons.

I just tested the above and works fine.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
New Member

Thank you for solving my

Thank you for solving my problem.

 

My problem was that in my non mobile routers I didn`t create Subinterfaces but instead just entered:

interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.252
 vlan-id dot1q 2
  exit-vlan-config

 

 

 

90
Views
0
Helpful
8
Replies