Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Multiple-VRF over PPP

Dear,

I am looking for a solution for the following problem


We have a PE router, containing multiple VRF.

An CE router is linked to this PE router via ATM-interfaces and is running MLPPP for bundling the lines.

Now, the CE router should be able to access 2 different VRF's.

Any idea how to solve this? My first idea was to enable MPLS, however, it was told me that MPLS over PPP is not supported.

Regards

5 REPLIES
Hall of Fame Super Silver

Re: Multiple-VRF over PPP

Hello Samuel,

>> it was told me that MPLS over PPP is not supported.

I have tested MPLS over PPP and over ML PPP on serial interfaces without problems, also for ML PPP over ATM this should be possible there were some examples in the forums.

You need special care of MTU issues, like it happens in some DSL remote offices using PPPoE you may need to reduce MTU on LAN interfaces to be sure to avoid MTU issues on the MPLS enabled link.

Hope to help

Giuseppe

New Member

Re: Multiple-VRF over PPP

Dear,

Thanks for the answer.

I tried to add mpls ip to an Cisco 3725 on the Dialer interface and it looks te be working. the only strange thing is that when I also add mpls ip on the other side (the Cisco 7200 - PE router) is not working anymore.


However, I tried the same thing on the Cisco 1841 and Cisco 2621XM and their its not working at all.


Can you give me an example config since I was not able to find it in the forum.

Thanks in advance!

New Member

Re: Multiple-VRF over PPP

Dear,


I little bit more information about my configs

PE router: (7200 - running 12.4-24T)

interface Virtual-Template1
ip unnumbered Loopback0
ip load-sharing per-packet
mpls ip
peer default ip address pool default
keepalive 2
ppp mtu adaptive
ppp authentication pap
ppp multilink
ppp multilink links minimum 1
ppp multilink fragment maximum 2

interface GigabitEthernet0/3

pppoe enable group global

bba-group pppoe global
virtual-template 1

CE router: (3725 - running 12.4-15.T14)

interface ATM0/0
no ip address
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 2

interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 2
dialer-group 2
mpls ip
ppp authentication pap callin
ppp pap sent-username ******* password 0 *********
ppp multilink

mpls ldp router-id Dialer1 force

Router#sh pppoe session
*Jul 24 09:33:04.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st
    N/A    186  0030.f2f0.8c19  ATM0/0                 Di1  Vi2        UP
                0014.a9dd.09b0  VC:  8/35                   UP
Router#

I have enabled debug mpls packets on the CE, when I ping the device from the PE, I see the following:

*Jul 24 09:33:14.215: MPLS: Di1: recvd: CoS=6, TTL=255, Label(s)=18
*Jul 24 09:33:14.215: MPLS: Di1: xmit: (no label)
*Jul 24 09:33:14.215: MPLS: Di1: recvd: CoS=6, TTL=255, Label(s)=18
*Jul 24 09:33:14.215: MPLS: Di1: xmit: (no label)
*Jul 24 09:33:16.243: MPLS: Di1: recvd: CoS=6, TTL=255, Label(s)=18
*Jul 24 09:33:16.243: MPLS: Di1: xmit: (no label)
*Jul 24 09:33:17.195: MPLS: Di1: recvd: CoS=0, TTL=255, Label(s)=18
*Jul 24 09:33:17.195: MPLS: Di1: xmit: (no label)
*Jul 24 09:33:20.195: MPLS: Di1: recvd: CoS=0, TTL=255, Label(s)=18
*Jul 24 09:33:20.195: MPLS: Di1: xmit: (no label)

It looks packets are arriving right labeled, but no packets are send out.

Any idea what I am doing wrong?

Thanks in advance

Hall of Fame Super Silver

Re: Multiple-VRF over PPP

Hello Samuel,

sorry for late answer:

mpls ldp router-id Dialer1 force

I would say you need to use a loopback as router-id and not the dialer interface that has a dynamic negotiated address

Hope to help

Giuseppe

New Member

Re: Multiple-VRF over PPP

Dear,


Since we are always giving the same IP adres via PPPoE, I don't see the reason why it would not work with Dailer1 as router-id ...

It keep strange for me that the Cisco 3725 is arriving the mpls labelled packets but not sending anything back.

Any other idea?

1193
Views
0
Helpful
5
Replies