Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Multiple WAN links and multiple routers

There are two routers in redundancy and each has multiple WAN links between two sites.

What is ideal way to configure load sharing. The ethernet of the routers are configured with GLBP. How can the WAN links be load shared. The destination is only one and never changes.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Multiple WAN links and multiple routers

Hello Cisco_lite,

I did a search for bugs on GLBP for release 12.4(9)T I found a few but no one looks like to apply here.

However, two notes:

a) NAT is involved here you have NAT configured on RC and RD

ip nat inside on serial interfaces

but nat is missing on RD GE port, if really missing this is a problem

NAT has its own timers for translations

b) you should track the state of WAN links using weigthing commands (GLBP has a two dimensions criteria priority to choice AVG and weighting for election AVFs) so that if both wan links fail on RC RD will be used

Hope to help

Giuseppe

12 REPLIES
Hall of Fame Super Silver

Re: Multiple WAN links and multiple routers

Hello Cisco_Lite,

if destination and source are the same normal destination based CEF load balancing (actually an exor of IP SA, IP DA and an hash seed) will use a single link.

To be noted that GLBP itself works on ARP and can load balance only if there are multiple hosts (it provides a different MAC address in the answer to an ARP request for the GLBP VIP address).

if multiple hosts are in the vlan and all of them access the same destination you should be fine:

some will use one router, the other the second router

CEF load balancing will place some flows on Wan link 1.1 some on link 1.2

The same happen on R2 CEF will place some flows on wan link 2.1 other on link 2.2.

if the host is only one it will always send its traffic to a single router. for example R1 and normal load balancing will use a single WAN link.

You can mitigate the effects in this case by enabling per packet load-balancing so that all wan links of the used router will be used.

Be aware that same type of applications suffer with per packet load-balancing specially VOIP.

So or you are fine in this way (multiple hosts on vlan) or you need to enable per packet load balancing (if single host in vlan and no VOIP is involved on the links)

Hope to help

Giuseppe

Re: Multiple WAN links and multiple routers

Hi,

HSRP,VRRP and GLBP are Gateway Redundancy protocols designed for the LAN.

With GLBP, the Load sharing is performed per HOST, so if you have multiple host , a single host will have one particular GW, Based on the ARP reply from a Single virtual Mac-address. The Second host would have a nother Virtual mac address for its arp request.

As for the WAN load sharing, Pls specify if you have a routing protocol as BGP configured with ur upstream provider or not?? what are the multiple links for??

HTH

Mohamed

New Member

Re: Multiple WAN links and multiple routers

I am using static routes only. Multiple links are to load-share 3x2Mbps links i.e. making it total of 6Mbps. 2 links are one router and one link on the other. I want to avoid multi-Link PPP.

Another query, will assymetric routing occur in the given scenario and can it break things. for e.g. traffic goes from routerA to routerB over one link and comes back via the other link. Or it goes from routerA to routerB over one link and comes back via second/redundant routerB over the third link to the second/redundant routerA.

Please assist.

Thanks.

New Member

Re: Multiple WAN links and multiple routers

I am experiencing problems with GLBP on Ethernet inside and load sharing (destination-based) over WAN links via static routes.

Could you please advise how can I troubleshoot it. I did ping test for couple of hours and no issues were faced. When I left it overnight, and checked all pings were timing out. ip cef is enabled on all the routers. Please see the attached topology.

Any help/hints will be appreciated.

debug glbp is just giving hello's.

Hall of Fame Super Silver

Re: Multiple WAN links and multiple routers

Hello Cisco_Lite,

ARP cache has a default timeout of four hours on routers.

You say that you had successful end-to-end ping in a two hours test but the overnight test failed.

On one side try to verify arp activity with the appropriate debug

debug arp

or debug ip arp (check to see the correct one)

GLBP works on ARP the AVG answers to ARP request for the VIP IP address using alternate AVF MAC addresses.

So it is possible that GLBP can interfer with ARP activity

I mean that this looks like a possible IOS bug.

if you post the IOS version and platform you use, it is possible to search for possible known bugs about GLBP and ARP

Hope to help

Giuseppe

New Member

Re: Multiple WAN links and multiple routers

Hi Cisco_lite,

Based on my experience, i would have done the following.

If it is really neccessary to have 6mbps, then using FRF16 technology (if your SP supports) then, it will give you what you required ie 6 mbps capacity. to achieve this, you can have all the 3 links connected to the same router and for the matter of redudancy, you may have a secondary router with a 2 mbps link.(if your provider provides good SLA).

Using HSRP has a redudancy protocol and BGP between you and your provider is a good solution.

It works perfectly for my clients.

Cheers,

Anish Augustin

New Member

Re: Multiple WAN links and multiple routers

Hi Giuseppe,

Please find below the requested information along with the relevant configs. Please review the modified attachment.

Also to mention, when I bring down the other two links, the connectivity is established without any errors. Issue is only when load-sharing (not sure if it due to two links within the same router and two different links between the routers).

Thanks for your help.

ROUTERA

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(9)T7, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport')">http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Thu 10-Jan-08 16:35 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

ROUTERA Configuration

interface GigabitEthernet0/0

ip address 10.1.1.4 255.255.255.0

duplex auto

speed auto

glbp 10 ip 10.1.1.3

glbp 10 priority 110

glbp 10 preempt

!

interface Serial0/0/0

bandwidth 2000

ip address 20.1.1.210 255.255.255.0

!

interface Serial0/0/1

bandwidth 2000

ip address 30.1.1.222 255.255.255.0

--------------------------------

ROUTERB

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(9)T7

, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport')">http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Thu 10-Jan-08 16:35 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

ROUTERB Configuration

interface GigabitEthernet0/0

ip address 10.1.1.5 255.255.255.0

duplex auto

speed auto

glbp 10 ip 10.1.1.3

!

interface Serial0/0/0

bandwidth 2000

ip address 40.1.1.226 255.255.255.0

-----------------------------

ROUTERC

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(9)T7, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport')">http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Thu 10-Jan-08 16:35 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

ROUTERC Configuration

interface GigabitEthernet0/0

ip address 50.1.1.18 255.255.255.0

ip nat outside

no ip virtual-reassembly

duplex auto

speed auto

glbp 50 ip 50.1.1.20

glbp 50 priority 110

glbp 50 preempt

!

interface Serial0/0/0

bandwidth 2000

ip address 20.1.1.209 255.255.255.0

ip nat inside

no ip virtual-reassembly

!

interface Serial0/0/1

bandwidth 2000

ip address 30.1.1.221 255.255.255.0

ip nat inside

no ip virtual-reassembly

ip nat inside source static network 192.168.10.0 172.16.1.0 /24

----

ROUTERD

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(9)T7

, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport')">http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Thu 10-Jan-08 16:35 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

ROUTERD Configuration

interface GigabitEthernet0/0

ip address 50.1.1.19 255.255.255.0

duplex auto

speed auto

glbp 50 ip 50.1.1.20

!

interface Serial0/0/0

bandwidth 2000

ip address 40.1.1.225 255.255.255.0

ip nat inside

no ip virtual-reassembly

ip nat inside source static network 192.168.10.0 172.16.1.0 /24

Hall of Fame Super Silver

Re: Multiple WAN links and multiple routers

Hello Cisco_lite,

I did a search for bugs on GLBP for release 12.4(9)T I found a few but no one looks like to apply here.

However, two notes:

a) NAT is involved here you have NAT configured on RC and RD

ip nat inside on serial interfaces

but nat is missing on RD GE port, if really missing this is a problem

NAT has its own timers for translations

b) you should track the state of WAN links using weigthing commands (GLBP has a two dimensions criteria priority to choice AVG and weighting for election AVFs) so that if both wan links fail on RC RD will be used

Hope to help

Giuseppe

New Member

Re: Multiple WAN links and multiple routers

Hello Giuseppe,

Thanks for pointing out the missing NAT statement.

I have added the NAT statement, and did 'clear arp-cache' on all the routers.

The pings are still consistently timing out.

Please assist.

Thanks.

New Member

Re: Multiple WAN links and multiple routers

Hello Giuseppe,

The problem is fixed. Routes were messed up. ROUTERD held routes dissimilar to ROUTERC (except the gateway).

Could you please send me any link on the WAN link tracking feature you'd mentioned.

Thanks a bunch.

Hall of Fame Super Silver

Re: Multiple WAN links and multiple routers

Hello Cisco_Lite,

I was short of time before

here it is a link to GLBP configuration

http://www.cisco.com/en/US/docs/ios/ipapp/configuration/guide/ipapp_glbp_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1054579')">http://www.cisco.com/en/US/docs/ios/ipapp/configuration/guide/ipapp_glbp_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1054579

see section named

Configuring GLBP Weighting Values and Object Tracking

in this way forwarding can be performed by the device with surviving link to other site

the weighting is reduced if the tracked interface(s) are down (multiple decrements apply one for each link down)

Hope to help

Giuseppe

New Member

Re: Multiple WAN links and multiple routers

With regards to object tracking in the given topology i.e. 2 serials on one router and 1 serial on the second router...how can I set the decrement value. Only when two serials on first router fail, the second router should pick up. And if the only serial on second router fail, the first router should pickup.

Also, in normal scenario should the weighting be the same across the GLBP group i.e. on two routers. What does lower & upper in below entry mean.

glbp 10 weighting 110 lower

95 upper 105

425
Views
19
Helpful
12
Replies
CreatePlease to create content