Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Mutlilink PPP help.

Hello all,

I have two sight for internet traffic which are connected with two T1's. I configure them with multilink ppp so i should get a throughput of 3 Mbps correct? My snmp traffic graph is not showing a balanced load across the two T1's. Here are the router configs:

Router1:

interface Multilink1

ip address 69.X.X.X 255.255.255.252

no ip mroute-cache

no cdp enable

ppp multilink

multilink-group 1

!

interface FastEthernet0/0

ip address 69.X.X.X 255.255.255.252

no ip route-cache

no ip mroute-cache

speed auto

full-duplex

!

interface Serial0/0

no ip address

encapsulation ppp

no fair-queue

pulse-time 10

no cdp enable

ppp multilink

multilink-group 1

!

interface FastEthernet0/1

ip address 69.X.X.X 255.255.255.128

speed 100

full-duplex

!

interface Serial0/1

no ip address

encapsulation ppp

no fair-queue

pulse-time 10

ppp multilink

multilink-group 1

ip route 0.0.0.0 0.0.0.0 X.X.X.X

ip route 69.X.X.X 255.255.255.192 69.X.X.X

ip route 208.X.X.0 255.255.255.128 X.X.X.X

Router 2 (remote site):

!

controller T1 0/0

framing esf

clock source line primary

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 0/1

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 1/0

shutdown

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 1/1

shutdown

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 1/2

shutdown

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 1/3

shutdown

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

!

interface Multilink1

ip address 69.X.X.X 255.255.255.252

no ip mroute-cache

no cdp enable

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/0

ip address 69.X.X.X 255.255.255.192

speed 10

half-duplex

!

interface Serial0/0:0

no ip address

encapsulation ppp

no fair-queue

pulse-time 10

ppp multilink

ppp multilink group 1

!

interface Serial0/1:0

no ip address

encapsulation ppp

no fair-queue

pulse-time 10

ppp multilink

ppp multilink group 1

!

interface Serial1/0:0

no ip address

shutdown

!

interface Serial1/1:0

no ip address

shutdown

!

interface Serial1/2:0

no ip address

shutdown

!

interface Serial1/3:0

no ip address

shutdown

ip route 0.0.0.0 0.0.0.0 69.X.X.X (Multilink IP address of router 1)

Can anyone tell me what I'm doing wrong?

Thanks,

4 REPLIES
Cisco Employee

Re: Mutlilink PPP help.

Hi,

MLPPP makes sure that there is an equal packet distribution acorss the links.

By default the router does per destination load-balancing on the interfaces. If you want to do per-packet load-balancing, you can disable fast switching on the serial interfaces by using "no ip route-cache".

If you have CEF enabled on the router, you can also use CEF to do that load-blancing per packet. under the interface use " ip cef load-balncing per-packet".

Try the above to options listed above and see if it helps.

-amit singh

New Member

Re: Mutlilink PPP help.

I am now seeing that the two circuits are balanced. However, I am not sure that I am getting the best throughput. Is there any way to test this? Thanks.

Cisco Employee

Re: Mutlilink PPP help.

"I am now seeing that the two circuits are balanced",Please tell us the configuration you did. You can check it only in the reporting graphs or under the serial interface using " show interface" command and should show you almost equal traffic pattern.

-amit singh

New Member

Re: Mutlilink PPP help.

The configuation is list above. When I do a speed test (speakeasy.net) I would expect to see at leat a 2 to 2.5 Mbps throughput, however the highest I have gotten was 1690 with very little usage on the two circuits.

97
Views
5
Helpful
4
Replies