Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Named EIGRP for IPv6

Hi,

 

I'm trying to do some lab testing and tested named EIGRP. I was able to understand the EIGRPv6 configuration where you configure the EIGRP statement under the interface and by issuing "no shutdown" under the EIGRP process created. So basically all IPv6 networks that has to be advertised via EIGRP has to have the "ip eigrp xxx" statement under the interface.

 

Now, I'm trying to do named EIGRP. By simply creating the EIGRP multi-af process and by issuing "no shutdown" under the address-family ipv6 autonomous-system, all interfaces with IPv6 address are being advertised right away and EIGRP peering gets established as well.

 

Is this the normal behavior? So is it a general practice to shutdown the address-family ipv6 process first and af-interface default to shutdown state, then individually turn on specific af-interface for EIGRP IPv6 processing?

 

Thanks,

JL

 

Configuration Below:

 

R1#sh run
Building configuration...

Current configuration : 1030 bytes
!
! Last configuration change at 16:23:15 UTC Wed Oct 8 2014
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
ip cef    
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.255
 ipv6 address 2001:1:1:1::1/128
!
interface Loopback1
 no ip address
 ipv6 address 2001:1:1:1::11/128
!
interface FastEthernet0/0
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface FastEthernet0/1
 ip address 155.1.12.1 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:1:1:12::1/64
!         
!
router eigrp multi_af
 !
 address-family ipv6 unicast autonomous-system 100
  !
  topology base
  exit-af-topology
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

R1#
***********************************************************************************************
***********************************************************************************************
R2#sh running-config
Building configuration...

Current configuration : 969 bytes
!
! Last configuration change at 16:23:26 UTC Wed Oct 8 2014
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
ip cef    
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.255
 delay 1
 ipv6 address 2001:1:1:1::2/128
!
interface FastEthernet0/0
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface FastEthernet0/1
 ip address 155.1.12.2 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:1:1:12::2/64
!
!
router eigrp multi_af
 !        
 address-family ipv6 unicast autonomous-system 100
  !
  topology base
  exit-af-topology
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

R2#
***************************************************************************
***************************************************************************
R1#sh ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
LC  2001:1:1:1::1/128 [0/0]
     via Loopback0, receive
D   2001:1:1:1::2/128 [90/107520]
     via FE80::C80C:10FF:FEF4:6, FastEthernet0/1

LC  2001:1:1:1::11/128 [0/0]
     via Loopback1, receive
C   2001:1:1:12::/64 [0/0]
     via FastEthernet0/1, directly connected
L   2001:1:1:12::1/128 [0/0]
     via FastEthernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
R1#
***************************************************************************
***************************************************************************
R2#sh ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
D   2001:1:1:1::1/128 [90/103040]
     via FE80::C80A:10FF:FEF4:6, FastEthernet0/1

LC  2001:1:1:1::2/128 [0/0]
     via Loopback0, receive
D   2001:1:1:1::11/128 [90/103040]
     via FE80::C80A:10FF:FEF4:6, FastEthernet0/1

C   2001:1:1:12::/64 [0/0]
     via FastEthernet0/1, directly connected
L   2001:1:1:12::2/128 [0/0]
     via FastEthernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
R2#

 

3 REPLIES

Someone can correct me if I'm

Someone can correct me if I'm wrong but i think its discovered via the link local address of the interfaces. And I also think its normal/ordinary behaviour. When you do show ipv6 eigrp neigh do you see the link local addresses in the neigborship?

Normally to control the behaviour we would go under the af-interface and shut it (making it non participant in eigrp) make it non active, alternatively - go passive.

Bilal

CCIE - 45032

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

The only way I found to

The only way I found to disable the automatic route advertisement is to shut the routing process right away after it was created. Go to IPv6 address-family and shut the af-interface default and turn on individual interface that needs to participate.  If the routing process is turned on and you added an IPv6 address-family, all interfaces with IPv6 address will automatically participate. So if you already have an IPv4 address-family running in the first place and you want to add IPv6 under the same EIGRP process then it would be ideal to plot it through notepad and paste it to ensure you can have absolute control of the IPv6 advertisement. 

 

That's how I see it and just correct me if I am wrong. 

Yes, there are more ways than

Yes, there are more ways than one of achieving this, I have highlighted some and so have you. Both will work just fine. With regards to general practice, I'm not too sure how much IPv6 is around at the moment, especially with EIGRP implementation.

Seems like you have a good understanding of how to control the behaviour anyway so shouldn't be too much of a worry for you.

Bilal

CCIE - 45032

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
82
Views
0
Helpful
3
Replies
CreatePlease to create content