Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT a single address across WAN

Greetings,

I need to NAT a single IP address from network A across the WAN to network B using two routers attached to a T1. Example - IP:10.1.5.47 on NetA becomes IP:172.16.10.79 on NetB.

Network B is also the default Internet gateway for network A. Is this simple to do? Thanks.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Re: NAT a single address across WAN

Yes, it will only NAT that one IP address, all other traffic will not get Natted.

Jon

Re: NAT a single address across WAN

put the nat statement on your netb router:

ip nat inside source static 10.1.5.47 172.16.10.79

interface FastEthernet1/0

ip nat out

interface Serial2/0:0

ip nat in

remove the nat statement on NetA.

that should do it.

-brad

www.ccbootcamp.com

(please rate the post if this helps!)

15 REPLIES
Hall of Fame Super Blue

Re: NAT a single address across WAN

Hi

ip nat inside source static 10.1.5.47 172.16.10.79

On router connected to network A

int fa0/0

ip nat inside

int fa0/1

ip nat outside

where fa0/0 is the interface connecting to the internal network A and fa0/1 is the interface connecting this router to the router with network B on it.

HTH

Jon

New Member

Re: NAT a single address across WAN

Thanks for the prompt reply Jon.

So ... this will only NAT the single IP address coming from NetA and not all IPs correct? Forgive my ignorance.

Hall of Fame Super Blue

Re: NAT a single address across WAN

Yes, it will only NAT that one IP address, all other traffic will not get Natted.

Jon

New Member

Re: NAT a single address across WAN

Jon,

Thought this work serve my needs - but I've been told the user can't see past the internal netA

Here's what I have on the NetA router:

interface Ethernet0/0 [interface to NetB]

description BRIDGE connection to FOX 7206 - Fast4/0

ip address 10.1.51.2 255.255.255.252

no ip directed-broadcast

ip nat outside

ip route-cache flow

interface FastEthernet2/0 [NetA interface]

description LAN interface

ip address 10.1.7.1 255.255.252.0

no ip directed-broadcast

ip nat inside

ip route-cache flow

full-duplex

ip nat inside source static 10.1.5.47 172.16.10.79

any idea why this wouldn't work per your suggestions?

Hall of Fame Super Blue

Re: NAT a single address across WAN

Can you post a "sh ip nat translations" from the router.

the 10.1.5.47 is entering the router in the fa2/0 interface ?

Also does the router at the far end know how to route back to 172.16.10.79 ?

Jon

Re: NAT a single address across WAN

do the devices on the other side of NetB have a route to 172.16.10.79? you got a visio of the network?

-brad

http://www.ccbootcamp.com

(please rate the post if this helps!)

Hall of Fame Super Blue

Re: NAT a single address across WAN

Hi Brad

The devices on NetB don't need a route to 10.1.5.47 as this will have been Natted to 172.16.10.79.

Jon

Re: NAT a single address across WAN

lol...you replied too quickly. :)

-b

Hall of Fame Super Blue

Re: NAT a single address across WAN

I know, and now my post looks like i'm losing my marbles if anybody else reads it :)

Jon

New Member

Re: NAT a single address across WAN

Hi all. Thanks for taking up my cause.

Here is a simple drawing of the networks. The two networks use EIGRP to route between. The router listed on the inside network - NetB (172.16.10.200) is where the host with 10.1.5.47 needs to get to - but that router only accepts connections from hosts in the 172.16.10.0 subnet - hence the need for the NAT.

Here is the output from your request:

COPA_WAN#sho ip nat translations

Pro Inside global Inside local--- 172.16.10.79 10.1.5.47

and the Outside global and Outside local are blank.

Let me know if you need more data.

Thanks.

New Member

Re: NAT a single address across WAN

sorry - forgot the attachment

Re: NAT a single address across WAN

so you are trying to have an address on NetA router show up on NetB with using an ip address from the NetB ip subnet? That won't work. If you want to do something like that, you'd have to setup a bridge or setup NAT on the NetB side router, not the NetA side router.

show us your configs for both routers. i'll reply with the config you need on NetB side router.

-brad

http://www.ccbootcamp.com

(please rate the post if this helps!)

New Member

Re: NAT a single address across WAN

Here they are. Thanks again for all of your help!!

Re: NAT a single address across WAN

put the nat statement on your netb router:

ip nat inside source static 10.1.5.47 172.16.10.79

interface FastEthernet1/0

ip nat out

interface Serial2/0:0

ip nat in

remove the nat statement on NetA.

that should do it.

-brad

www.ccbootcamp.com

(please rate the post if this helps!)

New Member

Re: NAT a single address across WAN

Brad-

Awesome!! Works like a charm.

Thanks both to you and Jon for all your help!!

347
Views
0
Helpful
15
Replies