Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

NAT and Route map configuration

I have a trouble trying to get connectivity using Nat and route-map together in a multihoming scenario.

5 REPLIES
New Member

Re: NAT and Route map configuration

I?m seing matches in my access-list but the translation is not made. Anybody have a clue???

New Member

Re: NAT and Route map configuration

Here is an example of one I recently used. If you post your configuration we might see any possible errors.

ip nat pool Pool1 11.11.12.12 11.11.12.12 prefix-length 28

ip nat pool Pool2 10.10.11.11 10.10.11.11 prefix-length 28

ip nat inside source route-map MAP-1 pool Pool1 overload

ip nat inside source route-map MAP-2 pool Pool2 overload

INTERFACE VLAN2

ip nat inside

INTERFACE VLAN3

ip nat inside

interface fa0/1

ip nat outside

interface fa0/0

ip nat outside

access-list 108 deny ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

access-list 108 permit ip 192.168.2.0 0.0.0.255 ANY

access-list 118 deny ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255

access-list 118 permit ip 192.168.1.0 0.0.0.255 ANY

route-map MAP-1 permit 10

match ip address 108

set default interface fa0/1

route-map MAP-2 permit 10

match ip address 118

set default interface fa0/0

New Member

Re: NAT and Route map configuration

Dear Sir

Can u tell the secenario and the configuration u had done

New Member

Re: NAT and Route map configuration

The customer has 2 T-1's going to 2 ISP's. They wanted the traffic from the 192.168.1.0/24 network to go out of the Fast0/0 interface to ISP1 and the traffic from the 192.168.2.0 network to use the Fast0/1 interface using ISP2. The traffic had to be NAT'd prior to exiting the Fast Ethernet interfaces. So this configuration did just that for them.

New Member

Re: NAT and Route map configuration

Can I have multiple global addresses for an internal IP in order to connect to diferent parnert network??. I mean something like:

10.0.44.50 --> 172.20.10.61 for ISP1

10.0.44.50 --> 172.20.10.64 for ISP2 and each statement associated to static nat inside source with different route-maps and access-list and have connection without problem to connect both ISPs simultaneusly

155
Views
0
Helpful
5
Replies