Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NAT config increases CPU utilization on cisco 7206VXR

Hi There,

I'm a bit lost why adding a simple NAT config onto our cisco 7206VXR can cause the CPU utilization to go from 25% to 50% and higher, causing the router itself to become sluggish and unresponsive at times. Removing the "ip nat outside" config from the outside interface restores the CPU utilization back to normal.

#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-IS-M), Version 12.3(22), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by cisco Systems, Inc.

Compiled Wed 24-Jan-07 20:17 by ccai

Image text-base: 0x60008AF4, data-base: 0x61D44000

ROM: System Bootstrap, Version 12.2(8r)B, RELEASE SOFTWARE (fc1)

BOOTLDR: 7200 Software (C7200-KBOOT-M), Version 12.2(15)B, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Snips of the NAT config:

interface GigabitEthernet0/1.11

encapsulation dot1Q 11

ip address x.x.x.x 255.255.255.240

ip nat outside

ip flow ingress

no cdp enable

interface GigabitEthernet0/1.12

encapsulation dot1Q 12

ip address 192.168.12.1 255.255.255.0

ip nat inside

ip flow ingress

no cdp enable

ip nat inside source list 50 interface GigabitEthernet0/1.11 overload

access-list 50 permit 192.168.12.0 0.0.0.255

Please see attached for "sh ip int" and "sh process cpu" output.

Thank you in advance.

Cheers.

Andy

1 REPLY

Re: NAT config increases CPU utilization on cisco 7206VXR

Hi

I think this is happening due to packets being process switched as per the below link.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094430.shtml

Thanks

Mahmood

163
Views
0
Helpful
1
Replies
CreatePlease to create content