Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NAT Configuration Confusion

Dear All,

I have the following configuration in PIX

Outside interface ip address is a.b.c.10/28

global (outside) 1 interface
route outside 0.0.0.0 0.0.0.0 a.b.c.11 200

In Cisco 1841

int fa0/0
connected to PIX
ip address a.b.c.11/28

int fa0/1
connected to ISP
ip address e.f.g.202

int fa0/2
Connection to new ISP
ip address x.x.x.x

ip nat inside source list 7 interface FastEthernet0/1 overload
ip nat inside source static 10.6.15.5 172.18.1.5
ip nat inside source static 10.6.15.6 172.18.1.6

access-list 7 permit a.b.c.10 (PIX outside interface)

OSPF is set on the router, internet working fine.


This is the old configuration. I have few confusion on this configuration. I have not seen ip nat inside on lan port and ip nat outside on wan port. And, I am not also being able to see the nat transalation with ip nat tranlsatioin command. When I execute ip nat translation I am able to see only the static translation but not the actual translation. Can you please explore about the nat configuation on this.

Now I want to add new ISP link on int fa0/2. If I add  ip nat inside source list 7 interface FastEthernet0/2 overload command it is not being able to nat/pass traffic, why ? However if I connect a new router on fa0/2 and do the new nat setting with the same ip address of the new ISP in the new router I can see the nat translation data but my connection becomes very slow. Is this due to double natting. In the same connection if I shut down the OLD ISP connection my net connection from new ISP also fails. I will not be able to pass traffic through lan to internet, but I am able to ping from the new router.

I have not run ospf on the new link. I passed the traffic through static routing, what goes wrong, don't know.

I could not figure out what is the problem. Please, anybody help me in this matter.

Waiting for kind cooperation,

- Mero 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: NAT Configuration Confusion

Hi,

     Did you solve ip address of youtube website and then do a static route? 

     How do you know that youtube uses the same server(ip address) when being downloaded heavy files?

     Please post current configuration.

HTH,

Toshi

5 REPLIES

NAT Configuration Confusion

Hello,

    First off, you didn't do NAT on R1841 for sure. It would be done only on PIX. Why? You were configuring old style NAT so you have to tell the router with "ip nat inside/ip nat outside" command. That's why you got nothing from "sh ip nat trans". Your router is fine. So no need to chain a new router to do NAT.

   What do you want to do? Back up link(new ISP)?

    If you want to do IOS NAT load-balancing, you can read the following document to get ideas.

Ref:  http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a0080950834.shtml

Cheers,

Toshi

Community Member

NAT Configuration Confusion

Hi,

I don't want to do load balancing, but I want to route 4-5 net address (eg ip a, b, c, d, e) from old link and rest from new link. I routed as

ip route 0.0.0.0 0.0.0.0 new link gateway

ip route a old link gateway

ip route b old link gateway

ip nat inside source list 7 interface FastEthernet0/2 overload

If I do like this also internet working fine but no traffic seen from new ISP link although I downloaded heavy files, however if I trace to youtube. the trace goes through new link.

what is going on I don't understand ?

Please help

NAT Configuration Confusion

Hi,

   Let me sum things up. 

You want to do NAT on both links(old and new). Right? 

You are going to load-sharing based on destination IP addresses(from static routes).  Right?

Toshi

Community Member

NAT Configuration Confusion

Hie,

1. Yes I want to do nat on both links

2. yes, load sharing based on destination IP

3. Although I can see the traffice going through new link when tracing to youtube, but when I download the files from the same page I cann't see the MRTG graph/traffic through new link.

4. I can ping to youtube through new link, but when I shut down the old link my ping response fails, why ?

Mero

Re: NAT Configuration Confusion

Hi,

     Did you solve ip address of youtube website and then do a static route? 

     How do you know that youtube uses the same server(ip address) when being downloaded heavy files?

     Please post current configuration.

HTH,

Toshi

328
Views
0
Helpful
5
Replies
CreatePlease to create content