Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT Configuration for T1 Router

When I plug the T1 into the serial interface on the router, I am able to ping the ISP gateway.  However, none of my LAN users can get out.  Is there something with my NAT configuration?  Any advice would be helpful.

interface FastEthernet0/0

description DATA_LAN

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

ip address x.x.x.x 255.255.255.252 

ip nat outside 

ip virtual-reassembly 

encapsulation ppp 

no ip route-cache !

ip forward-protocol nd

!

ip route 0.0.0.0 0.0.0.0 x.x.x.x

!

!

ip http server

ip http secure-server

ip nat pool no-overload 192.168.1.2 192.168.1.254 prefix-length 24

ip nat inside source list 7 pool no-overload

!

access-list 7 permit 192.168.1.0 0.0.0.255

Everyone's tags (2)
2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: NAT Configuration for T1 Router

Spencer,

Sorry...I posted another message before I saw the actual problem....Please make the change to your nat statement and you should be good.

ip nat inside source list 7 interface s0/0/0 overload

HTH,

John

HTH, John *** Please rate all useful posts ***

Re: NAT Configuration for T1 Router

From the looks of it, you don't have routing enabled. Turn it on by typing "ip routing" at the (config) prompt and see if that resolves your issue.

HTH,

John

Please rate helpful posts...

HTH, John *** Please rate all useful posts ***
7 REPLIES

Re: NAT Configuration for T1 Router

I see an issue. Your nat pool will need to nat to a public address if you're going to use it like this. You can go out dynamically using the address that you have on the serial side by changing your translation statement:

ip nat inside source list 7 interface s0/0/0 overload

HTH, John *** Please rate all useful posts ***
New Member

NAT Configuration for T1 Router

Thank you for your reply.  Here is the output requested.

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to x.x.x.x, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

happy-dans-t1#ping x.x.x.x sour fa0/0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to x.x.x.x, timeout is 2 seconds:

Packet sent with a source address of 192.168.1.1

.....

Success rate is 0 percent (0/5)

happy-dans-t1#show ip nat tran

Pro Inside global      Inside local       Outside local      Outside global

icmp 192.168.1.2:10    192.168.1.1:10     x.x.x.x:10  x.x.x.x:10

--- 192.168.1.2        192.168.1.1        ---                ---

Re: NAT Configuration for T1 Router

Spencer,

Sorry...I posted another message before I saw the actual problem....Please make the change to your nat statement and you should be good.

ip nat inside source list 7 interface s0/0/0 overload

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: NAT Configuration for T1 Router

John,

That fixed the issue that I was having.  However, now I am having an issue with my routing table not populating.  I can ping my ISP gateway from both sides, the router just won't take the routes I have.  As you can see in the above config, I clearly have my static default route set.

happy-dans-t1#show ip route
Default gateway is not set

Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty


t1-router#ping x.x.x.x sour fa0/0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to x.x.x.x, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
t1-router#

Re: NAT Configuration for T1 Router

From the looks of it, you don't have routing enabled. Turn it on by typing "ip routing" at the (config) prompt and see if that resolves your issue.

HTH,

John

Please rate helpful posts...

HTH, John *** Please rate all useful posts ***
New Member

Re: NAT Configuration for T1 Router

This seem to help everything and get this connection working.  Thanks John!!

Re: NAT Configuration for T1 Router

Awesome Thanks for the ratings!

HTH, John *** Please rate all useful posts ***
618
Views
0
Helpful
7
Replies
CreatePlease login to create content