Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NAT issue with Duplicate IP Address message

Hi Pros,

Got a network with 2 WAN Routers and a LAN.

Users across LAN need to access a server in my LAN with IP Address 10.30.247.101.

The users in WAN already have the subnet in their local LAN (overlapping) and thats the reason NAT is implemented.

Now, one of my colleagues had configured NAT as below:

ip nat inside source static 10.30.247.101 10.192.1.212

That means WAN users access server by giving IP 10.192.1.212 and it gets translated into 10.30.247.101.

This config is done on both routers as they are redundant with HSRP.

We are hitting on these logging messages every 30 secs on both routers.

Nov 20 15:33:48.882 IN: %IP-4-DUPADDR: Duplicate address 10.192.1.212 on FastEth

ernet0/1, sourced by 0004.9a39.1fb1

This mac is found to be of second router.

Config of R1 is below:

interface Multilink1

description *** Multilink for 2 X E1 Singtel to Sprtc37-Multilink1 s2/0 and s1/

0 ***

bandwidth 4000

ip address 10.8.16.54 255.255.255.252

ip access-group SQL2000_block in

ip accounting output-packets

ip nat outside

ip route-cache flow

ip summary-address eigrp 7 10.192.128.0 255.255.128.0 5

ip summary-address eigrp 7 10.192.7.0 255.255.255.0 5

ip summary-address eigrp 7 10.192.0.0 255.255.128.0 5

load-interval 30

delay 2000

ppp multilink

multilink-group 1

!

interface FastEthernet0/0

description **** Dealing Room LAN in FBB Connects to SWIN02 Port 2/4 ****

ip address 10.192.7.251 255.255.255.0

ip helper-address 10.192.0.211

ip helper-address 10.192.0.212

no ip redirects

ip route-cache flow

speed 100

full-duplex

standby ip 10.192.7.254

!

interface FastEthernet0/1

description **** Connects to FBB Backbone LAN Connects to SWIN02 Port 2/3 ****

ip address 10.192.1.251 255.255.254.0

ip helper-address 10.192.128.215

ip helper-address 10.192.1.234

ip helper-address 10.192.0.234

no ip redirects

ip nat inside

ip route-cache flow

speed 100

full-duplex

standby ip 10.192.1.254

Config of R2 is below:

interface FastEthernet0/1

description **** Connects to FBB Backbone LAN Connects to SWIN01 Port 2/3 ****

ip address 10.192.1.252 255.255.254.0

ip helper-address 10.192.128.215

ip helper-address 10.192.0.234

ip nat inside

ip policy route-map wp_policy

speed 100

full-duplex

standby ip 10.192.1.254

!

interface Ethernet1/0

description Connectivity to Akruti ( 10 Mbps Actual )

ip address 10.192.250.85 255.255.255.252

ip accounting output-packets

ip nat outside

ip route-cache flow

full-duplex

!

interface Serial1/0

description Connectivity to Akruti (2 MBPS Actual)

ip address 10.192.250.73 255.255.255.252

ip accounting output-packets

ip nat outside

ip route-cache flow

no fair-queue

serial restart-delay 0

Is it because we are translating a IP address coming from interface fa0/1 to IP address in same subnet of interface fa0/1 (10.192.1.252 255.255.254.0) that NAT is throwing up such messages ?

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: NAT issue with Duplicate IP Address message

Hi

I think you should configure NAT with HSRP with feature "NAT-Static Mapping Support with HSRP for High Availability". Here you can find guidelines and examples:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087c4c.html

Hope this helps

1 REPLY
Silver

Re: NAT issue with Duplicate IP Address message

Hi

I think you should configure NAT with HSRP with feature "NAT-Static Mapping Support with HSRP for High Availability". Here you can find guidelines and examples:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087c4c.html

Hope this helps

403
Views
0
Helpful
1
Replies
CreatePlease to create content