Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NAT not working on Cisco Router

I configured NAT on a cisco 2811 router running but it's not working. Following are the commands:

interface FastEthernet0/0

ip address 192.168.1.7 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.16.20.106 255.255.255.252

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.20.105

ip route 10.2.8.0 255.255.248.0 172.16.20.105

!

ip http server

no ip http secure-server

ip nat source static 192.168.1.112 10.234.8.2

!

I try to ping 10.2.8.15 from a Laptop (192.168.1.112) connected to the NAT inside interface but ping is unsuccesful and when i do a show ip nat translation i see nothing. I've erased the nvram and reconfigured same nat commands without success. I've also tried dynamic nat using "ip nat source list pool" command without success. I'm surprised. The ios image is (C2800NM-ADVSECURITYK9-M), Version 12.4(3i). Please assist. Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: NAT not working on Cisco Router

Configure:

no ip nat source static 192.168.1.112 10.234.8.2

ip nat inside source static 192.168.1.112 10.234.8.2

or pool dynamic, or interface.

5 REPLIES
Hall of Fame Super Gold

Re: NAT not working on Cisco Router

Configure:

no ip nat source static 192.168.1.112 10.234.8.2

ip nat inside source static 192.168.1.112 10.234.8.2

or pool dynamic, or interface.

Community Member

Re: NAT not working on Cisco Router

Thanks so much. Spent hours wondering why where it's just due to my skipping the inside keyword. But then, I wonder, how come the router took the command?

Thanks anyway.

Community Member

Re: NAT not working on Cisco Router

Thanks so much. Spent hours wondering why whereas it's just due to my skipping the inside keyword. But then, I wonder, how come the router took the command?

Thanks anyway.

Hall of Fame Super Gold

Re: NAT not working on Cisco Router

Because it does something else, that is not of much use anyway.

Thanks for the nice rating and good luck!

Community Member

Re: NAT not working on Cisco Router

If you don't mind explaining, I'd like to know the something else that it does. I ran debugs then but didn't see anything.

1027
Views
0
Helpful
5
Replies
CreatePlease to create content