Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

NAT on 2501 problem

I am having cisco 2501 series router with one ethernet port. I have my isp connection connected to switch (DLINK nonmanagable, router is also connected to the DLINK nonmanagable link using ehternet port. my isp had given me 172.16.102.x (given to router ehternet port) ip address and they r bindin this ip with router ethernet mac address. now i am having 4 pc connected to my lan(SWITCH) having ip addressing 192.16.1.xx.

is it possible to assign secondary ip of my router ethernet port as 192.168.1.1 can i NAT it with my primary ip which is provided by my ISP whcih is 172.16.102.x so my local lan can access internet...or if any body having other solution for providing internet to lan through router then please help me.....

my cisco ios is 12.0(14) and i am having only one ethernet port on my router...

regards

devang

3 REPLIES
Bronze

Re: NAT on 2501 problem

Hello Devang,

try the following configuration:

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Ethernet0

ip address 172.16.102.x y.y.y.y

ip address 192.16.1.x y.y.y.y

ip nat outside

ip policy route-map NAT

!

ip nat inside source list 1 interface Ethernet0 overload

!

access-list 1 permit 172.16.102.x y.y.y.y

!

route-map NAT permit 10

match ip address 1

match interface Loopback0

Regards,

Nethelper

Re: NAT on 2501 problem

hi

I feel Nethelper has missed to add the secondary keyword for the ip address under the ethernet interface which you want to mention as the secondary ip address..

regds

Bronze

Re: NAT on 2501 problem

Hello,

Edwin is right, I forgot that.

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Ethernet0

ip address 172.16.102.x y.y.y.y

ip address 192.16.1.x y.y.y.y secondary

ip nat outside

ip policy route-map NAT

!

ip nat inside source list 1 interface Ethernet0 overload

!

access-list 1 permit 172.16.102.x y.y.y.y

!

route-map NAT permit 10

match ip address 1

match interface Loopback0

Regards,

Nethelper

103
Views
3
Helpful
3
Replies