Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT on router with only ip nat outiside role

HI

I'm wondering for the following behaviour.

My router Cisco 1841 IOS 12.4(21) has the following config:

interface FastEthernet0/0

ip address 10.59.254.60 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 2048

no ip address

encapsulation frame-relay IETF

no ip mroute-cache

load-interval 30

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0/0.70 point-to-point

ip address 192.168.152.46 255.255.255.252

ip nat outside

frame-relay interface-dlci 70

!

ip nat outside source static 192.168.152.7 10.191.152.7

As you can see there's not the “ip nat inside” statement.

If I do the command:

#telnet 10.191.152.7 80 /source-interface fastEthernet 0/0

Trying 10.191.152.7, 80 ... Open

*Oct 24 15:55:31: NAT: s=10.59.254.60, d=10.191.152.7->192.168.152.7 [47828]

*Oct 24 15:55:31: NAT*: s=192.168.152.7->10.191.152.7, d=10.59.254.60 [9352]

#sh ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C 10.59.254.0/24 is directly connected, FastEthernet0/0

S* 0.0.0.0/0 is directly connected, Serial0/0/0.70

I'm wondering why the translation happens!!!

Can anybody clearify ?

Tks

Ric

3 REPLIES
Silver

Re: NAT on router with only ip nat outiside role

Once you have specified the nat outside interface it is sufficient for NAT to start working. You omit outside definition and it would stop working.

Thanks.

New Member

Re: NAT on router with only ip nat outiside role

Do you have an url explaining that ???

New Member

Re: NAT on router with only ip nat outiside role

I think it would be better to use the nat outside interface "192.168.152.46 " as the static nat instead.

HTH

Dak

112
Views
0
Helpful
3
Replies