Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

NAT on two diff subinterface of single physical interface

hello,

i am having one ethernet port e0 and can i created two different subinterface like inter e0.1 and e0.2 and can i configure the NAT between two different subinterface so that if one subinterface haiving ISP address and other having local network address of my lan so i can provide internet to my internal lan.

I am having 2501 series router...

and give me more detail information aboute subinterfaces on ethernet port and its encapsulation.

regards

Devang

  • WAN Routing and Switching
4 REPLIES

Re: NAT on two diff subinterface of single physical interface

Subinterfaces are not supported on the 2500 series.

Please check the URL below for info about how to use subinterfaces on a 1700

Regards,

Leo

Re: NAT on two diff subinterface of single physical interface

thanks for your reply.

but can u tell me wht will be the requirement to creat the subinterfaces on ehternet port? and what kind of encapsulation, speed it want???

what is the exact working please send it to me i want it in detail....

regards

devang

Re: NAT on two diff subinterface of single physical interface

Hello,

a subinterface is a logical interface, i.e. for ethernet you need an encapsulation dot1Q (802.1q) or ISL (cisco proprietary).

The requirement is, that the IOS and the hardware supports it - as a rule of thumb: a FastEthernet interface will usually support VLANs and subinterfaces. In case you would have support, the configuration would look like this:

interface FastEthernet0/0.100

description to ISP

encapsulation dot1Q 100

ip address 1.1.1.1 255.255.255.0

ip nat outside

interface FastEthernet0/0.200

description inside LAN

encapsulation dot1Q 200

ip address 10.10.1.1 255.255.255.0

ip nat inside

The maximum "speed of a subinterface" will be given by the physical interface, i.e. both subinterfaces in the example above share the 100Mbps of the physical interface.

Configuration examples and explanations can be found f.e. in "Routing Between VLANs Overview" and subsequent sections at

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00800ca801.html

Hope this helps! Please rate all posts.

Regards, Martin

Re: NAT on two diff subinterface of single physical interface

Devang,

Try nat on a stick instead.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094430.shtml

PS: please remember to rate posts!

397
Views
0
Helpful
4
Replies
This widget could not be displayed.