Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT over GRE Tunnel

I have one computer on my local network with the IP address 192.168.1.135 and I need to telnet the IP 10.2.61.18 on port 59041.

I setup one static route on my computer to use default gateway 192.168.0.128(Router IP) when destination is 10.2.61.18.

From the router, I created the loopback 1 interface and forced telnet to use its IP(10.245.9.193) when using telnet from router and it works. But only from router.

When I do a telnet from my computer on  10.2.61.18 I need to get there (The other side of GRE tunnel) with the ip 10.245.9.195. But it is hitting the other side with my local address.

I need a NAT, but I am not succeding in doind it.

My router config is bellow. Anyone can help?

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

!

ip subnet-zero

ip telnet source-interface Loopback1

ip multicast-routing

ip dvmrp route-limit 7000

!

!

!

!

!

interface Loopback0

ip address 10.244.244.148 255.255.255.255

no ip directed-broadcast

ip pim sparse-mode

!

interface Loopback1

ip address 10.245.9.193 255.255.255.240

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface Tunnel0

ip address 10.244.250.86 255.255.255.252

no ip directed-broadcast

ip pim sparse-mode

tunnel source Loopback0

tunnel destination 10.244.244.1

!

interface Ethernet0/0

ip address 192.168.0.128 255.255.252.0

no ip directed-broadcast

ip pim sparse-mode

!

ip classless

ip route 10.2.61.18 255.255.255.255 Tunnel0

ip route 10.244.0.0 255.255.0.0 Tunnel0

ip route 10.244.250.0 255.255.255.0 Tunnel0

ip pim rp-address 10.244.0.10 10

ip pim rp-address 10.244.0.23 20

ip pim spt-threshold infinity

!

access-list 1 permit 10.244.244.0 0.0.0.255

access-list 1 permit 10.244.0.0 0.0.0.255

access-list 1 permit 10.244.250.0 0.0.0.255

access-list 1 permit any

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 10 permit 233.111.180.96 0.0.0.31

access-list 10 permit 233.111.180.128 0.0.0.31

access-list 20 permit 233.252.11.0 0.0.0.255

!

252
Views
0
Helpful
0
Replies
CreatePlease to create content