Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nat over two WAN link

Hi all,

I have an issue trying to nat over two links. Currently I can only get it to work over one. I have static routes and I need to have it over both so that if one link is down we use the other link, link an automatic failover.

Below is my current config.

interface FastEthernet0

ip address xxx.xxx.xxx.173 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

ip address xxx.xxx.xxx.2 255.255.255.128

ip nat outside

ip virtual-reassembly

speed 10

half-duplex

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

ip access-group Control in

ip nat inside

ip virtual-reassembly

!

interface Async1

no ip address

encapsulation slip

!

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.169 151

ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.1 152

!

!

no ip http server

no ip http secure-server

ip nat inside source static 192.168.0.2 interface FastEthernet0

!

ip access-list extended Control

permit ip 192.168.0.0 0.0.0.255 any

5 REPLIES
New Member

Re: Nat over two WAN link

Hi

Are these Internet links or Interoffice leased lines.

If they are Internet links you can ask your service provider to route the public segment towards both the links at his end. So what happens when reverse packet comes to the ISP end it will find the route towards tow interfaces if any of them is down it will go to the secondary link. Auto load balancing will take place.

Please rate if helpfull.

regards,

Suresh Kumar

New Member

Re: Nat over two WAN link

Thanks Suresh they are both Internet links

New Member

Re: Nat over two WAN link

Hi,

you have to use the "extendable" command at the end of the NAT rule, for example:

ip nat inside source static 192.168.0.2 x.x.x.x extendable

ip nat inside source static 192.168.0.2 y.y.y.y extendable

where x.x.x.x and y.y.y.y are the ip addresses of your interfaces fa0 and fa1.

Make sure you use the IP address not "interdace fastEthernet" command.

Good luck and regards!

New Member

Re: Nat over two WAN link

Thanks but this did not give my desired result as nat now works on one interface but not the other.

I am hoping that the best of both worlds.. I will post another configuration I am trying soon.. just hoping it works

New Member

Re: Nat over two WAN link

ip sla 1

icmp-echo xxx.xxx.xxx.1

ip sla schedule 1 life forever start-time now

!

!

track 123 rtr 1 reachability

!

I tried this to monitor if the link is down.. but for some strange reason putting this on the routing table it says the link is down...

I had to remove it and having the

ip nat inside source static 192.168.0.2 xxx.xxx.xxx.169 extendable

ip nat inside source static 192.168.0.2 yyy.yyy.yyy.1 extendable

Solved the problem

thanks guys ... but really the problem is with the statement when i ping the gw (within the router) it timeout even though I am on the net. I can ping from a workstation.. just wondering ...

144
Views
3
Helpful
5
Replies