Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT overload backup

Does Cisco router have any option of specifying NAT overload backup, may be with use of route-maps.For ex:If outside interface s0 is configured for NAT overload, I want to failover to outside interface s1, if s0 goes down?

Thanks,

Praful

6 REPLIES

Re: NAT overload backup

Hi,

this can be achieved with normal routing. Example:

interface ethernet0

ip nat inside

interface serial0

ip nat outside

interface serial1

ip nat outside

ip nat inside source list 1 Serial0 overload

ip nat inside source list 1 Serial1 overload

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 Serial1 250

access-list 1 permit any

As long as serial0 is up all traffic will use S0. when S0 is down then everything will be routed through S1 and NAT translations are built with the S1 IP address.

Hope this helps

Martin

Bronze

Re: NAT overload backup

I know from testing that this works, just replace E1 and E2 with S0 and S1.

interface Ethernet0

ip nat inside

!

interface Ethernet1

ip nat outside

!

interface Ethernet2

ip nat outside

!

ip nat inside source route-map Ethernet1 interface Ethernet1 overload

ip nat inside source route-map Ethernet2 interface Ethernet2 overload

!

access-list 105 permit ip 10.0.0.0 0.255.255.255 any

access-list 105 permit ip 172.16.0.0 0.15.255.255 any

access-list 105 permit ip 192.168.0.0 0.0.255.255 any

!

route-map Ethernet1 permit 10

match ip address 105

match interface Ethernet1

!

route-map Ethernet2 permit 10

match ip address 105

match interface Ethernet2

New Member

Re: NAT overload backup

Thanks for your replies. I have tried it in lab, but the second NAT overload command overwrites the first one.

I am not sure if we can have two NAT overload commands at the same time.

Thanks,

Praful

Re: NAT overload backup

Hi

If the links are getting connected to the same SP via different physical paths (for reduandncy purpose) then u can make use of logical loopback interface in ur router.

Just configure overload over the loopback interface and make sure u have static default routes placed in ur router as well the static routes to have the reachability for ur loopback ip with & without admin distance @ the SP end via the respective WAN links.

regds

Re: NAT overload backup

Hi Praful,

sorry for making mistakes above.

The correct commands would be

ip nat inside source list 1 interface Serial0 overload

ip nat inside source list 2 interface Serial1 overload

access-list 1 permit any

access-list 2 permit any

Hope this helps

Martin

New Member

Re: NAT overload backup

Good day,

How about your issue ?

Best regards.

173
Views
8
Helpful
6
Replies
CreatePlease to create content