Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAT PAT routing problem

I have two dns servers, DNS1 goes out through ADSL router R1 (this is the firewall’s default route). DNS2 goes out through R2 ADSL Router (R1 send all the traffic from DNS2 to R2). R2 has only one public IP address so I’m doing NAT overload for browsing and PAT for udp 53 (dns). The firewall and R1 are using public IP addresses of R1, so no need to nat in R1.

If I’m outside of my bussiness and query my dns servers (nslookup), I have no problem with DNS1, but queries to DNS2 do  not work

Any help?

Important R2 configuration

interface Vlan1

ip address xxxx

no ip redirects

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

no cdp enable

ppp authentication chap pap callin

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static udp yyyy 53 interface Dialer1 53

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: NAT PAT routing problem

Hi

  Good to hear that's working.

Regards,

V Dinesh Kumar

6 REPLIES
New Member

Re: NAT PAT routing problem

Hi,

       Check the translation table whether your particular DNS ip gets translated.

Regards,

V Dinesh Kumar

New Member

Re: NAT PAT routing problem

yes the ip is translated

New Member

Re: NAT PAT routing problem

Hi

  Whats defined in source-list 1? Is it matching all the traffic? If so can you deny the particular DNS ip and check

Regards,

V Dinesh Kumar

New Member

Re: NAT PAT routing problem

Thanks, there is no effect, i have the same result

New Member

Re: NAT PAT routing problem

Sorry, It's working. Please reply me and I'll rate you correctly

Thank you very much

New Member

Re: NAT PAT routing problem

Hi

  Good to hear that's working.

Regards,

V Dinesh Kumar

686
Views
5
Helpful
6
Replies
CreatePlease login to create content